View Full Version : [ubuntu] Why is my xorg.conf empty?

David Jenkins
December 21st, 2008, 02:29 PM
I have just loaded 8.10 alternate onto an aged Toshiba Satellite laptop. As usual, the Ubuntu install didn't work out the correct resolution for the screen, so I tried to open xorg.conf to apply the usual fix (changing 24-bit colour to 16-bit), which has always worked in the past.

Unfortunately, this time /etc/X11/xorg.conf is an empty file - no text in it whatsoever.

Have things changed? Was there an install error?

Any clues would be appreciated!


December 21st, 2008, 02:33 PM
The X-Server in Intrepid and above is such that it makes as little use of xorg.conf as possible, in some cases(like yours) the xorg.conf file can be empty. But you can create and use an xorg.conf file. To do so, try booting Ubuntu in Recovery Mode and selecting xfix, then see if an xorg.conf file is created.

David Jenkins
December 21st, 2008, 03:38 PM
Ahh - I see. Is there a better way to set the colour to 16-bit? It would be nicer to stick to the original intent rather than revert to the bad old ways!

David Jenkins
December 21st, 2008, 05:47 PM
I'll answer my own question - I'll explore some of the official ideas mentioned in https://wiki.ubuntu.com/X/Config/Resolution.

cheers! :D