View Full Version : [ubuntu] How do I prevent xchat from autostarting?

December 18th, 2008, 07:04 AM
Hi All

I set xchat to autostart some while ago on my Gutsy machine, and can't remember how I did it. Now I want to turn it off and can't work out how to.

I have tried System > Preferences > Sessions, but xchat is not listed there.

I have also looked in ~/.config/autostart, but it is not listed there either.

I have searched for xchat in System > Preferences > Gnome Configuration Editor, but with no luck.

Where else might the setting be that autostarts xchat?

Any hints/pointers would be greatly appreciated.


Tim Sharitt
December 18th, 2008, 07:24 AM
Look in the ~/.gnome2 folder and see if there is a 'session' file. This is created when a gnome session is saved. You can delete this file, but any other startup programs saved here won't start on the next boot either unless they are in System > Preferences > Sessions.

December 18th, 2008, 09:49 AM
Thanks Tim

That's where it was hiding. I just deleted the entry relating to xchat, and updated the numbers of entries that followed, and now it is working great.