View Full Version : [ubuntu] Relative Noob - need help with wired connection

December 17th, 2008, 04:43 AM
So I'm having some rather odd problems...

First of all - the router and modem are definitely working. Every other computer connects just fine - wired or wireless.

My computer refuses to connect to the internet. It worked fine for the last 4 weeks. Before that, I had similar problems that just disappeared.

I've tried automatic DHCP settings, DHCP address only settings, and what I always use, manual settings.

Oddly enough, VMware running in Ubuntu can connect to the internet. I'm posting from an XP install from within VMware, so some form of virtual ethernet port is working. No applications running "in Ubuntu" connect though. I can, however, connect to the router's configuration page in Firefox.

I have no idea where to begin or how to fix this. Any help would be greatly appreciated.

December 17th, 2008, 06:26 AM
hey randalotto,
im quite new to ubuntu 2 but you could try this

open teminal (alt+F2) and type

sudo /etc/inted.d/networking restart

or do

ifconfig and fine network number should look like (eth0)

and the do

ipup (interface name here e.g eth0)

and that should work

Swat Leader
"team Move"

December 17th, 2008, 06:42 AM
just a small typo in above post, should be:

sudo /etc/init.d/networking restart

December 17th, 2008, 07:02 AM
just a small typo in above post, should be:

sudo /etc/init.d/networking restart

Thanks Small typo but would that be right???

December 17th, 2008, 10:34 PM
No go.

Tried restarting networking, (which I've done lots of times before,) and of course, it doesn't work.

Also, "ipup" isn't a recognized command...

December 17th, 2008, 11:41 PM
It's "ifup" not "ipup"

Can you ping websites? Try pinging google.ca

Also, try
nslookup google.ca

and see what happens.

December 18th, 2008, 01:24 AM
Trying ifup eth0 gives me
"ignoring unknown interface eth0=eth0"

Pinging gives me
"ping: unknown host google.com"

";; connection timed out; no servers could be reach"


December 18th, 2008, 03:06 AM
Uh-oh, not a good sign... I suspect ifconfig -a will show no (IPv4) address for eth0.

December 18th, 2008, 03:19 AM
Actually, everything looks good there (to me at least...)

I'm having troubles pasting it, but it shows:

inet addr: Bcast: Mask:
(then lots of other stuff...)

December 18th, 2008, 05:25 AM
Can you ping your own computer?


Also, try pinging your router's IP.

And can you post the results of
cat /etc/resolv.conf

December 18th, 2008, 05:37 AM
resolvconf was messing me up on this front - kept writing strange and useless info to /etc/resolv.conf. The 'puter had no way of doing a DNS lookup (even though the puter is running a DNS). I could ping other devices on the local network but nothing the other side of my router.

I uninstalled resolvconf, manually edited /etc/resolv.conf with something sensible (like a nameserver or two) and life is good.