View Full Version : [ubuntu] 3G Modem - Sony MD300

December 16th, 2008, 10:28 PM

I configured a Sony MD300 3G modem in my laptop 1, fresh install intrepid ibex all good. In my Laptop 2, (fresh install too) i did exactly the same but I cant get it work. any ideas?

here is what I did:

(and worked ok on my first laptop)

Create a file in /etc/udev/rules.d/:

#ACTION!="add", GOTO="3G_End"
#BUS=="usb", SYSFS{idProduct}=="1000", SYSFS{idVendor}=="0fd1", PROGRAM="/bin/sh -c 'echo 3 > /sys/%p/device/bConfigurationValue'"

ACTION!="add", GOTO="3G_End"
BUS=="usb", SYSFS{idProduct}=="d0cf", SYSFS{idVendor}=="0fce", NAME="modem" PROGRAM="/bin/sh -c 'echo 3 > /sys/%p/device/bConfigurationValue'"

now, create a file: /etc/wvdial.conf

[Dialer Defaults]
Modem = /dev/ttyACM0
ISDN = off
Modem Type = USB Modem
Baud = 460800
Init = ATZ
Init2 = AT+CFUN=1
Init3 = ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
Init4 = AT+CGDCONT=1,"IP","internet.tigo.py"
Init5 =
Init6 =
Init7 =
Init8 =
Init9 =
Phone = *99#
Phone1 =
Phone2 =
Phone3 =
Phone4 =
Dial Prefix =
Dial Attempts = 1
Dial Command = ATM1L3DT
Ask Password = off
Password = tigo
Username = tigo
Auto Reconnect = off
Abort on Busy = off
Carrier Check = on
Check Def Route = on
Abort on No Dialtone = on
Stupid Mode = off
Idle Seconds = 0
Auto DNS = on
;Minimize = off
;Dock = off
;Do NOT edit this file by hand!

Then I go to /usr/sbin/pppd
right click, I give permisson to all users to read write, and select
"allow executing file as a program" (pppd)

Now I go to Etc/ppp/peers I give permisson to all users to read write to all the files whitin the folder, and the same with the files pap-secrets and chap-secrets in etc/ppp

And voila, machine 1 connects, machine 2 I get this:

*using gnome-ppp in both, intrepid ibes, fresh install.

--> Ignoring malformed input line: ";Do NOT edit this file by hand!"
--> WvDial: Internet dialer version 1.60
--> Cannot get information for serial port.
--> Initializing modem.
--> Sending: ATZ
--> Sending: ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
ATQ0 V1 E1 S0=0 &C1 &D2 +FCLASS=0
--> Modem initialized.
--> Sending: ATM1L3DT*99#
--> Waiting for carrier.
~[7f]}#@!}!}!} }9}#}%B#}%}(}"}'}"}"}&} } } } }%}&X*}3cD7~
--> Carrier detected. Waiting for prompt.
~[7f]}#@!}!}"} }9}#}%B#}%}(}"}'}"}"}&} } } } }%}&X*}3c[08]Z~
--> PPP negotiation detected.
--> Starting pppd at Tue Dec 16 18:24:00 2008
--> Pid of pppd: 7832
--> Disconnecting at Tue Dec 16 18:24:01 2008
--> The PPP daemon has died: pppd options error (exit code = 2)
--> man pppd explains pppd error codes in more detail.
--> I guess that's it for now, exiting
--> The PPP daemon has died. (exit code = 2)

Please help ! dunno what to do anymore. Im stuck. I readed other posts but why works in one machine and not in the other? *same modem

December 16th, 2008, 11:38 PM
I know this may sound crazy but did networkmanager not work for you, i have a huwaei 3gmodem and after a bit of setup it worked fine.


December 16th, 2008, 11:48 PM

I tried to config Network manager, Mobile Bradoband TAB, fill the blanks but I cant connect neither, the icon gets blue, spinning then nothing. I dong get any log or error.

December 17th, 2008, 05:51 PM
One thing do these modems get PC specific, if you load it onto one laptop, will it only work in that one until you unregister it or will they just work any where, never had to try so just a thought.


December 18th, 2008, 12:59 AM
Yes, some do but this works ok in Vista and other machine with XP.

January 14th, 2009, 09:56 PM
Hello Mrwichtig

As the log you posted says

Ignoring malformed input line: ";Do NOT edit this file by hand!"

I suggest you to copy the files 50-md300modem.rules and wvdial.conf, using a pendrive or something, from the working laptop to the non working one.

Good luck!