PDA

View Full Version : [ubuntu] The Composite extension is not available



Oxidize
December 16th, 2008, 03:27 PM
Ok first off i have used search and looked into this but the info i found did nothing for me,


Section "Extensions"
Option "Composite" "Enable"
EndSection

Did not seem to work so other than posting here i have no idea what to do.

Anyway as the pasted config below shows, i use dual screens and i think this is the issue that compiz fails to work properly under it, im not sure if this can be fixed or if i will be forced to go to just one screen in order to gain the full visual effects.

Here is my xorg.conf

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings: version 1.0 (buildd@crested) Mon Nov 3 08:46:04 UTC 2008
# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# Note that some configuration settings that could be done previously
# in this file, now are automatically configured by the server and settings
# here are ignored.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "Monitor"
Identifier "Configured Monitor"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Unknown"
ModelName "Maxdata (RogenTech) Bel2225S1W"
HorizSync 30.0 - 84.0
VertRefresh 55.0 - 77.0
EndSection

Section "Monitor"
Identifier "Monitor1"
VendorName "Unknown"
ModelName "Maxdata (RogenTech) Bel2225S1W"
HorizSync 30.0 - 84.0
VertRefresh 55.0 - 77.0
EndSection

Section "Screen"
Identifier "Default Screen"
Device "Configured Video Device"
Monitor "Configured Monitor"
DefaultDepth 24
EndSection

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
Option "TwinView" "0"
Option "TwinViewXineramaInfoOrder" "CRT-0"
Option "metamodes" "CRT-0: nvidia-auto-select +0+0"
SubSection "Display"
Depth 24
EndSubSection
EndSection

Section "Screen"
Identifier "Screen1"
Device "Device1"
Monitor "Monitor1"
DefaultDepth 24
Option "TwinView" "0"
Option "metamodes" "CRT-1: nvidia-auto-select +0+0"
SubSection "Display"
Depth 24
EndSubSection
EndSection

Section "Module"
Load "glx"
Disable "dri2"
EndSection

Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0" 1680 0
Screen 1 "Screen1" LeftOf "Screen0"
EndSection

Section "Device"
Identifier "Configured Video Device"
Option "NoLogo" "True"
Driver "nvidia"
EndSection

Section "Device"
Identifier "Device0"
VendorName "NVIDIA Corporation"
BoardName "GeForce 8800 GTS 512"
BusID "PCI:1:0:0"
Screen 0
Driver "nvidia"
EndSection

Section "Device"
Identifier "Device1"
VendorName "NVIDIA Corporation"
BoardName "GeForce 8800 GTS 512"
BusID "PCI:1:0:0"
Screen 1
Driver "nvidia"
EndSection

Section "ServerFlags"
Option "Xinerama" "1"
EndSection

Section "Extensions"
Option "Composite" "Enable"
EndSection

Oxidize
December 16th, 2008, 04:47 PM
Fixed with help from the ubuntu-uk IRC channel, went from seperate x to twin view.