PDA

View Full Version : [xubuntu] [SOLVED] X starts in failsafe mode when no monitor is attached.



Memfis
December 16th, 2008, 02:05 AM
Hi,

I'm familiar with debian and have been running it as a server OS for many years. I took the leap and setup an Xubuntu 8.10 server.

The problem I have is that when no monitor is plugged in locally X starts in failsafe mode.

I want to run this as a headless box which I will vnc into.

What is the best way to prevent X starting in failsafe mode when no monitor is detected?

How can I prevent X or whatever from checking if a monitor is attached?

Lastly I'd like to thank mschemerii in the irc chatroom for attempting to help me, and breaking his own install of X at the same time. I hope he's OK as I've not heard back in several hours.

[edit] I'm not sure if this should be in desktop or install section. Please feel free to move thread if I've done it wrong.

Memfis
December 16th, 2008, 02:12 AM
List of running X processes :

/usr/sbin/gdm --config=/etc/gdm/gdm-cdd.conf

xinit /etc/gdm/failsafeXinit /etc/X11/xorg.conf.failsafe with-gdm -- /usr/bin/X :0 -auth /var/lib/gdm/:0.Xauth -nolisten tcp vt7 -br -once -config /etc/X11/xorg.conf.failsafe -logfile /var/log/Xorg.failsafe.log

/usr/bin/X :0 -auth /var/lib/gdm/:0.Xauth -nolisten tcp vt7 -br -once -config /etc/X11/xorg.conf.failsafe -logfile /var/log/Xorg.failsafe.log

/bin/bash /etc/gdm/failsafeXinit /etc/X11/xorg.conf.failsafe with-gdm

zenity --warning --text <big><b>Ubuntu is running in low-graphics mode</b></big>\n\nThe following error was encountered. You may need\nto update your configuration to solve this.\n\n(EE) intel(0): No valid modes.?(EE) Screen(s) found, but none have a usable configuration.

Memfis
December 16th, 2008, 02:42 AM
Sorry to keep replying to my own thread.

I've looked at the failsafe log and nothing jumps out.

Could I edit /etc/X11/xorg.conf.failsafe with some default values so that X starts ok?
Would doing this mean that when a monitor is plugged in the standard xorg.conf works, and when there's no monitor the failsafe settings take effect so that I can vnc to a working desktop?

louistan3
December 16th, 2008, 02:49 AM
I dont see why it would matter if the monitor is plugged in or not.

It shouldn't care if there is a monitor, maybe there's another problem? when you plug the monitor and boot, does it still go into failsafe?

someone who knows a bit better should reply. :S

Memfis
December 16th, 2008, 02:51 AM
Booting with a monitor plugged in starts X/gdm/xfce normally.
After which vnc works fine.

louistan3
December 16th, 2008, 04:15 AM
ooh, have you tried booting without the monitor then plugging it in after the boot up and seeing if its failsafe or not? check it locally cause it might only be on failsafe mode when on vnc.

Memfis
December 16th, 2008, 04:17 AM
If I boot without the monitor, then plug it in, xorg still runs in failsafe mode.
If I boot with the monitor plugged in, xorg starts normally and will continue when the monitor is unplugged until next reboot.

It's the boot time / xorg startup detection thats the problem.

Good night, back in 10 hours or so.

Memfis
December 16th, 2008, 04:29 PM
Adding driver=vesa to the device section allows X to start :

Section "Device"
Identifier "Configured Video Device"
Driver "vesa"
EndSection

We're getting there, now to figure out the VertRefresh & HorizSync for 1024x768*24 and where to put it in the xorg conf.

louistan3
December 17th, 2008, 03:12 AM
if i remember correctly, the new xorg system doesnt use the xorg.conf file anymore.

Can anyone clarify this?

louistan3
December 17th, 2008, 03:19 AM
i just found this..

https://help.ubuntu.com/community/XORGHardy

its about the new xorg.. its for hardy though.

Memfis
December 17th, 2008, 01:54 PM
[solved]

I'm sure that these settings aren't quite correct, but they seam to work for my vnc.

Section "Device"
Identifier "Configured Video Device"
Driver "vesa"
Option "NoDDCValue" "True"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
HorizSync 31.5-48.5
VertRefresh 50-70
EndSection

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
DefaultDepth 24
SubSection "Display"
Depth 24
Modes "1024x768"
EndSubSection
EndSection

Raptus_
March 22nd, 2009, 02:38 PM
Hi,

Just wanted to say that I had the exact same problem til my Ubuntu file-server that also did not have any monitor attached.

The solution over worked great! I just replaced the existing "device", "monitoring" ++ config's and that was that:D

thanks!

Hyper WD
June 21st, 2009, 09:56 PM
I just wanted to add that I 've been trying to find a solution to this for the past 3 days for my Linux Mint box when I finally stumbled on this post purely by accident. Solved the problem completely. Kudos to Memfis for the solution.

Works beautifully.

Thanks a lot!:D

pfunkman
July 10th, 2009, 08:11 AM
[solved]

I'm sure that these settings aren't quite correct, but they seam to work for my vnc.

Section "Device"
Identifier "Configured Video Device"
Driver "vesa"
Option "NoDDCValue" "True"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
HorizSync 31.5-48.5
VertRefresh 50-70
EndSection

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
DefaultDepth 24
SubSection "Display"
Depth 24
Modes "1024x768"
EndSubSection
EndSection

Perfect, there are about a dozen threads on a few different sites about the same issue and i literally stumbled on this trying to fix it and it works.

:guitar:

mike16889
August 10th, 2009, 11:38 AM
thanx man, setting up an ubuntu fileserver/php test server/media center and haveing trouble with it booting headless, i want to just plug it into power and thats it, connected to network via wireless N card and this problem has rly held me up, will try your config and see if it works.

Endymion_hu
August 11th, 2009, 11:05 AM
Hi,
I had the same problem but I have an intel graphics card and this solution didn't work.
For the intel driver the DDC option is different.
The working solution is:

Section "Device"
Identifier "Configured Video Device"
Driver "intel"
Option "DDC" "False"
EndSection

mike16889
August 13th, 2009, 10:49 AM
thanx man ur config did work, thanx alot.

zzeroo
August 20th, 2009, 07:03 AM
*big thump* great work. Saves my day, too.

MIKE SILVA
September 7th, 2009, 06:19 PM
Hi,

For me doesn't work.
Any help please. The system stops on the screen:

Ubuntu is running in low-graphics mode.
(EE) Intel(0): No valid modes
(EE) Screen(s) found but none have a usable configuration.

I don't have connected a monitor when system boot, only after a few minuts i connect i see this message.

My xorg.conf is:

Section "Device"
Identifier "Configured Video Device"
Driver "intel"
Option "DDC" "False"
EndSection
Section "Monitor"
Identifier "Configured Monitor"
HorizSync 31.5-48.5
VertRefresh 50-70
EndSection

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
DefaultDepth 24
SubSection "Display"
Depth 24
Modes "1024x768"
EndSubSection
EndSection



Any sugestion? If I write "vesa" for the driver, the system works, but the resolution is 640 x 480 and don't accept other.

Waiting for help, please!

MIKE SILVA
September 7th, 2009, 06:21 PM
Forgot to add,

My computer is a Dell Intel 82845 G/GL.

With monitor is perfect, no problem. But I need to work withou monitor. Accessing by VNC.

TinkerJ
September 26th, 2009, 11:21 PM
I too have:

00:02.0 VGA compatible controller: Intel Corporation 82945G/GZ Integrated Graphics Controller (rev 02)

I need X to start without a monitor attached because the primary use is x11vnc.

But I think I need to use the intel driver because I have a secondary output running to projector for playing vids, and need video acceleration.