View Full Version : [ubuntu] 8.10 no sound...

December 15th, 2008, 09:53 PM
I just did a fresh install of Intrepid on my system76 GazP3 that I bought 2 years ago, and there is no sound! I followed some directions on a few different threads that dealt with issues of alsa and pulse, but nothing worked. Tried running the driver-- no beans.

I was a bit late to upgrade my machine-- did I miss a memo on how to make it work? any help is appreciated, thanks,


December 15th, 2008, 10:20 PM
Acouple quick quotes from here might help http://ubuntuforums.org/showthread.php?p=4928900

Note 1. Intrepid users: due to a bug in the ALSA libraries, your PCM mixer may occasionally become muted or reset to 0% volume. If you cannot hear sound - or hear a faint crackling - refer to Part C, Step 3.

3. Ensure that your sound card's PCM mixer is not muted or set to 0% volume (this appears to be a bug in Intrepid):


$ alsamixer -Dhw

Note: When the PulseAudio ALSA plugins are active, you must explicitly specify your hardware device in alsamixer (marked in blue above), otherwise it will open the PulseAudio mixer.
Maybe this will help.

February 2nd, 2009, 02:53 AM
Hi there Astro!
I have an almost identical situation. I have a gazp3. Sound worked fine under Hardy 32 bit, but has not worked since I upgraded to 64 bit Hardy.
I recently did a fresh install of Intrepid 64 bit and still no sound. I notice that you haven't responded to 2hot6ft2's suggestions... did they fix the problem?

Will attempt them and update this thread with the result.

February 2nd, 2009, 04:37 PM
Sound definitely works on the GazP3.

Make sure you have installed *and* ran your System76 Driver...

To install the System76 Driver, navigate to http://planet76.com/repositories and download the latest .deb package. It will be the one closest to the bottom of the page. Save the package to your Desktop and, when it has finished downloading, double-click it to launch the Gdebi installer. Then, click the install button.

Once the package has installed, you can open the System76 driver by going to System > Administration > System76 Driver. To install the drivers for your machine, Click the "Install" tab and the "Install" button. If you are restoring your machine to factory settings, Click the "Restore" tab and the "Restore" button.

When the driver has finished running, reboot your computer.

And then, make sure all of your audio channels are opened and set...

First, run your System76 Driver (System > Administration > System76 Driver > Install Tab > Install Button) and reboot your computer.

Second, double-click on the speaker icon in the upper right corner of your screen. In the resulting Sound Control Panel, go to Edit > Preferences. (If you are using Ubuntu 8.10, you will have to click the Preferences button.) Make sure all available checkboxes have been selected. This will make more sliders available on the sound control panel. On the sound control panel, make sure that PCM, Master and Front (or whatever combination of these you have) are not turned down too low or muted.

Third, go to System > Preferences > Sound. Make sure all drop-down selectors are set to ALSA. (If you are using Ubuntu 8.10, make sure all of them are set to Pulse Audio instead.) Click the first Test button to see if you now have sound.

Pay attention to the Pulseaudio part.

February 3rd, 2009, 05:06 AM
Hmmm... doesn't appear to have worked. I'm reasonably sure I followed your instructions verbatim.

I have the January, 7 2009 system76 driver. I ran "restore system" and rebooted. The screen shot should show that the volume-control and sound preferences are as specified.

I've attached the system76 driver log, a screen-shot that shows the volume control preferences and the sound preferences, and a file with the output of some standard diagnostics:
uname -a
lsb_release -a
lsmod | grep -iEe"snd"
sudo lshw -C sound

Is there other information I should post?

February 3rd, 2009, 04:49 PM

Thanks. On the older Gazelles, there is a tricky setting that you need to adjust. Under the "Switches" tab of your volume control, there may be a checkbox for "Amp", "Ext" or "Ext Amp".

That either needs to be selected or deselected for the sound to work (I don't remember which, but I think it supposed to be de-selected).

If that checkbox is not present, check and uncheck the ones that are there, and it should appear.

Everything else on your set-up looks good. You might want to turn up your master and PCM a bit, though.

By the way, the PCM is actually the amplifier for your system. The other volume settings typically are relative to the PCM. It's not a good idea to turn the PCM all the way up on older Gazelles. 3/4 of the way up should be sufficient.

February 3rd, 2009, 06:41 PM
That WAS it!!! Thanks! Wow... what a tricky little bit to flip.

February 3rd, 2009, 06:54 PM
That WAS it!!! Thanks! Wow... what a tricky little bit to flip.

You're welcome. That's a ridiculous default setting.

March 4th, 2009, 06:31 PM
Thank you for this solution. It worked on my Toshiba Tecra M3. Crazy.

May 3rd, 2010, 06:52 AM
cheers that worked a treat for me in lucid lynx