PDA

View Full Version : [ubuntu] Cannot get full resolution after install



civillian
December 15th, 2008, 01:48 PM
ust last night I installed a copy of ubuntu 8.10 from a magazine cover-disc and it installed fine (after a few worries about my hard drive, but thats another story).
This morning when I tried to install the nvidia drivers for my card with envyNG it all went a bit wrong.
First off I tried to install the drivers using envyng -g which didn't work and left me in the CLI. I rebooted to safe mode and found out that the gtk front-end for envyNG was buggy, so I tried again using the Qt front-end. This left me with a workable system again but only at the resolution of 400x300.

I went to the ubuntu driver manager and it said that I was using the latest nvdia driver which was not the recommended one, so I installed and activated the reccomended one from the ubuntu driver manager and now I'm stuck in 1024x768 and unable to use the full resolution of my monitor which is 1280x1024.

Can anyone shed any light on this issue?

My xorg.conf file reads as follows

# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# Note that some configuration settings that could be done previously
# in this file, now are automatically configured by the server and settings
# here are ignored.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "Monitor"
Identifier "Configured Monitor"
EndSection

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
DefaultDepth 24
EndSection

Section "Module"
Load "glx"
EndSection

Section "Device"
Identifier "Configured Video Device"
Driver "nvidia"
Option "NoLogo" "True"
EndSection

Thanks in advance!

albinootje
December 15th, 2008, 01:52 PM
Can you check in a terminal :
xrandr -q

civillian
December 15th, 2008, 01:55 PM
civint@civint-desktop:~$ xrandr -q
Screen 0: minimum 320 x 240, current 1024 x 768, maximum 1024 x 768
default connected 1024x768+0+0 0mm x 0mm
1024x768 50.0*
800x600 51.0 52.0 53.0
680x384 54.0 55.0
640x480 56.0
512x384 57.0
400x300 58.0
320x240 59.0


thats the result of xrandr -q

albinootje
December 15th, 2008, 02:21 PM
Hmm, the only thing i can think of now, is to look up the details of your monitor, and to try an online ModeLine generator.

http://xtiming.sourceforge.net/cgi-bin/xtiming.pl

And then copy the resulting ModeLine in the relevant section of /etc/X11/xorg.conf

civillian
December 15th, 2008, 02:52 PM
where would the relevant section be?

albinootje
December 15th, 2008, 03:00 PM
Here's an example :
http://www.simplehelp.net/2008/05/29/how-to-increase-the-screen-resolutions-available-to-ubuntu-804-hardy-heron-while-running-in-parallels-desktop/

In case you're using Intrepid / 8.10 then you're xorg.conf will be pretty bare boned. Just copy the section like in the example, and edit it accordingly so that basically only your new ModeLine will stay there.

civillian
December 15th, 2008, 03:06 PM
if I edited the example given (for 8.04) to give the max resolution I wanted, would it still work with 8.10?

albinootje
December 15th, 2008, 03:15 PM
if I edited the example given (for 8.04) to give the max resolution I wanted, would it still work with 8.10?

You basically would end up with something like this :

Section "Monitor"
Identifier "Configured Monitor"
HorizSync 28-40
VertRefresh 43-60
modeline "1280768@75" 102.98 1280 1360 1496 1712 768 769 772 802
EndSection

Where the only modeline would be the modeline that you've produced.
You can just try it.

HTH

civillian
December 15th, 2008, 03:26 PM
I tried it with the modeline

Modeline "1280x1024@50" 90.89 1280 1312 1656 1688 1024 1045 1054 1076

then restarted my x session (ctrl alt backspace) and nothing changed...any ideas?

albinootje
December 15th, 2008, 03:31 PM
Can you put the 1280x768 in the Section "Screen" ?

For example like this :

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
Modes "1280800@75"
EndSection

civillian
December 15th, 2008, 03:55 PM
---disregard this post---

civillian
December 15th, 2008, 04:11 PM
I used the nvidia tool that came with the drivers to edit my xorg.conf, so it now reads like this

# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings: version 1.0 (buildd@palmer) Mon Nov 3 08:46:46 UTC 2008

Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "type1"
Load "freetype"
Load "glx"
EndSection

Section "ServerFlags"
Option "Xinerama" "0"
EndSection

Section "InputDevice"
# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
# generated from default
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "Monitor"
# HorizSync source: builtin, VertRefresh source: builtin
Identifier "Monitor0"
VendorName "Unknown"
ModelName "CRT-0"
HorizSync 28.0 - 55.0
VertRefresh 43.0 - 72.0
Option "DPMS"
EndSection

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce 8400 GS"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
Option "TwinView" "0"
Option "TwinViewXineramaInfoOrder" "CRT-0"
Option "metamodes" "1024x768_60 +0+0"
SubSection "Display"
Depth 24
EndSubSection
EndSection



however I still can't get the resolution any higher than 1024x768 :(
I tried adding another metamode, but that crashed the xserver when I restarted and it forced the session to run in low graphics mode.

albinootje
December 15th, 2008, 04:34 PM
however I still can't get the resolution any higher than 1024x768 :(
I tried adding another metamode, but that crashed the xserver when I restarted and it forced the session to run in low graphics mode.

Sorry to hear that :(

This specific nvidia driver forum might be a good place to ask for help :
http://www.phoronix.com/forums/forumdisplay.php?f=20

GL!