View Full Version : [ubuntu] Sudo Firefox

December 15th, 2008, 12:02 PM
i've been unable to navigate firefox properly for a few days, ie can't move backwards or forwards, the keys are greyed out. i discovered if i run firefox with sudo then i regain the navigation keys. i've also noticed i can't change my system settings, tell a lie i can for about a second then the settings revert back. i guess it's some permissions issue.

December 15th, 2008, 12:34 PM
make sure you own your .mozilla file and you have access write access to the programs folder.

December 16th, 2008, 04:00 AM
If that happened to me, I would fire someone! LOL!

>root and internet DON'T go together!<

!Even saying root and internet in the same sentence is blasphemy!

That would be like *cough cough* Microsoft, with XP and earlier.

December 16th, 2008, 04:14 AM
It's probably a corrupted firefox profile.

December 16th, 2008, 05:11 AM
Step 1
Close Firefox completely

Step 2
Paste this command into the terminal (http://www.psychocats.net/ubuntu/terminal):
sudo chown -R $USER:$USER ~/.mozilla

Step 3
Start Firefox normally

Step 4
Never run the command sudo firefox ever. If you're using the Mozilla Firefox (not Ubuntu repositories Firefox), you can use the command
gksudo firefox to install updates.

For more information, read this:

December 23rd, 2008, 02:41 PM
Thanks Aysiu, that fixed it. I'm guessing it's a similar problem for my system settings any ideas how i chmod that

thanks again

December 23rd, 2008, 02:54 PM
Just do the same thing, but to your whole profile

sudo chown -R $USER *

The -R means recursive (so it goes into subdirs), the asterik matches every file and directory.

Stuff like this happens when you run programs as root. The thing is, root is a completely different user, not a different operating mode for the same user. So processes launched by root create files that are owned by root. and then you cannot access those files as your normal user.