PDA

View Full Version : [ubuntu] screen resolution



craigtrom
December 14th, 2008, 09:58 PM
hi everyone
im having a problem with my screen resolution.
whats happening is, the desktop environment is fine, everything fits on the screen, but when i open any application, that window is huge wont fit on the screen, cant click anything. i already tryed with the display settings i end up "losing" the screen was so big. but this only happen when i open a application even firefox.
my screen resolution at the moment is
any suggestion?
640x480 (4:3)
50 hz



thanks

chriskin
December 14th, 2008, 10:56 PM
why do you have such a low resolution?
the lower the resolution , the bigger everything seems to be

just choose a higher resolution and things might be better
if you can't choose anything higher than 640x480 , you might need to install the graphic card drivers or something

craigtrom
December 15th, 2008, 06:16 PM
thank you for the reply.

thats my only choice for resolution. but there used to be more choices but now there only that one.

chriskin
December 15th, 2008, 07:09 PM
what about the graphic card drivers?
are they installed?

if they are, try switching to another driver, there are usually more than one to choose from.

:popcorn:

craigtrom
December 15th, 2008, 08:58 PM
they are and in use. like the desktop is normal everything is normal size but when i open a application that windows is oversized cant even click the buttons have to use the keys shortcuts

chriskin
December 15th, 2008, 09:18 PM
i don't know then, sorry :S

:confused:

craigtrom
December 15th, 2008, 09:29 PM
thanks for your help.

happy xmas

samden
December 15th, 2008, 10:18 PM
What is your xorg.conf? If you post the "Device", "Monitor" and "Screen" sections of your xorg.conf we will know more about what we are dealing with. Use:

sudo gedit /etc/X11/xorg.conf and copy the relevant sections.
My "Screen" section is below.

Section "Screen"
Identifier "Default Screen"
Device "Configured Video Device"
Monitor "Configured Monitor"
SubSection "Display"
Modes "1024x768"
EndSubSection
EndSection
If under Modes you only have "640x480" listed, try changing it to:

Modes "1024x768" "800x600" "640x480"
Save that, log out and log back in again, see if you have more screen resolution options now.

craigtrom
December 17th, 2008, 07:06 PM
thank you for your reply, this is my screen.


# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# Note that some configuration settings that could be done previously
# in this file, now are automatically configured by the server and settings
# here are ignored.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "Device"
Identifier "Configured Video Device"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
EndSection

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
EndSection

samden
December 17th, 2008, 10:17 PM
Before we try editing anything manually, try running
sudo dpkg-reconfigure -phigh xserver-xorg as suggested in the xorg.conf file itself. Then restart X (log out and log back in again) and see if it has fixed itself.

If that doesn't work, run
lspci | grep VGA and post the result here. That will tell us what video card you have so we can make sure you are using the correct driver.

If dpkg-reconfigure didn't work, try editing the "Screen" section to read:
Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
SubSection "Display"
Modes "1024x768" "800x600"
EndSection Then log out, log back in again, see if you have more resolution options.

Before you edit the xorg.conf file yourself, make sure you back it up:

sudo cp /etc/X11/xorg.conf /etc/X11/xorg.conf.bckp
Then if it all turns to custard you can restore your old xorg.conf by running:

sudo cp /etc/X11/xorg.conf.bckp /etc/X11/xorg.conf

I had a similar issue recently, you may like to check out the discussion here:
http://ubuntuforums.org/showthread.php?t=1003102

andrea000
December 18th, 2008, 03:18 AM
I had about the same problem and someone on here told me about envy it will
let you pick your driver if you use a nvidia card only i thank.I don't know
if this helps but it may it did me.
here's the link to tell you more

http://albertomilone.com/nvidia_scripts1.html

samden
December 18th, 2008, 04:46 AM
Once you've posted the result of "lspci | grep VGA" we'll know what graphics card you have and whether or not envy (that andrea000 has suggested) will be helpful to you or not.

craigtrom
December 18th, 2008, 10:28 PM
thanks for the help must appreciated.


01:00.0 VGA compatible controller: nVidia Corporation NV34 [GeForce FX 5500] (rev a1)

after following the first advice, i have now a more options but a max of 800x600 (4.3) resolution. witch is much better.

the second advice went bad had to restore the previous file. but anyway its much better now.

thank you

craigtrom
December 18th, 2008, 10:33 PM
after editing the file, it went bad, backed up the file again and its like this:



Section "Device"
Identifier "Configured Video Device"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
EndSection

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
EndSection


thank you for all the help

carloshiga
December 19th, 2008, 01:03 AM
I have the same problem. My video card is a nVidia GeForce4 MX 4000. I disabled the nVidia driver because the resolution was awful (640x480). I edited my xorg.conf to add this



SubSection "Display"
Modes "1024x768"
EndSubSection


but it doesn't work. Today I was trying to use xrandr to fix the problem but I got no success. I don't know why this happens. When I was using Kubuntu 8.04 everything was working just fine.

67GTA
December 19th, 2008, 01:16 AM
Just out of curiosity, does anyone having trouble with the nvidia driver have a Hauppauge TV tuner? The module for the card has a driver in kernel 2.6.27 that keeps the nvidia driver from loading. Open a terminal and see if
lsmod | grep cx18 returns anything. If it does, I can help you with your resolution problem.

andrea000
December 19th, 2008, 05:23 AM
thanks for the help must appreciated.


01:00.0 VGA compatible controller: nVidia Corporation NV34 [GeForce FX 5500] (rev a1)

after following the first advice, i have now a more options but a max of 800x600 (4.3) resolution. witch is much better.

the second advice went bad had to restore the previous file. but anyway its much better now.

thank you

Sorry craigtrom for the bad advice i am new to to linux i have a nvidia card as well and the first driver i picked also went bad so i ran it again and picked a different driver and it worked.Sorry

Andrea

andrea000
December 19th, 2008, 06:13 PM
craigtrom i am soo so sorry i am new to this linux stuff i never meant to give you bad advice.I had a problem like the one you have and someone on here told me about envy and
it fixed mine.like i said i am so sorry.

Andrea

craigtrom
December 19th, 2008, 08:14 PM
craigtrom i am soo so sorry i am new to this linux stuff i never meant to give you bad advice.I had a problem like the one you have and someone on here told me about envy and
it fixed mine.like i said i am so sorry.

Andrea







thats ok, im new to ubuntu aswell, still trying to learn how to work it.

thank you, and happy holidays

samden
December 20th, 2008, 02:58 AM
I'll be clear I'm not that experienced with Linux either,I have been using Ubuntu full time for only 6 months. I'm coming from it from the same place you are, just a couple of months further down the line! So I can only offer advice based on my own problems and what I have learnt through them.

I am glad that my initial advice brought you up to 800x600, but that is still a nasty resolution to try and use much. Try (after backing up of course!) editing your xorg.conf to read:
Section "Device"
Identifier "Configured Video Device"
Driver "nvidia"
EndSection
Section "Screen"
Identifier "Default Screen"
Device "Configured Video Device"
Monitor "Configured Monitor"
SubSection "Display"
Modes "1024x768" "800x600"
EndSubSection
EndSection and see if that helps at all. If no improvement, try editing the "Monitor" section (while keeping the rest as above) to:
Section "Monitor"
Identifier "Configured Monitor"
HorizSync 30 - 50
VertRefresh 50 - 75
EndSection
That should slow down the refresh rate which may allow it to cope with a higher resolution.