PDA

View Full Version : [ubuntu] Strange wide screen problem



Ape3000
December 13th, 2008, 07:59 PM
I got a new Acer P221w 22" 16:10 monitor and an old CTR monitor. I also have Ubuntu Intrepid and GeForce 7950 GT. There is a weird problem with the new wide screen monitor. At random cycle the screen will split and go nuts. (See the screen shot).

First I though that it's a problem cause by the monitor, but I think it might caused by X or the graphics card. Then I was sure that it's about handling wide screen resolutions, but it seems to be with the DVI cables or DVI handling by graphics card / X-server. What makes it even weirder is that mouse moves just like it should. So it can go over that black "wall". All windows can be moved from the left side to the right part by moving them out of the screen's left border.

When I take a screen shot it looks just fine. I edited the screen shot so it looks just like I see it. The problem can be fixed by changing resolution back and forth.

EDIT: I use the proprietary drivers for the graphics card. The resolution is 1680x1050.

EDIT2: The problem isn't with the resolution. The problem happens when I use DVI cables. Everything works fine with analog cables.

Ape3000
December 24th, 2008, 07:08 PM
It also happens with Samsung SyncMaster T220 and 1680x1050 resolution.

namdung
December 24th, 2008, 09:56 PM
Try
http://ubuntuforums.org/showthread.php?t=1018633

Ape3000
December 25th, 2008, 12:04 AM
Try
http://ubuntuforums.org/showthread.php?t=1018633

I don't see the similarity with that one. All the resolutions are working perfectly except this thing. It brakes the screen every hour or something like that.

EDIT: I pasted my xorg.conf. It might help solving this.


# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings: version 1.0 (buildd@palmer) Mon Nov 3 08:46:46 UTC 2008

Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
EndSection

Section "Files"
EndSection

Section "Module"
Load "dbe"
Load "extmod"
Load "type1"
Load "freetype"
Load "glx"
EndSection

Section "ServerFlags"
Option "Xinerama" "0"
EndSection

Section "InputDevice"
# generated from default
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"
# generated from default
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "Monitor"
# HorizSync source: edid, VertRefresh source: edid
Identifier "Monitor0"
VendorName "Unknown"
ModelName "Samsung SyncMaster"
HorizSync 30.0 - 81.0
VertRefresh 56.0 - 75.0
Option "DPMS"
EndSection

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce 7950 GT"
EndSection

Section "Screen"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
Option "TwinView" "0"
Option "metamodes" "1680x1050_60 +0+0"
SubSection "Display"
Depth 24
EndSubSection
EndSection

Ape3000
December 25th, 2008, 05:10 PM
I also tried fresh xorg.conf. It did not help. Here is the new one:

# xorg.conf (X.Org X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# Note that some configuration settings that could be done previously
# in this file, now are automatically configured by the server and settings
# here are ignored.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce 7950 GT"
EndSection

Section "Monitor"
Identifier "Configured Monitor"
ModelName "Samsung SyncMaster"
EndSection

Section "Screen"
Identifier "Default Screen"
Monitor "Configured Monitor"
Device "Configured Video Device"
EndSection

stovicek
December 25th, 2008, 06:36 PM
I have an Acer AL2216W and a nVidia GeForce 7900 GTX set at 1680x1050 with no issue running Ubuntu Intrepid. I do have the newest nvidia-glx-177 driving the card rather than the nvidia-glx-173. You didn't specify which one you were using, but I would trying switching to one or the other at least temporarily to see if that is the case. You can also install nvidia-settings which would give you a gui utility for configuring the drivers that may help resolve your problem.

These are only ideas as I have not encountered the problem that you're currently experiencing.

Ape3000
December 28th, 2008, 11:57 AM
I do have the newest nvidia-glx-177 driving the card rather than the nvidia-glx-173.

I do have nvidia-glx-177.

Ape3000
December 28th, 2008, 05:22 PM
Now I tested also with 173-drivers, but I didn't notice any difference. The screen is still going crazy.

Ape3000
December 29th, 2008, 10:31 PM
I found out that every time this bug happens, I get the following message to my syslog:

Dec 29 23:28:29 ape-desktop acpid: client connected from 5406[0:0]

I tried disabling acpid. The message didn't show up anymore, but it didn't fix the problem.

stovicek
December 29th, 2008, 10:46 PM
Does your /var/log/acpid file show anything for that timestamp?

Ape3000
December 30th, 2008, 11:24 AM
Does your /var/log/acpid file show anything for that timestamp?

The last lines on /var/log/acpid are from Oct 24.

Ape3000
December 30th, 2008, 03:54 PM
I think there is no problem when using analog cables. Usually I use digital DVI. I need to verify whether the analog cable is working. At least it has worse image quality, so that's not the solution.

Ape3000
December 30th, 2008, 11:32 PM
I found a somewhat similar problem and tried few things, but it didn't helped.

http://ubuntuforums.org/showthread.php?t=133390

I still need help with this.

Ape3000
December 31st, 2008, 06:57 PM
I think there is no problem when using analog cables. Usually I use digital DVI. I need to verify whether the analog cable is working. At least it has worse image quality, so that's not the solution.

I tested analog cables for a quite long time and there was never any problems. The image quality is slightly better with DVI, so I hope that I could use it without problems.

Ape3000
January 1st, 2009, 12:43 PM
I found quite similar bug report: https://bugs.launchpad.net/ubuntu/+source/xserver-xorg-video-nv/+bug/286730