PDA

View Full Version : [ubuntu] Installing intel graphics...please help!



zct823
December 12th, 2008, 11:02 AM
hello,):P

i am user of ubuntu for couple of days. so i have learn on how to install packages. but i still in trouble and headache on how to installing graphics card driver for ubuntu gutsy...

i used mobile intel 945GM on my laptop, and right now my graphics card driver set as under experimental modesetting, which not so compatible for graphics. so i decide to change my graphics driver... then i tried to search at google, however, what i get is about graphics card ATI and NVIDIA, nothing for intel.

so, i decide to look at intellinuxgraphics.org, and they have tell on how to install from the scratch. however, as i am absolutely beginner, i cannot understand too much on that section...

can you all give me guide on how to install graphics card driver from scratch, which is suitable for me? ubuntu gives not graphics card driver for intel through software updates but available for ati and nvidia, which is need to search myself. any teaches from yours is very appreciated... thanks...

3rdalbum
December 12th, 2008, 11:36 AM
I'm not sure I understand what you want to do. Intel's graphics driver is open-source, and therefore is included with Ubuntu. You've got it already. Why do you need a different version? It would involve compiling it; and that's something a new user won't want to do.

zct823
December 12th, 2008, 11:50 AM
thanks for ur post, 3rdalbum..

oh, i forgot to say... sorry in advance... i may need to revert back my graphics card driver cause i cannot run any graphics intensive apps, including i cannot apply any desktop effects, which is say that like desktop could not enabled effects. or is anything i can do to revert back this problem?

please help... thanks...

3rdalbum
December 12th, 2008, 12:11 PM
Could you please post the contents of the file /etc/X11/xorg.conf

zct823
December 12th, 2008, 12:31 PM
Could you please post the contents of the file /etc/X11/xorg.conf

thanks for your reply, this is my xorg.conf at X11 folder.


# xorg.conf (xorg X Window System server configuration file)
#
# This file was generated by dexconf, the Debian X Configuration tool, using
# values from the debconf database.
#
# Edit this file with caution, and see the xorg.conf manual page.
# (Type "man xorg.conf" at the shell prompt.)
#
# This file is automatically updated on xserver-xorg package upgrades *only*
# if it has not been modified since the last upgrade of the xserver-xorg
# package.
#
# If you have edited this file but would like it to be automatically updated
# again, run the following command:
# sudo dpkg-reconfigure -phigh xserver-xorg

Section "Files"
EndSection

Section "InputDevice"
Identifier "Generic Keyboard"
Driver "kbd"
Option "CoreKeyboard"
Option "XkbRules" "xorg"
Option "XkbModel" "pc105"
Option "XkbLayout" "us"
EndSection

Section "InputDevice"
Identifier "Configured Mouse"
Driver "mouse"
Option "CorePointer"
Option "Device" "/dev/input/mice"
Option "Protocol" "ImPS/2"
Option "ZAxisMapping" "4 5"
Option "Emulate3Buttons" "true"
EndSection

Section "InputDevice"
Identifier "Synaptics Touchpad"
Driver "synaptics"
Option "SendCoreEvents" "true"
Option "Device" "/dev/psaux"
Option "Protocol" "auto-dev"
Option "HorizEdgeScroll" "0"
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "stylus"
Option "Device" "/dev/input/wacom"
Option "Type" "stylus"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "eraser"
Option "Device" "/dev/input/wacom"
Option "Type" "eraser"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "InputDevice"
Driver "wacom"
Identifier "cursor"
Option "Device" "/dev/input/wacom"
Option "Type" "cursor"
Option "ForceDevice" "ISDV4" # Tablet PC ONLY
EndSection

Section "Device"
Identifier "Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller"
Driver "intel"
BusID "PCI:0:2:0"
EndSection

Section "Monitor"
Identifier "Generic Monitor"
Option "DPMS"
EndSection

Section "Screen"
Identifier "Default Screen"
Device "Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller"
Monitor "Generic Monitor"
DefaultDepth 24
SubSection "Display"
Modes "1280x800"
EndSubSection
EndSection

Section "ServerLayout"
Identifier "Default Layout"
Screen "Default Screen"
InputDevice "Generic Keyboard"
InputDevice "Configured Mouse"

# Uncomment if you have a wacom tablet
# InputDevice "stylus" "SendCoreEvents"
# InputDevice "cursor" "SendCoreEvents"
# InputDevice "eraser" "SendCoreEvents"
InputDevice "Synaptics Touchpad"
EndSection

anything ruins above? any helps are appreciated... thanks...

Nepherte
December 12th, 2008, 01:06 PM
As you can see, you are already using the Intel driver:

Section "Device"
Identifier "Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller"
Driver "intel"
BusID "PCI:0:2:0"
EndSection

zct823
December 12th, 2008, 01:41 PM
As you can see, you are already using the Intel driver:

Section "Device"
Identifier "Intel Corporation Mobile 945GM/GMS, 943/940GML Express Integrated Graphics Controller"
Driver "intel"
BusID "PCI:0:2:0"
EndSection

oh i see, but why i cannot apply any desktop effects and any graphics intensive program? can give me methods to fix this problem? any helps are appreciated... thanks...

Nepherte
December 13th, 2008, 12:44 PM
Perhaps your graphics card is blacklisted by compiz (desktop effects), but I'm not sure of it. Don't know how to fix that.

scorp123
December 13th, 2008, 01:08 PM
i cannot run any graphics intensive apps Don't expect any 3D miracles from an Intel 945GM. If you need gaming hardware you should buy a laptop with at least a Nvidia 8400M or better.


i cannot apply any desktop effects It works out of the box, thanks to the Intel drivers being open source. You probably just have to reset your graphics settings to the defaults. Please see the other postings here.

druellan
December 13th, 2008, 01:11 PM
I'm using Intrepid on a 945gm hardware and it must work even if you delete your xorg.conf altogether. Try this:

- rename your xorg.conf to xorg.conf.bak -> restart X with ctrl+alt+backspace
- check what happens, and whathever the result you get, run this command on a terminal: sudo dpkg-reconfigure xserver-org. This will regenerate your xorg.conf

If nothing works, perhaps is a good time to try update drivers here http://packages.ubuntu.com/intrepid/xserver-xorg-video-intel

scorp123
December 13th, 2008, 02:23 PM
perhaps is a good time to try update drivers here http://packages.ubuntu.com/intrepid/xserver-xorg-video-intel Driver updates should happen automagically thanks to the "apt" manager. Either you get a notification when you login, or if you want to do it manually:
sudo apt-get update && sudo apt-get dist-upgrade ... if there are any updates they will be installed automatically. Manually installing drivers should not be needed here.

druellan
December 13th, 2008, 09:44 PM
scorp123, I'm sorry, you're totally right, drivers should be up-to-date, at least against Ubuntu's repos. I get confused reading an old Launchpad report. Thanks for the correction!