PDA

View Full Version : [ubuntu] [SOLVED] Thunderbird, gets a life!



jay li
December 12th, 2008, 05:53 AM
Every time I plug my eee pc to the power, Thunderbird opened by himself.
Any ideas what causing it?

Ubuntu 8.10
Asus Eee PC 701 4G Surf

P.S. No problem with Ubuntu 8.04

Ong
December 12th, 2008, 05:58 AM
It might be a startup program.To disable it, go to system> preferences>sessions.On the startup programs tab look for Thunderbird and uncheck it:confused:

jay li
December 12th, 2008, 06:05 AM
Thunderbird is not there.

lisati
December 12th, 2008, 06:09 AM
My copy of Xubuntu sometimes seems to remember what was running when I shut it down, and start them up again when I next boot Xubuntu - I usually get round this by manually closing any programs that I don't want automatically loaded before shutting it down (if I remember).

jay li
December 12th, 2008, 06:57 AM
Let me refresh my problem.

When my battery laptop is empty then I need to charge it, right?
Now if I plug the AC Adaptor to electricity then Thunderbird pop up.
I had this problem with evolution too, and it's drive me nuts.
So I removed it and install Thunderbird, thinking maybe I'll solve this nasty habit.
I think it's a bug on Ubuntu 8.10, cause on Ubuntu 8.04 it didn't happen.

misfitpierce
December 12th, 2008, 07:00 AM
It could be a bug... Did you try uninstalling thunderbird plug in eeepc then unplug then reinstall with it plugged in then try unplugging and replugging in?

jay li
December 12th, 2008, 07:09 AM
No, I did not.
But first let me see if I understand you.
Are you suggesting me to install thunderbird while my laptop is connected to the wall, and see what will happen?

Rhubarb
December 12th, 2008, 07:17 AM
This happens to me too on my eee PC S101 with Ubuntu 8.10
I haven't had much time recently to try and figure out what's going on.
Suffice to say I haven't even done a simple web search on it yet either.

If I discover anything before the solution is worked out here, I'll post a message here in this thread.

It's quite bizzare, when my eee PC is running off battery power, then connect the AC power cord up to it, it then opens up the default email application (which for me in this case is evolution).

jay li
December 12th, 2008, 07:22 AM
Thanks Rhubarb.

cariboo
December 12th, 2008, 07:34 AM
Have either of you tried System-->Preferneces-->Sessions-->Options
and chcecked to see if Automatically remember running apllcations when logging out is checked?

If it isn't, close all running applications then put a check mark in the above command, then shutdown and restart to see if Thunderbird or other applications opens at startup.

Jim

Aearenda
December 12th, 2008, 07:40 AM
It looks to me as though something triggered by the change in power status is starting the mail application. It's nothing to do with saved sessions or logging off and on. When you plug the power in the ACPI subsystem reports this and it can trigger changes, such as running a program. Unfortunately, I'm not familiar with Xubuntu so I can't suggest how to change this on your system.

mobilediesel
December 12th, 2008, 07:42 AM
Have either of you tried System-->Preferneces-->Sessions-->Options
and chcecked to see if Automatically remember running apllcations when logging out is checked?

If it isn't, close all running applications then put a check mark in the above command, then shutdown and restart to see if Thunderbird or other applications opens at startup.

Jim

It doesn't sound like a startup issue. I think he's saying that, if the computer is already powered up, the email application launches when he plugs it into AC power. The computer is already on and in use.

jay li
December 12th, 2008, 07:58 AM
Hi, cariboo907 I tried your suggestion but unfortunately nothing changed.

Rhubarb
December 12th, 2008, 08:10 AM
Looks like this is a known bug, see here:
https://bugs.launchpad.net/ubuntu/+source/hal-info/+bug/268422

I'm just about to try the solution that's mentioned there on mine.
I'll report my findings.

lisati
December 12th, 2008, 08:22 AM
It looks to me as though something triggered by the change in power status is starting the mail application. It's nothing to do with saved sessions or logging off and on. When you plug the power in the ACPI subsystem reports this and it can trigger changes, such as running a program. Unfortunately, I'm not familiar with Xubuntu so I can't suggest how to change this on your system.

I mentioned Xubuntu - I think the OP uses Ubuntu. Personally, I'm not overly bothered by the relatively minor inconvenience of having Thunderbird or whatever else was running sometimes being "remembered" when I restart my machine for whatever reason.... my own solution is to remember to shut down what I don't want active on restart, and to exerecise patience when I've forgotten.

Rhubarb
December 12th, 2008, 08:24 AM
To fix this:

Open up a terminal (Applications --> Accessories --> Terminal), and enter this in:

gksu gedit /etc/acpi/events/asus-mail
- You will need to enter in your password

Comment out the last two lines with a # in front, so it looks like this:

# /etc/acpi/events/asus-mail
# This is called when the user presses the mail button and calls
# /etc/acpi/hotkey.sh for further processing.

# event=hotkey (ATKD|HOTK) 00000050
# action=/etc/acpi/mailbtn.sh
Then save and quit gedit.

Now, restart the acpi service for changes to make effect (so you don't need to restart your netbook):

sudo service acpid restart

Then plug in your AC adapter, and the email application should not start up :D

- Rhubarb

jay li
December 12th, 2008, 08:26 AM
Looks like this is a known bug, see here:
https://bugs.launchpad.net/ubuntu/+source/hal-info/+bug/268422

I'm just about to try the solution that's mentioned there on mine.
I'll report my findings.

Thanks Rhubarb.

You know I tried google it several times, and I didn't find any mention about it.

jay li
December 12th, 2008, 08:35 AM
:D Finely this problem has been solved.

Thank you! Rhubarb.

jay li
December 12th, 2008, 08:42 AM
OK, since this has been solved do I have to make somthing, get this thread mark as "[SOLVED]"?

Rhubarb
December 12th, 2008, 09:19 AM
There should be a way to mark this thread as solved.
I'm not sure how as I mainly answer threads not create them :P

I did a google search for something like "intrepid power email evolution".

jay li
December 12th, 2008, 09:25 AM
Can't find it yet, but hi thanks man for everything. :D

capnthommo
December 12th, 2008, 10:45 AM
hi, dunno if you found it yet but to mark the thread solved look at the top and on the right there's atab for "thread tools" click there and there is an opdtion for mark thread as solved. hope that helps
cheers

jay li
December 12th, 2008, 11:00 AM
Thanks to you too, I just did.
BTW my name is jay li, remember that... ;-)

capnthommo
December 12th, 2008, 11:28 AM
oops, sorry to sound so off hand, jay li. best of luck
nigel

jay li
December 12th, 2008, 11:37 AM
Best of luck for you too, and thanks again capnthommo.

brokenLockpick
January 17th, 2009, 01:27 AM
Wow that was just the ticket Rhubarb. I was having the same problem on my 900a, thanks for the informative post.