PDA

View Full Version : [ubuntu] 8.10, default keyring can't unlock



madmaxnj
December 11th, 2008, 12:48 PM
I did an install of 8.10 and got my wired working and then switched to my wireless and got it working. I setup only one login and enabled autologin when installing ubuntu. I was surprised that it always asked for my admin password even though I think I'm logged in as admin.

Every boot up I get the window "Enter password for default keyring to unlock, the application nm-connection-editor wants access but it is locked." I cannot clear this window. Whatever I type in this window must be wrong because it just pops up again. Eventually it must time out and the wireless window would popup asking me for my WEP key.

I read some posts on this and tried to clear this but I must have made it worse, because now it doesn't prompt me for my WEP key. When I go to the Systems-Preferences-Network Configuration and enter my WEP key I get the keyring popup again and it doesn't connect.

when I go to System-Prefernces-Password and Encryption Settings, on the Encryption tab under the heading of Default Key there is an a pull-down menu but the only option selectable is "None. Prompt for a key." I've read in other posts to set the default keyring password to your user password here, but I don't even have the option.

I'm totally stumped. And yes, I am a total noob at Unbuntu, so please, the more detail the better.

Thanks

madmaxnj
December 11th, 2008, 06:36 PM
I think I figured out what I did to make the wireless completely dead now. When I was trying to figure out how to get it to save the WEP password I changed the name of the connection from its default (something like "wireless connection 1") to match the SSID. I'm guessing that was the killer. Somehere in the system it must be trying to use the old default name and I changed it here to a new name and they aren't connecting.

What is the default name again? I don't remember the exact syntax.

I still have the default keyring problem too if anybody can help. In looking through the forums it looks like most people still run 8.04.

Cris(c)
January 23rd, 2009, 09:04 PM
Same issue with the keyring menu here...

KayakJim
February 1st, 2009, 01:31 AM
This took care of the issue for me:
http://ubuntu-tutorials.com/2007/07/12/automatically-unlocking-the-default-gnome-keyring-pam-keyring/

sahabcse
February 21st, 2009, 08:51 AM
Hi

Try the following url

--------------------------------------
http://sahabm.blogspot.com/2009/02/default-keyring-cant-unlock-ubuntu-810.html
--------------------------------------

Regards,
Sahab