PDA

View Full Version : [ubuntu] How to remove the icons from Firefox buttons?



jay li
December 11th, 2008, 12:21 PM
Hello!

There is another post talking about "How can I remove all button icons?" (http://ubuntuforums.org/showthread.php?t=405453) and I would like to do it with Firefox buttons too?
I don't want to use another theme to get this result, I like the original one.
So it is impossible doing it?

Thank you guys.

Michael.Godawski
December 11th, 2008, 12:26 PM
Don't really know... but perhaps there is some hidden option to disable them. Type

about:config
into the url field, and check the entries provided there. But be careful, aks before changing something. :p

jay li
December 11th, 2008, 12:33 PM
Thanks Michael.Godawski I'm going to check your tip.

frank002
December 11th, 2008, 12:37 PM
Right click on the taskbar and click Customize. On the bottom left you will see where it gives you the options of icons and text, icons only or text only.

jay li
December 11th, 2008, 12:48 PM
Hi frank002,

Well I kind meant to the "Close" "Help" etc. Buttons like in this image:

Pappy1911
December 12th, 2008, 01:29 AM
Right click on the taskbar and click Customize. On the bottom left you will see where it gives you the options of icons and text, icons only or text only.

Just as Frank said.....works for me..

frank002
December 12th, 2008, 04:13 AM
I don't believe you can remove those. However, if someone knows of a way, I am sure he or she will post it. Good Luck.

jay li
December 12th, 2008, 06:01 AM
I am sure there must be a way.
If I could do that with Ubuntu GUI, Firefox must have this feature too.
The problem is I don't know how to do it.

jay li
June 12th, 2009, 04:57 PM
I am sure there must be a way.
If I could do that with Ubuntu GUI, Firefox must have this feature too.
The problem is I don't know how to do it.

To do it, open your hidden "userChrome.css" file in the path /home/USER_NAME/.mozilla/PROFILE_FOLDER/chrome/userChrome.css (if not exist, create one), and add the following rule:
/* Remove icons from buttons. */
button:not(#navigator-throbber) > .button-box > .button-icon {
display: none !important;
}