View Full Version : [ubuntu] Intrepid - Machine Switches Net Connections For No Apparent Reason

December 7th, 2008, 05:26 PM
I've got Intrepid set up with a couple of net connections - home, work. Work is set as the default. For some reason, while I'm at home, Intrepid switches from the home connection to the work connection on the fly for no apparent reason, while I'm working on the machine.


December 9th, 2008, 02:30 AM

December 9th, 2008, 02:37 AM

The default (work) connection is static. The alternate (home) connection is dynamic.

It's the dynamic connection that keeps reverting for some reason to the static one (while the dynamic connection is active, and operating).

It doesn't seem to do it at any particular time or for any particular reason.

December 9th, 2008, 03:02 AM
Curious - not the reply I expected. I've seen other threads with the opposite problem - DHCP kicks in and overrides the static settings. Since NM in Intrepid seems to have some issues with static addresses, that would have been expected.

How do you switch between the two?

December 9th, 2008, 05:20 AM
In the other cases, which is the default setting? Again, in my case, the static setting is the default.

I switch using the NetworkManager Applet 0.7.0.

Yes, the change takes, and the net works - until it gets flopped.

Tonight - no flip.

December 9th, 2008, 05:48 AM
I can't tell you what your specific problem is but maybe this (http://ubuntuforums.org/showthread.php?t=1004752) will shed some light.

You'll find it interesting too. I found the article the other day.

December 9th, 2008, 03:51 PM
It doesn't seem to do it at any particular time or for any particular reason.

Are you absolutely sure that this doesn't happen something close to after the same amount of time that the system has been connected?

Say, for example, about the same amount of time as the lease time the router hands out for the connection? At that point, software that was running to try and always keep a connection active might get confused. I'm just guessing but it's easy to test, configure your router for a longer (or shorter) lease time and see if the issue tracks with that change.

December 13th, 2008, 12:03 AM
I just had it happen again. I was screwing around, trying out Ekija Softphone. When I quit, and then exited the widget in the menu, the net immediately switched.