PDA

View Full Version : [all variants] Invalid Raid Superblock Magic



sam702
December 7th, 2008, 06:37 AM
Hello Ubuntu Gurus!

I get an "Invalid Raid Superblock Magic on sda1" error when I boot up.

I have...

ASUS P5Q-EM motherboard (Intel G45 Chipset)
Two identical sata drives on Software Raid 1
Bios setting is AHCI for the sata drives
Ubuntu Intrepid Ibex, Samba fileserver
Headless fileserver setup

I get the error message and it drops out of the shell. Sometimes when I wait awhile and reboot from the initramfs prompt it still gives me the "invalid raid superblock magic" error, but it still boots. When it does boots, I check the /proc/mdstat and it says every thing is good with the raid.

I made edits to the /boot/grub/menu.lst to include the rootdelay=90 on the kernel line, but I still run into the error.

I did apt-get update and upgrade and still the problem persists. How can I resolve this issue? Please help.

Thanks.

bthessel
February 15th, 2009, 02:45 PM
Hello Ubuntu Gurus!

I get an "Invalid Raid Superblock Magic on sda1" error when I boot up.

I have...

ASUS P5Q-EM motherboard (Intel G45 Chipset)
Two identical sata drives on Software Raid 1
Bios setting is AHCI for the sata drives
Ubuntu Intrepid Ibex, Samba fileserver
Headless fileserver setup

I get the error message and it drops out of the shell. Sometimes when I wait awhile and reboot from the initramfs prompt it still gives me the "invalid raid superblock magic" error, but it still boots. When it does boots, I check the /proc/mdstat and it says every thing is good with the raid.

I made edits to the /boot/grub/menu.lst to include the rootdelay=90 on the kernel line, but I still run into the error.

I did apt-get update and upgrade and still the problem persists. How can I resolve this issue? Please help.

Thanks.

Did you ever find a way to fix this? I am having the same problem.

fjgaude
February 15th, 2009, 03:38 PM
Hard to say what is causing this. I'd try adding a delay here:

Edit this file, adding the sleep line after the mount: /usr/share/initramfs-tools/init # to stop a race condition with md. The line numbers may not be the same for your system.


187 maybe_break mount
188 sleep 10
189 log_begin_msg "Mounting root file system..."
Then run this to rebuild the image


sudo /usr/sbin/update-initramfs -uk all

Let us know if this works.