PDA

View Full Version : [ubuntu] 8.10 upgrade causes random 20second freezes



andrewjb1234
December 7th, 2008, 12:20 AM
Ive had a weird situation since my upgrade from 8.04 to 8.10. I've tried everything i can think off, ive removed video drivers disabled my sound, removed all pulseaudio libraries, removed compiz and still no luck. Here are my symptons:

occasionally, for about 20-30seconds (doesnt matter what im doing) gnome will stop responding, it will still draw (ie, if i select items on desktop it still does that) but if i try to open a menu, or an application it wont do it until about 20-30 seconds later! however, when i run my cursor over objects (for example if i have awn open and run my cursor over an icon in it, it will force the graphic to continue its animation!) ... same for if im typing into a console whilst this momentary freeze is happening, if i press up to go to history-1 it wont show it, but if i move my cursor a little bit, it will update the display.

If i hit ctrl alt backspace, i drop back to the tty and it will hang there for around 20-30seconds and then load up xserver again...

ive tried going in as safe mode, disabling my wireless card, ... I've even looked through my process list to make sure nothing is eating 100% cpu, and its not!

I've been searching for a solution through forum and tried some of those suggestions also, but none of them have worked.

Andrew

inobe
December 7th, 2008, 01:10 AM
this sounds hardware related, i know you stated it happening after the upgrade, i agree that it is partially responsible.

i have had similar problems' but with other distributions !

one instance was my hdd was going... running some disk tools like seagates diskwizard pointed out disk inconsistencies .

another situation a year later, i needed to reset the cmos in the bios.

i would also use the memory tester from the live cd...

finally a bios update !

i would try all these steps one by one.

don't forget to check the release notes, look for the bugs that apply to your hardware or symptoms

http://www.ubuntu.com/getubuntu/releasenotes/810

cyberfin
December 7th, 2008, 05:38 PM
Hi there,

I've been having the same exact problem with an upgrade on my laptop. I read about it possibly being due to the swap being messed up and sure enough, it seems like ubuntu isn't using any swap whatsoever (checked by executing the free command).

This is very annoying and did not happen in previous distros. Any comments or pointers will be thanked.

andrewjb1234
December 7th, 2008, 10:31 PM
- upgrade was on an acer 5633wlmi laptop

and sure enough 0 swap is being used (via free) on mine as well - coincidence?

Andy

andrewjb1234
December 8th, 2008, 11:32 PM
i think ive 'fixed' the problem,

its to do with the nvidia 177 driver, u need to remove composite enabling from your xorg.conf - i think that solved it for me.

(that or removing apparmor from services) - going through and testing.

Andy

andrewjb1234
December 9th, 2008, 12:03 AM
I disabled the restricted modules under rcconf as well as apparmor and no more temporary lockups =)

cyberfin
December 9th, 2008, 10:07 AM
Thanks a bunch for the advice. I'll try it when I get home tonight and post the results.

andrewjb1234
December 20th, 2008, 08:06 PM
ok, the above didnt fix it for me it came back after a day or so, after some long investigation i realised the problem was actually in a acerhk driver, ( its a hotkey driver for acer laptops ) ... by rmmod acerhk - i was able to stop the occasional gnome slowdowns .. and it wasnt a hardware fault.

Andy

cyberfin
December 20th, 2008, 09:09 PM
Mine was solved through updating, disabling compiz, re-enabling it and a host of other things that I can't remember anymore, but it was all graphic orientated. Seems like gnome is to blame because I did not get this reaction in kde, which i installed to try as well.

Good luck.