View Full Version : [ubuntu] file /boot/grub/stage1 not read correctly

December 5th, 2008, 10:41 AM
Well, basically I screwed my ubuntu instalation. I resized 2 partitions and then I rebooted, but grub was not loading and giving error 17. I booted the Live CD and tried reinstalling grub, but every attemp resulted in "file /boot/grub/stage1 not read correctly". Any idea how can I get it to work again?

Ps: I tried to fix the boot using the SuperGrub live cd, but it didn't work. At least I've got to boot my windows partition lol.

December 5th, 2008, 03:45 PM
OK, how about booting your Live CD, open a terminal (Applications > Accessories > Terminal) and post the output of:

sudo fdisk -lu
From the above output, determine which is your Ubuntu partition in the form sdXY (like sda2 or similar) by noticing which partition is "linux" under the "system" category, and then use that as follows:

sudo fsck -y /dev/sdXY
And please post the results. If that completes successfully then also post:

sudo grub
grub> find /boot/grub/stage1
grub> find /grub/stage1
grub> quit