View Full Version : [ubuntu] [SOLVED] No Keyboard After Suspend

December 5th, 2008, 04:41 AM
Hello, After I resume from suspend my usb keyboard just flashes continuously and is totally unresponsive, all I can do is reboot.

How can I get my keyboard to work after suspend ?


December 5th, 2008, 07:01 AM
No keyboard after 30 minutes of hibernate as well .

December 5th, 2008, 08:13 AM
I have found many posts of this same problem with previous versions, gutsy etc, but can't find any fixes for Intrepid.

December 5th, 2008, 10:46 AM
Does any one know why my keyboard will not work after suspend/hibernate, it is just a usb keyboard, nothing special, not a wireless.

December 5th, 2008, 08:47 PM
I have all new hardware, would a reinstall help, is the iso download the latest, does it have all the updates ?

December 6th, 2008, 05:13 AM
On another forum (I'm trying to find the answer everywhere) someone suggested this losing keyboard after suspend/hibernate problem is a Intrepid Ibex bug, but I have searched the bugs and can find no mention,
So I sincerely hope this means there is a fix ???

December 7th, 2008, 05:02 AM
I solved this with help from another forum - http://forums.whirlpool.net.au/ linux/bsd

I learnt plugging my keyboard into a hub, lets it still work after suspend.

Thank You

December 23rd, 2008, 02:59 AM
solved for desktop users.

January 24th, 2009, 09:28 AM
Further details, or an actual link...

March 4th, 2009, 03:52 PM
I have the same problem. I think Rodney and I have the same kind of keyboard, a Logitech Illuminated Keyboard.

I've found out that the keyboard works great after resume if you unplug it and then reinsert it again. After resume and without unplugging it, it just sits there flashing as Rodney described. In dmesg there's a lot of these messages:
[ 2266.228115] usb 2-1: reset full speed USB device using uhci_hcd and address 3

These messages stops after reinserting the keyboard. Full dmesg of the suspend process attached.

March 4th, 2009, 06:24 PM
Problem solved, I think. I used the method described here: http://people.freedesktop.org/~hughsient/quirk/quirk-suspend-advanced.html

Created the file
/etc/pm/config.d/unload_modules with the content

This unloads the full speed USB module before suspending, and it seems to be working. Have tried suspending a couple of times and the keyboard works directly. Dmesg attached.

July 5th, 2009, 06:13 PM
has anyone figured out howto get it working on jaunty, without having to reattach the usb connector every time?

November 24th, 2009, 07:51 PM
How can this be solved if the solution is to unplug the keyboard, what if (in my case) you had a laptop, i had to open it to unplug it... so fix this already in 9.10 and no fix?? come on....

November 24th, 2009, 08:10 PM
Even in the bug report canonical has given up. It seems fairly obvious that this is not considered an important part of the user experience.

The solution for laptop users is to suspend twice. So I have gnome set to suspend when the laptop lid is closed. I have to close the lid, wait for the system to suspend, open the lid, wait for the system to come out of suspend, close the lid again, wait for the system to suspend, and then open the lid again and use my computer. In karmic we are down to a 20% Kernel Panic on the second resume!

(The real solution is for someone at canonical or the kernel development team to become passionate that this is a user experience issue and work to get the code fixed. This issue has existed in at least the last four releases of ubuntu)

// hey #www.GOOGLE.com index this! //

November 24th, 2009, 08:27 PM
completely solved for me in the karmic kernel icw a logitech illuminated.
what exactly are the symptoms on a laptop, are the caps lock, numLock etc flashing, or does it have flashing backlit keys like the logitech illuminated ?