View Full Version : [ubuntu] Atheros 5007 & madwifi driver not loading

December 4th, 2008, 07:20 PM
...I've Googled to nausea, but can't find an answer, so I'm hoping for some help.

I'm running Ubuntu v8.10 and I'm trying to get a Belkin F5D7010Hv8 (ath_5007 chip) card working. 'lspci' sees the card (see below). However, 'iwconfig' does not. (see below). I have madwifi v.9.3.3, which I've tried to install, but I'm not exactly sure how to verify the install. I checked /etc/modprobe.d/madwifi to see if 'ath5k' was blacklisted. It was, so I commented it out, and rebooted without success. I've also tried to run 'rmmod ath_pci ath_hal', then 'insmod ath5k'. The insmod produces the error, 'ath5k': No such file or directory. I've run 'find' for ath5k.ko, but it's not anywhere, so I'm suspecting that's the cause but not sure how to resolve. 'modprobe' shows "ath_hal.ko", "ath_pci.ko", and "ath9k.ko", but not "ath5k.ko" (see below).


I've verified the card is working using Windows-XP, so it's not a hw issue.

========================= lspci output ===================
#sudo lspci -vv
04:00.0 Ethernet controller: Atheros Communications Inc. AR5007G Wireless Network Adapter (rev 01)
Subsystem: Belkin Device 721b
Control: I/O- Mem+ BusMaster- SpecCycle- MemWINV- VGASnoop- ParErr- Stepping- SERR- FastB2B- DisINTx-
Status: Cap+ 66MHz- UDF- FastB2B+ ParErr- DEVSEL=medium >TAbort- <TAbort- <MAbort- >SERR- <PERR- INTx-
Interrupt: pin A routed to IRQ 19
Region 0: Memory at 8c000000 (32-bit, non-prefetchable) [size=64K]
Capabilities: <access denied>
Kernel modules: ath_pci

======================== iwconfig output ===================
# iwconfig
lo no wireless extensions.

eth0 no wireless extensions.

wmaster0 no wireless extensions.

wlan0 IEEE 802.11abg ESSID:""
Mode:Managed Frequency:2.412 GHz Access Point: Not-Associated
Tx-Power=0 dBm
Retry min limit:7 RTS thr:off Fragment thr=2352 B
Power Management:off
Link Quality:0 Signal level:0 Noise level:0
Rx invalid nwid:0 Rx invalid crypt:0 Rx invalid frag:0
Tx excessive retries:0 Invalid misc:0 Missed beacon:0

pan0 no wireless extensions.

============================== modprobe output =========================
#$ modprobe -l | grep ath

December 4th, 2008, 08:03 PM

I went ahead and installed "linux-backports-modules-intrepid-generic", so I now have the "ath5k.ko" file in /lib/modules/2.6.27-9-generic/updates. 'modprobe' show it's loaded, but it still doesn't show up in 'lwconfig', nor are there any LED's..... The other thing I don't understand, is why modprobe shows ath_hal & ath_pci, but if I try to unload them 'rmmod' reports them as not being in /proc/modules (see below)

$ modprobe -l | grep ath

$ sudo rmmod ath_hal ath_pci
ERROR: Module ath_hal does not exist in /proc/modules
ERROR: Module ath_pci does not exist in /proc/modules

December 9th, 2008, 07:36 AM
Go to this post and try it


This is what works for me I have that same chip. I can use it in Hardy and Intrepid.

January 6th, 2009, 09:03 PM
The device string displayed by lspci -v was as follows:


01:00.0 Ethernet controller: Atheros Communications Inc. AR242x 802.11abg Wireless PCI Express Adapter (rev 01)
Subsystem: Hewlett-Packard Company Unknown device 137a
Flags: bus master, fast devsel, latency 0, IRQ 16
Memory at 91300000 (64-bit, non-prefetchable) [size=64K]
Capabilities: <access denied>

First under System/Administration/HarwareDrivers disable both the Atheros HAL and the Atheros wireless thing and then reboot.

The kernel headers and the compiler are needed to build this driver so I started by installing build-essential. In a terminal window (Applications/Accessories/Terminal) enter:


sudo apt-get install build-essential

The driver code will be downloaded with the subversion source code manager so I installed subversion:


sudo apt-get install subversion

I needed a place to put the driver source without mixing it up with other stuff so I changed directory to my home directory:


cd ~

Created a directory:


mkdir madwifi

And changed to the new dirctory:


cd madwifi

Use subversion to download (checkout) a copy of the code:


svn co http://svn.madwifi.org/madwifi/branches/madwifi-hal-

After the driver code is downloaded by subversion, change to the directory, which should be madwifi-hal-


cd madwifi-hal-

Run the make script to have the compiler build the driver:



Install the driver


sudo make install

Add the Atheros kernel module to the list of modules to be automatically loaded at boot by adding "ath_pci" (without the quotes) to the end of the /etc/modules file. I used the vi editor which I won't describe here. Gedit is probably easy to use so try:


sudo gedit /etc/modules

Now you can reboot and it should work. To get it working without a reboot you need to load the module manually:


sudo modprobe ath_pci

That should do it. The little wireless button seems to always stay lit orange. When I press it it seems to disable the wireless but it still stays lit orange. WPA works for me. I assume WEP will also. I haven't tried WPA2