View Full Version : [ubuntu] desktop icons, context menus, etc GONE

December 4th, 2008, 04:39 PM
they're just gone. if I open terminal and type "nautilus restart" everything reappears and works, until I close the terminal. I've tried reinstalling the nautilus package but it didn't really fix anything. any ideas?

December 4th, 2008, 04:57 PM
Maybe put "nautilus restart" into your Sessions for startup? This'll get around that open Terminal window thing if it works.

December 4th, 2008, 05:00 PM
actually I just did that before I refreshed the thread to see if there were any replies. it works, however I get a little error message. a little annoying but everything works again. hopefully it'll get fixed in an update
the error is: Could not find "home/username/restart". please check the spelling and try again.
no idea what that's all about but who cares, its working again for the time being. as long as my dropbox is working I don't care, the box is headless anyways.

December 4th, 2008, 05:02 PM
Heck, try just shortening "nautilus restart" to just "nautilus" in your Sessions. It seemed to not like the "restart" part. :)

December 4th, 2008, 05:11 PM
tried that, it just opens a nautilus window then.

Ivo Moelans
December 4th, 2008, 06:14 PM
You could try nautilus --quit. This should restart nautilus afresh.

December 4th, 2008, 06:22 PM
changing my sessions item to "nautilus --restart" made everything work perfectly.