View Full Version : Packaging and Compiling Programs

Pages : 1 2 3 4 5 6 7 8 9 10 11 [12] 13 14 15 16

  1. Creating .deb for shared libraries using dh_make/debuild
  2. Problems compiling a CLI program using cc in bash, written for DOS using open watcom.
  3. Creating single .deb for shared dev library
  4. Building OpenCV: CV_CAP_OPPENNI not declared
  5. [SOLVED] #including a GUI and distributing...
  6. patching a deb package using "ar" for unpacking and packing
  7. error when compiling
  8. compiling with f77
  9. [SOLVED] PPA's not there...
  10. trouble with makefile, system cannot find file specified
  11. Ubuntu Software Development
  12. Compiling as a .deb?
  13. compiling a kernel module
  14. How to package a RealBasic application?
  15. [SOLVED] Oneiric and indirect linking
  16. Problems compiling GTK tutorial program
  17. can not open anjuta second time
  18. GNU Compiler Collection
  19. linking against libpng: relocation R_X86_64_32 error
  20. How to mark that package requires user logout
  21. Help Compiling Modules
  22. Compiling linux kernel 3.0.0 failing on UBUNTU 10.04
  23. Launchpad build problems...help?
  24. [SOLVED] apache2 2.2.19 build problems with lucid ppa
  25. Launchpad autobuilder fails building linux 3.0.0 on Ubuntu 10.04 LTS
  26. autobuilder fails to build openssl 1.0.0d-2ubuntu2~lucid1 i386
  27. [SOLVED] apt-get source and edit-patch for a specific unreleased version
  28. Building unity from source
  29. Ubuntu Software Center shows 'sorry' screen
  30. C programming in BT 5
  31. Best way to compile linux kernel
  32. I'm on Maverick, but package requires cdbs (>= 0.4.85~)
  33. Easy way? Or false hope?
  34. Compile a Netbeans C++ project from command line
  35. [SOLVED] Compiling OpenCV 2.3 on Natty x86-64 bit
  36. Help with Installing Perl
  37. using ldconfig to include link lib .so
  38. unable to run "make" in kubuntu 10.04
  39. error in char device module compilation
  40. [Tutorial] Debianize Github Projects And Upload to Ubuntu PPA
  41. linking : selecting Symbols from 2 or more different dynamic librarie
  42. .deb file for Ubuntu
  43. [SOLVED] GNOME/Unity menu items?
  44. Keeping my version on software
  45. Which version of libstdc++ is my app linking to?
  46. Zlib error and configure commands???
  47. Gfortran shared library compile issue
  48. Setting program PATH
  49. Ubuntu kernel 2.6.38 compilation error
  50. Ubuntu am64 udisks compilation
  51. Compiler Problem with Geany
  52. [SOLVED] Help with a makefile install: rule.
  53. Unable to locate dh_make ? - why ?
  54. [SOLVED] Dude... wheres my compiler?
  55. PPA: C++ Compiler Not Installed?
  56. Distributing program with shared libraries
  57. [SOLVED] Uploading to Universe repository
  58. Need help compiling a Half-Life hook
  59. Packages for PHP 5.3.8
  60. Help needed on unpacking a firmware file
  61. [SOLVED] Packaging Java source.
  62. make python script run like normal program
  63. [SOLVED] Environment variables in debhelper.
  64. [SOLVED] Making a .deb out of C code
  65. [SOLVED] Could not find so lib
  66. arm-2010q1-202-arm-none-linux-gnueabi compilation and installation on ubuntu
  67. [SOLVED] make issue
  68. GCC 4.6 linker doesn't work anymore
  69. Problems linking glew and glut
  70. crt*.o
  71. [SOLVED] executing/installing packages .sh files
  72. File system
  73. gstreamer and appsink
  74. make problem
  75. gtk, I can't figure it out!!!!
  76. [SOLVED] garbage collection of compiled code by gcj
  77. how to make a custom entry in Synaptic for my application?
  78. pbuilder error - unmet dependencies
  79. Make file issue
  80. Need some guidance for rebuilding gentoo file manager
  81. libusb
  82. Help needed in packaging
  83. [SOLVED] Python package working for hardy but not for lucid
  84. cant use pthreads,
  85. List of Ubuntu patched kernel versions (downloadable source)
  86. dpkg-gencontrol: error: package linux-image* not in control info
  87. [SOLVED] Lapack install going bad
  88. [SOLVED] undefined reference to `clock_gettime' -lrt
  89. What processor type do I need to select.
  90. Problem face while make install of ACE-6.0.0
  91. Run File With Shared Library
  92. weird linker error with allegro
  93. Using Solaris File system in Linux???!!!
  94. [SOLVED] emerald rebuilding package from source. compile fails. help needed
  95. Problem compiling 32bit program on 64bit Ubuntu
  96. [SOLVED] How to add a file as a patch.
  97. Help building Crunch on 11.10?
  98. I am trying to install Openmortal..
  99. make: arm-linux-gcc: Command not found
  100. Undefined reference to dlopen, dlsym, dlerror, dlclose
  101. [SOLVED] Restarting service during postinst prevents finishing of deb-installation
  102. Help installing lua 5.1.4 on ubuntu 11.10
  103. Git-pbuilder on Ubuntu
  104. [SOLVED] building using git-buildpackage. creating orig.tar.gz help
  105. Kernel compilation error
  106. problem on installing g95 and qt
  107. Python tutorials quick start guides
  108. Compiling GTK2 from source
  109. [SOLVED] linking shared 64-bit libpcre3 - missing something simple?
  110. [SOLVED] nVidia OpenCL on Ubuntu 11.10 -lOpenCL /usr/bin/ld
  111. please help me create a PPA
  112. problem on installing qt
  113. Looking for a better way to run c++ console apps
  114. Kernel 3.2 rc-1 doesn't want to build the debian way.
  115. Need help compiling Dreamcast homebrew from source.
  116. problem on installing qt
  117. [SOLVED] $DESTDIR's not there....bit of a problem.
  118. [SOLVED] (newbie) how to have more than one gcc compiler version?
  119. Problem compiling WRF
  120. Having difficulty compiling Realtek WiFi drivers
  121. Lost building RPM packages
  122. [SOLVED] How to install packages from older releases?
  123. make issue with head file dependency with gcc 4.6.1 on ubuntu 11.10
  124. Frame size * larger than 1024
  125. [SOLVED] Linking errors when compiling an OpenCV program...
  126. ELM - is this even available?
  127. [SOLVED] Force pbuilder to use a specific kernel?
  128. [SOLVED] Update .ko files when kernel is updated?
  129. gcc error: expected ‚=‚, ‚,‚, ‚;‚, ‚asm‚ or ‚__attribute__‚ before ‚{‚ token
  130. Split deb into two files, one for driver and one for apps?
  131. gtk-doc.make not found when compiling Gedit
  132. [SOLVED] How to run two versions of Firefox together?
  133. Jar file excutable bit
  134. Manually set package dependencies
  135. Packaging *.deb that requires fuse module.
  136. OpenSSL + Netbeans + Ubuntu + C
  137. [SOLVED] Can't compile anything
  138. copyright file in debian folder
  139. cannot run eclipse in ubuntu 11.10
  140. Avoid codeblocks create .o files
  141. [SOLVED] pbuilder needs debhelper, but does not install it
  142. 'make' error
  143. pbuilder-dist denied permission to /lib/
  144. [SOLVED] Create multiple binaries from a single source package
  145. upgrade GLIB, Pango and GTK+ libraries (how to ?)
  146. [SOLVED] Trouble building kq
  147. trouble in php-qt compilation
  148. how do I compile software that needs later versions of libraries
  149. [SOLVED] Configure error, not sure what to make of it.
  150. No Symbol for Crypt, Can't Compile
  151. Cannot compile a simple driver module
  152. [SOLVED] debuild / dpkg-buildpackage: "Permission denied"
  153. Oneiric git kernel compile missing a linux-headers package.
  154. makefile creation
  155. [SOLVED] pbuilder "permission denied" errors
  156. compiling a program in Ubuntu
  157. [SOLVED] pbuilder not installing build dependencies
  158. Problems compiling MINUIT (cernlib) in ubuntu 11.10
  159. [SOLVED] Nvidia installer on custom kernel with SSD drive
  160. Preconfigure Apps Before Install?
  161. [SOLVED] Problem overwriting existing file, Installing a packaged program.
  162. set javac classpath
  163. why compiler is behaving differently for math lib
  164. [SOLVED] Compiling BSD Version of ar - Help with Error
  165. Importing libraries for mingw-gcc
  166. [SOLVED] dh_usrlocal: is not a directory
  167. Compiling libraries for Multiarch?
  168. [SOLVED] Compiling error
  169. Unable to compile kernel module... halp?
  170. Error compiling scramdisk-2.1
  171. Casting from int to pthread_t
  172. Natty building Gtk+-3.2.3
  173. Code::Blocks quickie
  174. Error while installing tuned with checkinstall
  175. Problems with "make" (compile) a program
  176. have thread do work for a period of time
  177. Any way to re-build Unity application cache from 'make install'?
  178. JAVA jdk installation
  179. Compiling with reference to libboost-sys-dev
  180. Update kernel modules without dkms or build tools?
  181. Qt 4.8 -platform linux-g++-32 on a 64 bit os
  182. OpenGL programming / questions about extensions
  183. Problem compiling, missing combressbound and compress
  184. [SOLVED] Discard certain warnings on compile g++
  185. ubuntu 11.10 compile errors
  186. Can't Build Pango: Grep Error
  187. Compiling with GTK development packages
  188. JHBUILD: Error during phase configure of guile1
  189. Could not find a configuration file for package OpenCV
  190. Installing from source vs installing from the USC
  191. Ubuntu natty building gtk+-3.2.3
  192. Compiling the Kernel
  193. gcc error on "-m elf_i386"
  194. compiling error in opencv with ffmpeg
  195. compile ajunta: No package gdl-3.0 found
  196. Cross compile for arm5tejl
  197. building gcc in lucid
  198. Creating DEB from Python Application
  199. To DKMS or not to DKMS?
  200. Shared libraries are not linked to the binary
  201. apache2 2.2.21-5 compile error
  202. [SOLVED] compiling i386 binary on x86_64
  203. Compile software debian way
  204. QT-copilation
  205. QT Compilation
  206. How do I make a program use the Unity UI (specifically the menu bar)?
  207. Best way to add site-packages back into PYTHONPATH?
  208. i386 package dependency on amd64 package?
  209. dpkg-depcheck can't find packages
  210. ARM cross compiling: Missing headers (termios.h)
  211. evolution-ews packaged for oneiric
  212. Samba Winbind Help Please!
  213. Java backend/servlets
  214. Customized GCC: installation from source code
  215. Ubuntu Developer Week: 31st Jan-2nd Feb
  216. DKMS guides
  217. Kernel Building: Questions about modules and CFLAGS, and other randoms
  218. getting source coude from a DEB package?
  219. Installing Zathura from source (pkg-config search path error)
  220. Autoadd icons to unity bar
  221. [SOLVED] Installing Florence keyboard?
  222. Cant install libusb
  223. creating a "Makefile"
  224. Autoconf tool error in ubuntu
  225. Using VOCE
  226. complile from source help
  227. [SOLVED] Getting F2PY installed correctly
  228. Compiling dvdistaster: bzlib.h not found (dev files installed)
  229. More F2py help
  230. [SOLVED] xml-xalan-c install issue Ubuntu
  231. Problem installing webcam-server
  232. OpenSSL Help
  233. 【how to compile 32-bit apps using autoconf】
  234. Cannot compile kernel using KernelCompile Community Documentation
  235. Using source files from a later ubuntu version to compile deb package ?
  236. How to install Crrcsim
  237. [SOLVED] fatal error: linux/compiler.h: No such file or directory
  238. Simple .deb creation - looking for general directions?
  239. [SOLVED] GTK2 compile failing on glibconfig.h
  240. Xoom Kernel Development
  241. Source Package for Ubuntu's Alternative Installer Ncurses Installer
  242. Cant Install Applications
  243. How to compile x264 code in Ubuntu 11.10 (new user)
  244. Problem to install rrtdtool 1.4.7 from source
  245. Compiling through SSH connection
  246. Trouble compiling custom Linux kernel (v3.2)
  247. Trouble compiling custom Linux kernel (v3.2)
  248. Can't figure out how to set up up a ppa, going mad slowly
  249. [SOLVED] compiling boost with monodevelop
  250. [SOLVED] Newbie's GNU C/C++ question - make