Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: [SOLVED] Can't change Gnome themes

  1. #1
    Join Date
    Mar 2007
    Beans
    Hidden!

    Exclamation [SOLVED] Can't change Gnome themes

    I just removed Intrepid and installed Hardy. I have my /home on another partition, so I just mapped to that and all my settings came back *except* the theme. Instead of the human theme, I have something that looks like the default gnome theme (gray with a blue title bar, highlights in blue, really blocky buttons).

    Everytime I go to System > Preferences > Appearance and select any of the human themes, all the open windows change to the way I want, but then any window I open after that is back to the default gnome appearance. The title bar and highlight colors often will change to what they are supposed to be, but the buttons and menus are all the ugly grey blocky style.

    This looks identical to this post: http://ubuntuforums.org/showthread.p...t+change+theme His screenshots are exactly what I'm seeing. Except the solution doesn't apply to me because I don't have the dark looks theme. I tried changing the human theme based on his fix, but that was a mess.

    Other things I've tried:
    I've renamed the .gconf file and logged back in
    I went through Synaptic and reinstalled the following items:

    gtk2-engines-murrine
    gtk2-engines-pixbuf
    gtk2-engines-ubuntulooks
    human-icon-theme
    human-theme
    ubuntu-gdm-themes
    gnome-themes

    I've tried other themes besides human.
    Also tried: gtk-window-decorator --replace, metacity --replace and compiz --replace

    Nothing works!!!! Help!!!

    What other information can I provide to help troubleshoot? I haven't found a solution yet on the forums (maybe I'm not using the right keywords). The closest I found was the link I posted above.

    Any help would be fantastic. I don't want to have to completely reinstall just to fix the dumb colors.
    Last edited by opus1; November 30th, 2008 at 10:50 PM. Reason: Tried some new things

  2. #2
    Join Date
    Aug 2007
    Location
    Seattle, WA
    Beans
    48
    Distro
    Xubuntu 8.04 Hardy Heron

    Re: Can't change Gnome themes

    Can you please restart without saving current session and post an image of the issue e.g. how it looks after applying human-theme.

  3. #3
    Join Date
    Mar 2007
    Beans
    Hidden!

    Re: Can't change Gnome themes

    Sure, give me a minute here.

    Just to help define the issue a little more. I've noticed that menus related to Ubuntu (that is, the panel menus and menus in the appearances window) have the correct appearance (brownish background) while "external" apps (firefox, calculator, etc.) have the default blue background to the menus as well as the blocky appearance to the buttons.

    I thought there might be some permission issue so I issued a

    Code:
    $ find /home/bob/ -user root
    But only one root owned file was found, and it's related to passwords.

  4. #4
    Join Date
    Mar 2007
    Beans
    Hidden!

    Re: Can't change Gnome themes

    Here are the screen captures. I tried to show what I was talking about with the two menu colors...
    Attached Images Attached Images

  5. #5
    Join Date
    Aug 2007
    Location
    Seattle, WA
    Beans
    48
    Distro
    Xubuntu 8.04 Hardy Heron

    Re: Can't change Gnome themes

    Please go to your window manager and check if proper style is selected. Since am on xubuntu. I can not advise further on ubuntu options.

  6. #6
    Join Date
    Mar 2007
    Beans
    Hidden!

    Re: Can't change Gnome themes

    Could someone direct me how to get to the window manager? I've looked through the menu items and haven't found anything that matches that description...

  7. #7
    Join Date
    Jun 2008
    Location
    Phra Nakhon Sri Ayutthaya
    Beans
    1,307
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Can't change Gnome themes

    How about disabling Visual Effects?
    Go to: Main Menu > System > Preferences > Appearance, and click None.
    Ubuntu Release 12.04
    Kernel Linux 3.0.0-16-generic
    Pentium dual core 3.00GHz

  8. #8
    Join Date
    Oct 2006
    Location
    Cologne, Europe
    Beans
    2,570
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Can't change Gnome themes

    Try running:
    Code:
    gnome-settings-daemon

  9. #9
    Join Date
    Feb 2007
    Location
    Antwerp, Belgium
    Beans
    166
    Distro
    Ubuntu Development Release

    Re: Can't change Gnome themes

    Could you give the following information:
    When you apply a theme, e.g. Human, and then in Appearance Preferences click on the Customize... button under the tab Controls Human should be selected and also under the tab Window Border Human should be selected.
    Is this the case?

  10. #10
    Join Date
    Mar 2007
    Beans
    Hidden!

    Smile Re: Can't change Gnome themes

    Thanks everyone for the replies. During the busy work week I typically don't spend much time at home, so I didn't see your replies.

    I started messing with it yesterday morning (before checking here) and managed to fix it.

    eternalnewbee: I did try your suggestion yesterday and it had no effect.

    Ivo Moelans: Yes, "human" was selected under the Controls and Window Border tabs. Selecting these tabs would cause the controls in the "appearance" window to reset themselves to "human", but when I closed the window and opened it again, they would revert back to the gtk look I described above.

    My fix is a strange one, though: I selected a completely different theme ("Clearlooks") and then changed each element of the theme, one-by-one, until it matched "Human".

    To be specific (for anyone else who might need this fix):
    1. I went to System > Preferences > Appearance.
    2. On the "theme" tab I chose "Clearlooks".
    3. I clicked the "Customize" button at the bottom.
    4. On the "controls", "Icons" and "Window Border" tabs, I chose "human".
    5. On the "Colors" tab, I chose colors that matched the "Human" theme.


    This made all applications menus and buttons behave properly.

    Interestingly, I went back and selected the "human" theme and it reverted back to the annoying behavior I noted in my first post. All three "Human" themes appear to be borked, but the other themes appear to work correctly (I may have stated otherwise above, but if I did, I was wrong).

    Forlong : Do you want me to try your suggestions, or should I mark this as 'solved'?

    Thank you everyone!
    Last edited by opus1; December 7th, 2008 at 07:37 PM. Reason: Forgot something.

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •