Page 2 of 22 FirstFirst 123412 ... LastLast
Results 11 to 20 of 215

Thread: Interpid Sound Solutions

  1. #11
    Join Date
    Apr 2006
    Location
    Sydney, Australia
    Beans
    146
    Distro
    Ubuntu 13.10 Saucy Salamander

    Re: Interpid Sound Solutions

    First of all thanks markbuntu for well written instructions and your time and effort.
    Unfortunately I have similar problems to Zarok with getting Digital output to work. I also share his sentiments as I have been using Ubuntu as my music player for a pretty expensive stereo for over two years without any sound problems only to have this latest release screwing everything up.

    I have followed markbuntu's (and others) instructions and have sound via my PC speakers, but cannot get digital output to work. I have attached a few screen shots and config files; maybe I'm missing something obvious.

    I do get digital output after the system rebooted (i.e. the drums) and I guess that this is before pulseaudio starts. I can also get digital output (the test tone) when I set the output to ALSA in the Sound Preferences.

    Thanks
    Attached Images Attached Images

  2. #12
    Join Date
    Dec 2008
    Beans
    1

    Re: Interpid Sound Solutions

    I appreciate all the help this forum provides. I recently installed Ubuntu 8.1 on a Dell Inspiron 9100 laptop, but am having sound problems.

    When I first installed Ubuntu, I could not control the sound with either the volume controls on the laptop or with the volume control in the top task bar. The sound was extremely loud, and I couldn't do anything about it.

    I followed all of the instructions in this post, and now I have the opposite problem. I still can't control my sound, but now it is very quiet.

    Does anyone know how to fix this problem?

  3. #13
    Join Date
    Apr 2008
    Beans
    4,377
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Interpid Sound Solutions

    Quote Originally Posted by lister171254 View Post
    First of all thanks markbuntu for well written instructions and your time and effort.
    Unfortunately I have similar problems to Zarok with getting Digital output to work. I also share his sentiments as I have been using Ubuntu as my music player for a pretty expensive stereo for over two years without any sound problems only to have this latest release screwing everything up.

    I have followed markbuntu's (and others) instructions and have sound via my PC speakers, but cannot get digital output to work. I have attached a few screen shots and config files; maybe I'm missing something obvious.

    I do get digital output after the system rebooted (i.e. the drums) and I guess that this is before pulseaudio starts. I can also get digital output (the test tone) when I set the output to ALSA in the Sound Preferences.

    Thanks
    If you follow the link in the OP to my 10,000 page guide, there is a link there with directions for adding a device for getting your digital output into the pulseaudio volume control. That should fix you up.

  4. #14
    Join Date
    Apr 2008
    Beans
    4,377
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Interpid Sound Solutions

    Quote Originally Posted by shanse2 View Post
    I appreciate all the help this forum provides. I recently installed Ubuntu 8.1 on a Dell Inspiron 9100 laptop, but am having sound problems.

    When I first installed Ubuntu, I could not control the sound with either the volume controls on the laptop or with the volume control in the top task bar. The sound was extremely loud, and I couldn't do anything about it.

    I followed all of the instructions in this post, and now I have the opposite problem. I still can't control my sound, but now it is very quiet.

    Does anyone know how to fix this problem?
    The pulseaudio volume control is probably controlling your sound now along with the panel volume control so you probably need to adjust them both. To get your media keys to control the sound you need to use System/Preferences/Sound and select your sound card for the default mixer.

  5. #15
    Join Date
    Apr 2006
    Location
    Sydney, Australia
    Beans
    146
    Distro
    Ubuntu 13.10 Saucy Salamander

    Re: Interpid Sound Solutions

    Quote Originally Posted by markbuntu View Post
    If you follow the link in the OP to my 10,000 page guide, there is a link there with directions for adding a device for getting your digital output into the pulseaudio volume control. That should fix you up.
    The digital output is already displayed in the pulseaudion volume control (see attached). I seem to recall that ALSA has a problem with multiple output devices on the same card. If this is correct, I would like to change the order of the devices when loaded (see attached) by pulse so the optical is loaded first. Tried to do this, but am unsuccessful so far.

    I may of course be totally off the mark.

    Thanks.
    Attached Images Attached Images

  6. #16
    Join Date
    Apr 2008
    Beans
    4,377
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Interpid Sound Solutions

    What you can do is go to the pulseaudio device chooser and select Configure Local Sound Server/Simultaneous Output and enable the box

    Add virtual output device for simultaneous output on all local sound cards

    This will create a virtual simultaneous output device in the pulseaudio volume control that you can use like any other device.

  7. #17
    Join Date
    Aug 2006
    Location
    London, UK
    Beans
    Hidden!

    Re: Interpid Sound Solutions

    I started out with no sound and before reading this thread installed oss 4. This gave me sound but also crackling, especially when there is no playback.

    I have tried to follow you solution but can not get pulse audio to work because the device is not being found.

    Pref-- default sound card does not bring up any options. The waiting cursor fades away.

    In sound prefs devices
    If I choose sound playback and set it to pulse audio sound server and test it this is the result:


    audiotestsrc wave=sine freq=512 ! audioconvert ! audioresample ! gconfaudiosink: Failed to connect stream: Invalid argument

    ie no test sound is produced. It does test if I set it to oss 4.

    Can you help me?

  8. #18
    Join Date
    Apr 2006
    Location
    Sydney, Australia
    Beans
    146
    Distro
    Ubuntu 13.10 Saucy Salamander

    Re: Interpid Sound Solutions

    Quote Originally Posted by markbuntu View Post
    What you can do is go to the pulseaudio device chooser and select Configure Local Sound Server/Simultaneous Output and enable the box

    Add virtual output device for simultaneous output on all local sound cards

    This will create a virtual simultaneous output device in the pulseaudio volume control that you can use like any other device.
    Tried you suggestion, but couldn't get it to work.

    I found a way of making my optical output the default and now have sound (again) via optical out. I used the Pulseaudio applet to set the default sink to the second sink as per attached screenshots.

    Thanks

  9. #19
    Join Date
    Apr 2008
    Beans
    4,377
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Interpid Sound Solutions

    Quote Originally Posted by Robbyx View Post
    I started out with no sound and before reading this thread installed oss 4. This gave me sound but also crackling, especially when there is no playback.

    I have tried to follow you solution but can not get pulse audio to work because the device is not being found.

    Pref-- default sound card does not bring up any options. The waiting cursor fades away.

    In sound prefs devices
    If I choose sound playback and set it to pulse audio sound server and test it this is the result:


    audiotestsrc wave=sine freq=512 ! audioconvert ! audioresample ! gconfaudiosink: Failed to connect stream: Invalid argument

    ie no test sound is produced. It does test if I set it to oss 4.

    Can you help me?
    This does not work with OSS4. I think there may be OSS4 support for pulseaudio in OSS4.1 but you would need to find that out from the OSS devs.

  10. #20
    Join Date
    Aug 2006
    Location
    London, UK
    Beans
    Hidden!

    Re: Interpid Sound Solutions

    Quote Originally Posted by markbuntu View Post
    This does not work with OSS4. I think there may be OSS4 support for pulseaudio in OSS4.1 but you would need to find that out from the OSS devs.
    I now realise that the sound has ceased working. In order to get the sound to work properly I don't mind going back to pulseaudio and to remove oss4. I do not know how to do that successfully.
    Last edited by Robbyx; December 10th, 2008 at 11:49 PM. Reason: Sound no longer working

Page 2 of 22 FirstFirst 123412 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •