Results 1 to 10 of 215

Thread: Interpid Sound Solutions

Threaded View

  1. #1
    Join Date
    Apr 2008
    Beans
    4,377
    Distro
    Ubuntu 9.10 Karmic Koala

    Interpid Sound Solutions

    Intrepid 8.10 Sound Solution
    also works with Hardy Heron 8.04
    with multimedia support

    If you are using Jaunty Jackalope 9.04 go here

    http://ubuntuforums.org/showthread.php?t=1130384

    If you have just upgraded to or installed Intrepid or Hardy or Jaunty and you have some sound somewhere, but not everywhere for everything, this is a fast way to get all the missing stuff you need and give you some tools to figure out what is going on. If you hear the startup sound but nothing else, or if some applications work and others don't, this is for you. If you have no sound at all, there is a link at the end of this post for more extensive troubleshooting help but you should try this first anyway as it may solve your problem and will not make matters worse.

    Make sure that your system is fully updated. (Jaunty is still somewhat of a mess with pulseaudio so if something is weird wait for an update or file a bug report)

    Essential Packages
    First you need to get some missing packages with Synaptic. These packages were not installed by default but are important for getting your sound working properly:

    asoundconf-gtk

    This is a little Default Sound Card application for choosing the default sound card for alsa. (This may not be necessary anymore with Jaunty)

    gnome-alsamixer

    This is a gui mixer, far easier to use than the command line alsamixer.

    alsa-oss

    This is the wrapper for oss applications so they will use alsa instead of grabbing the sound card all for themselves

    libasound2
    libasound2-plugins

    These are the plugins for alsa

    padevchooser

    This is the Pulse Audio device chooser and will pull in the pavucontrol which is the Pulse Audio Volume Control and papref which is the Pulse Audio Preferences along with the Pulse Audio Volume Meters. (This is now included with Jaunty)

    gstreamer0.10-pulseaudio

    This is the gstreamer plugin for pulseaudio

    ubuntu-restricted-extras

    This is the package with all the restricted codecs and java and flashplayer so you can watch youtube and play your mp3s,etc..

    If you have other applications like mplayer, vlc, amarok, or audacious be sure to get any extra packages available for them also.

    Setting things up
    Once you have all these packages installed, close any application that may be trying to use sound and go to System/Preferences/Sound and set all the preferences from automatic to PulseAudio except Default Mixer Tracks which you should set to your sound card. Go to System/Preferences/Default Sound Card and choose pulseaudio.

    Next, right click on the little speaker on the top panel, that is the Panel Volume Control. Click Open Volume Control and make sure it is set to the same thing as the Default Mixer Tracks. Click on Preferences and make sure that Master and PCM and whatever else you want to control are selected. Make sure that any boxes labeled SPDIF or IEC958 are not checked. Close the Preferences box. Push up the sliders in the volume control and make sure the little speakers do not have little red mute marks on them. Go to Applications/Sound and Video/GNOME ALSA Mixer and see if there is anything you missed because sometimes, for some cards, not all the options are in the Panel Volume Control.

    Go to Applications/Sound and Video and select Pulse Audio Device Chooser. This will put a little icon on the panel near the Panel Volume Control. Click on the new icon and choose Volume Control. This will open the Pulse Audio Volume Control. Go to Output Devices and see if your sound card is there, it will be listed as ALSA PCM on front:...(ALC88) via DMA or whatever your sound card is. If you have a usb device it will be listed as ALSA PCM on front:...(USB Audio) via DMA or something like that. Make sure the sliders are up and the device is not muted.

    If any of the above is giving you problems, try rebooting.

    Now, open Rythmbox and play something. If you have nothing handy just play one of the radio stations, you should hear something. In the Pulse Audio Volume Control/Playback you should see something like this
    Rythmbox: Playback Stream
    and some Volume sliders that you can adjust.

    More than one Device
    If you have more than one device listed in Output Devices, Rythmbox may be playing in the wrong one if you do not hear anything so right click on the stream and choose move stream and move it to another device.

    If you have more than one device and you want to use them all, like a usb headset and your speakers, go back to the Pulse Audio Device chooser on the panel and select Configure Local Sound Server/Simultaneous Output and click the box:
    "Add virtual output device for simultaneous output on all local sound cards"

    Now you can right click on the stream and move it to your new device. You should have sound from all your sound devices now or at least a clue about how it is supposed to work.

    Other stuff
    Another thing you may need to do, Check in System/Administration/Users and Groups that your users and root are enabled as members of the following groups:
    pulse
    pulse-access
    pulse-rt
    This seems to be a particular problem for some people after getting recent updates.

    Extras
    I usually do this right after every install/upgrade.It is updated for Intrepid now and will really get you dialed in for sound and video (not updated for jaunty yet):

    http://ubuntuforums.org/showthread.php?t=766683

    KDE4 Phonon and Pulseaudio
    If you are using Intrepid or Jaunty with KDE4.1 or KDE4.2/Kubuntu you should read this

    http://ubuntuforums.org/showthread.php?t=1055591

    (If you are using KDE4.2 see post #9 in that thread.)

    If this did not work for you, or you want to get your digital output or surround sound working, or you are using UbuntuStudio or jack, or you just need more information, you can go to my 10,000 page guide here, it was written for Hardy but also works for Intrepid, Jaunty testing is ongoing but the basic troubleshooting should help:

    http://ubuntuforums.org/showthread.php?t=843012

    An Italian language version of this post is here. Many thanks to caracuri for the translation.

    http://caracuri.altervista.org/blog/?p=129
    Last edited by markbuntu; April 20th, 2009 at 12:15 AM. Reason: typo

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •