I'll (try to) be brief...

I'm running Karmic Koala 9.10

Everything worked fine until I replaced my dual monitors with a single HP w1907 (widescreen LCD). Now when I boot up I get:



I tell it to go forth in low resolution and try to fix it in System/Preferences/NVIDIA X Server Settings and I get:

So I open a terminal session and type sudo nvidia-xconfig
I supply the password when prompted, and I get:

Using X configuration file: "/etc/X11/xorg.conf
Backed up file '/etc/X11/xorg.conf' as '/etc/X11/xorg.conf.backup'
New X configuration file written to '/etc/X11/xorg.conf'

Then I press Alt Ctrl Backspace keys but nothing happens so I type
sudo etc/init.d/gdm restart (was this the right thing to do?)

Then the screen goes black and I get a message saying
Stand by one minute while the display restarts... and it has Cancel and OK buttons so I click OK

Then the system starts in terminal mode prompting me for Login and Password.

So, anyone have any ideas? I'm hoping it's as simple as just adding or tweaking a line in the xconfig file but I have no idea what to change. I've attached below my current xconfig file.

FYI -- I'm not getting any of the distortion that someone else who posted on a similar issue was getting (nor do I have the same graphics card), I just have stuff appearing too big on the screen and taking up valuable display real estate. Also, I can't enjoy the fun "Jello" like window response that comes with the advanced graphics setting.

Any help would be most appreciated (over-simplification of steps is welcome too as I'm still a newbie --yes, even though I installed the OS back in February). Pardon delayed replies as I'm off to class for a couple hours.

Let me know if you need any other system details. Also, if the xconfig file below looks a little odd it's because I Franken-putered it together from various websites (back in February) to get my dual monitors to work. I didn't know what the blazes I was doing but it worked.

===========
===========

# nvidia-xconfig: X configuration file generated by nvidia-xconfig
# nvidia-xconfig: version 1.0 (buildmeister@builder58) Wed Dec 9 16:34:26 PST 2009


Section "ServerLayout"
Identifier "Layout0"
Screen 0 "Screen0" 0 0
InputDevice "Keyboard0" "CoreKeyboard"
InputDevice "Mouse0" "CorePointer"
Option "Xinerama" "0"
Option "StandbyTime" "0"
Option "SuspendTime" "0"
Option "OffTime" "0"
EndSection

Section "Module"
Load "v4l"
Load "glx"
Disable "dri2"
EndSection

Section "InputDevice"
Identifier "Mouse0"
Driver "mouse"
Option "Protocol" "auto"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons" "no"
Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

# generated from default
Identifier "Keyboard0"
Driver "kbd"
EndSection

Section "Monitor"
Identifier "Monitor0"
VendorName "Unknown"
ModelName "DELL SE178WFP"
HorizSync 30.0 - 83.0
VertRefresh 50.0 - 77.0
Option "DPMS"
EndSection

Section "Monitor"
Identifier "Monitor1"
VendorName "Unknown"
ModelName "PTW"
HorizSync 30.0 - 80.0
VertRefresh 60.0 - 75.0
EndSection

Section "Device"
Identifier "Device0"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce GT 220"
EndSection

Section "Device"
Identifier "Device1"
Driver "nvidia"
VendorName "NVIDIA Corporation"
BoardName "GeForce GT 220"
BusID "PCI:1:0:0"
Screen 1
EndSection

Section "Screen"

# Removed Option "metamodes" "CRT-0: nvidia-auto-select +0+0, CRT-1:nvidia-auto-select +1440+0"
# Removed Option "metamodes" "CRT-0: 1440x900 +0+0, CRT-1: 1280x1024 +1440+0"
Identifier "Screen0"
Device "Device0"
Monitor "Monitor0"
DefaultDepth 24
Option "RenderAccel" "true"
Option "TwinView" "1"
Option "TwinViewXineramaInfoOrder" "CRT-0"
Option "metamodes" "CRT-0: 1440x900 +0+0, CRT-1: nvidia-auto-select +1440+0"
SubSection "Display"
Depth 24
EndSubSection
EndSection

Section "Screen"
Identifier "Screen1"
Device "Device1"
Monitor "Monitor1"
DefaultDepth 24
Option "Twinview" "0"
Option "metamodes" "CRT-1:nvidia-auto-select +0+0"
SubSection "Display"
Depth 24
EndSubSection
EndSection