Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Dot is switched to comma in dot key!

  1. #1
    Join Date
    Nov 2007
    Location
    São Carlos, Brazil
    Beans
    136
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Dot is switched to comma in dot key!

    Hi everyone

    When I press the dot key in my keyboard, it inputs a comma
    I'm using VAIO VGN-FZ250AE, Ubuntu 8-10 fully updated
    This bug appeared after the updates of today (November, 15)
    Could anybody help me?

    Thank you very much, and sorry for the dot-less post LOL

    /edit: ABNT2 layout keyboard (Brazilian layout)
    Last edited by jpmelos; November 16th, 2008 at 04:39 AM.

  2. #2
    Join Date
    Apr 2006
    Beans
    547

    Re: Dot is switched to comma in dot key!

    Which keyboard do you have configured in Ubuntu?

    Try System->Prefences->Keyboard

  3. #3
    Join Date
    Nov 2007
    Beans
    7
    Distro
    Ubuntu 7.10 Gutsy Gibbon

    Re: Dot is switched to comma in dot key!

    I have exactly the same issue on an Acer Aspire 5050-3233,

    Also an ABNT2 layout keyboard (Brazilian layout),

    A difference is that I'm using Xubuntu 8,10, also fully updated, On the Keyboard Preferences, the option that is marked is "Use X configuration",

  4. #4
    Join Date
    Nov 2008
    Location
    Toronto
    Beans
    136
    Distro
    Ubuntu Karmic Koala (testing)

    Re: Dot is switched to comma in dot key!

    Are you sure your keyboard is a Brazilian layout? It might very well not be. I'm in Canada, but I have as of yet to see a Canadian layout keyboard. It's always US.

  5. #5
    Join Date
    Nov 2007
    Beans
    7
    Distro
    Ubuntu 7.10 Gutsy Gibbon

    Re: Dot is switched to comma in dot key!

    Quote Originally Posted by Mardoct909 View Post
    Are you sure your keyboard is a Brazilian layout? It might very well not be. I'm in Canada, but I have as of yet to see a Canadian layout keyboard. It's always US.
    Yes, I am,

    Anyway, it was working perfectly before the last upgrade,
    Is there any way to undo the last batch of upgrades I did? At least I would be able to do some decent typing until the issue was solved,

  6. #6
    Join Date
    Nov 2007
    Beans
    7
    Distro
    Ubuntu 7.10 Gutsy Gibbon

    Smile Re: Dot is switched to comma in dot key!

    It seems to be a problem with xkb-data version 1.3-2ubuntu4.1. To have your dots back, you have to revert to version 1.3-2ubuntu4. It worked for me. (see my dots! )

  7. #7
    Join Date
    Oct 2008
    Beans
    28

    Re: Dot is switched to comma in dot key!

    Create a script keymap.sh like this:

    Code:
    #!/bin/bash
    
    xmodmap -e "keycode 129 = period"
    xmodmap -e "keycode 60 = period greater"
    xmodmap -e "keycode 62 = Shift_R"
    xmodmap -e "keycode 46 = l"
    and then

    Code:
    sudo sh keymap.sh
    It works for me but there is a little problem: every time I boot my computer I have to run the script again. I tried to put it in /etc/init.d/ and use update-rc.d like this

    Code:
    sudo update-rc.d keymap.sh defaults
    but it didn't work. Any idea to run this script while booting?

  8. #8
    Join Date
    Jun 2007
    Location
    Rio de Janeiro - Brasil
    Beans
    319
    Distro
    Kubuntu Development Release

    Re: Dot is switched to comma in dot key!

    I'm having the same problem and it really scared the **** out of me Gonna revert to the previous version of xkb-data then, thanks for the tip!

  9. #9
    Join Date
    Jul 2005
    Beans
    204

    Re: Dot is switched to comma in dot key!

    Until yesterday I had this problem, but only on the numeric pad. But with yesterday's updates, the actual period button (on comma's right) started working like a comma also.

    What kind of fix not only doesn't fixes the problem but makes it worse?

    And then we can't have Openoffice 3.0 because it isn't "tested" yet...

  10. #10

    Re: Dot is switched to comma in dot key!

    It's an ond and well known bug, (<- this comma should be a DOT!)
    It's reported (more than one time), the team know the problem and the solution, but until now there's no package fixed in repositories,,

    https://bugs.launchpad.net/bugs/272606

    I never been so sad with a bug in [K]Ubuntu like I am now,
    Not because the bug itself (there are many other bugs in Kubuntu and I don't care), but because seems the team doesn't care about it,

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •