Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: webcam not found since intrepid installation

  1. #1
    Join Date
    Dec 2004
    Location
    Korea
    Beans
    440
    Distro
    Ubuntu 12.04 Precise Pangolin

    webcam not found since intrepid installation

    So I checked out the other threads on this topic, and it seems that for people in my particular situation there is no solution (or is there...?).

    In Ubuntu Hardy, my generic webcam worked fine (I don't even know what type it is). I plugged it in, and camera-monitor showed it to be working right away, it worked fine in cheese and skype and everything else, no problem, right out of the box, you get the idea.

    Then I did a clean install of Intrepid.

    No program will detect it. Any program that would actually explain something just says "no device connected to /dev/video0" or something along those lines.

    I tried my fiancee's webcam, a Logitech Quickcam, and it works great, but the quality is terrible (my webcam's quality is way better, despite being some generic thing with no name).

    I've installed just about every package that all of the "linux webcam howto" manuals list, and nothing works.

    Any ideas?
    Linux Gamer.
    Steam: rudeboyskunk
    Desura: rudeboyskunk
    Add me as a friend. Kill zombies/aliens/nazis with me. ON LINUX.

  2. #2
    Join Date
    Dec 2004
    Location
    Korea
    Beans
    440
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: webcam not found since intrepid installation

    *bump*
    Linux Gamer.
    Steam: rudeboyskunk
    Desura: rudeboyskunk
    Add me as a friend. Kill zombies/aliens/nazis with me. ON LINUX.

  3. #3
    Join Date
    Jun 2006
    Location
    UK
    Beans
    122
    Distro
    Ubuntu 13.04 Raring Ringtail

    Re: webcam not found since intrepid installation

    I have the same issue!

    I only used it in skype so nothing complicated but still.

    It work out of the box and now it does not.
    Code:
    Nov 16 21:13:02 marcin-laptop kernel: [18033.020047] usb 4-1: new full speed USB device using uhci_hcd and address 2
    Nov 16 21:13:02 marcin-laptop kernel: [18033.230165] usb 4-1: configuration #1 chosen from 1 choice
    Nov 16 21:13:02 marcin-laptop kernel: [18033.581565] Linux video capture interface: v2.00
    Nov 16 21:13:02 marcin-laptop kernel: [18033.605580] zc0301: V4L2 driver for ZC0301[P] Image Processor and Control Chip v1:1.10
    Nov 16 21:13:02 marcin-laptop kernel: [18033.606784] usb 4-1: ZC0301[P] Image Processor and Control Chip detected (vid/pid 0x0AC8:0x303B)
    Nov 16 21:13:03 marcin-laptop kernel: [18033.683945] usbcore: registered new interface driver zc0301
    It looks like it actually has driver loaded but still it can not be detected by skype.

    this 8.10 is buggies realise every so far my webcam, microphone and graphic card stopped working properly this is dreadful.

    I wish I could downgrade next time I will think twice before any "upgrade"

  4. #4
    Join Date
    Apr 2005
    Location
    Illinois
    Beans
    272

    Re: webcam not found since intrepid installation

    I too have issues with my webcams with Ubuntu 8.10. I have a built in webcam in my laptop and a USB Logitech Quickcam in my desktop. Ubuntu 8.04 detected them correctly and gave the right name under the webcam list. Skype, AMSN etc worked perfectly and the quality was good. After I did a clean install of Ubuntu 8.10 in my laptop and an upgrade in my desktop, Ubuntu 8.10 shows both webcams as USB webcam, without the webcam name. AMSN doesn't recognizes the webcam. Skype works fine with the webcam, but the video is quite dark. I need to switch 4-5 lights on to get a decent brightness. I couldn't find a way to adjust the brightness. I'm not sure what went wrong with Ubuntu 8.10 and why it went backwards as far as webcam is concerned.
    ===============================
    My Blog: http://www.blog.arun-prabha.com/
    My Home: http://www.arun-prabha.com
    ===============================

  5. #5
    Join Date
    Dec 2004
    Location
    Korea
    Beans
    440
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: webcam not found since intrepid installation

    *bump*
    Linux Gamer.
    Steam: rudeboyskunk
    Desura: rudeboyskunk
    Add me as a friend. Kill zombies/aliens/nazis with me. ON LINUX.

  6. #6
    Join Date
    Jul 2008
    Location
    Skelleftea, Sweden
    Beans
    94
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: webcam not found since intrepid installation

    I too am having a problem with this, is there any solution? I want my webcam back

  7. #7
    Join Date
    Nov 2008
    Location
    Pavlodar, Kazakhstan
    Beans
    4
    Distro
    Ubuntu 8.10 Intrepid Ibex

    Re: webcam not found since intrepid installation

    I've got 0ac8:303b Z-Star Microelectronics Corp. ZC0303 WebCam. It worked from the box on 8.04. but failed after upgrade to 8.10. I've found a solution here

    http://janimo.blogspot.com/2008/11/m...bcam-work.html

    Thanks to Janimo, saved me from downgrade.

    I did these steps (all as root!):
    1) Install moreutils package. It's in the repos
    2) Add the line
    Code:
    blacklist zc0301
    in the /etc/modprobe.d/blacklist file
    3) Add the line
    Code:
    gspca_zc3xx
    in the end of the /etc/modules file.
    4) Run
    Code:
    xxd /lib/modules/2.6.27-10-generic/kernel/drivers/media/video/gspca/gspca_zc3xx.ko |sed '/^000a370:/ s/1b30/3b30/' |xxd -r | sponge /lib/modules/2.6.27-10-generic/kernel/drivers/media/video/gspca/gspca_zc3xx.ko
    If your kernel isn't 2.6.27-10 change it according to your kernel version.
    5) Reboot.

    The 4th step must be done after every kernel upgrade. Don't forget to change the kernel version in the code.

    Both cheese and skype work flawlessly again!
    Hope it'll help you too
    Last edited by irtysh; November 25th, 2008 at 06:06 PM.

  8. #8
    Join Date
    Aug 2007
    Beans
    56

    Re: webcam not found since intrepid installation

    sory but to me not work (
    Ubuntu Intrepid 64 Z-STAR ZC0303 Webcam

  9. #9
    Join Date
    Nov 2006
    Location
    Las Vegas, NV
    Beans
    117
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: webcam not found since intrepid installation

    Here's a solution to the brightness problem:

    http://forum.skype.com/index.php?showtopic=106357

    I can't get this code to work. I'm using the correct kernel version (I think) but it gives me the following error:

    xxd: /lib/modules/2.6.24-21-generic/kernel/drivers/media/video/gspca/gspca_zc3xx.ko: No such file or directory
    error opening output file: No such file or directory

  10. #10
    Join Date
    Nov 2008
    Location
    Pavlodar, Kazakhstan
    Beans
    4
    Distro
    Ubuntu 8.10 Intrepid Ibex

    Re: webcam not found since intrepid installation

    Quote Originally Posted by rg_stephens View Post
    Here's a solution to the brightness problem:

    http://forum.skype.com/index.php?showtopic=106357

    I can't get this code to work. I'm using the correct kernel version (I think) but it gives me the following error:

    xxd: /lib/modules/2.6.24-21-generic/kernel/drivers/media/video/gspca/gspca_zc3xx.ko: No such file or directory
    error opening output file: No such file or directory
    Please check out your kernel version first:
    Code:
    uname -r
    And then make sure you change it in both places in the code: in the beginning and in the 'sponge' command.
    As far as I remember 2.6.24 kernel was in Hardy. My webcam worked fine on Hardy without any problem. Intrepid started with 2.6.27-7 and the latest one is 2.6.27-10.
    And you need to get root privileges to run the code. You can use sudo or just open root-terminal:
    Code:
    gksu /usr/bin/x-terminal-emulator
    and run the code there.
    Good luck!

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •