Results 1 to 8 of 8

Thread: no sound in tuxguitar, kguitar and other midi programs

  1. #1
    Join Date
    Nov 2008
    Beans
    3

    no sound in tuxguitar, kguitar and other midi programs

    I have tried to play songs in tuxguitar and kguitar.
    But I can't hear any sound output.

    kguitar gives the error:
    TSE3: Alsa: Received invalid input type �

    While tuxguitar doesn't give an error at all.

    Both of them play the song, but I can't hear any sound

    I think it has something to do with the midi output, because I have tried playing midi files with pmidi and it I also cannot hear anything.

    pmidi -l
    > 14:0 Midi Through Midi Through Port-0

    Please help
    Thank You

  2. #2
    Join Date
    Jun 2007
    Location
    Essex ,U.K.
    Beans
    229
    Distro
    Hardy Heron (Ubuntu Development)

    Re: no sound in tuxguitar, kguitar and other midi programs

    Hi,

    I had the same thing and fixed mine thus:

    from package manager install timidity

    then:

    tuxguitar/tools/settings/sound.......set midi port to -

    TiMidity port 0 #1 (or play around with the other ports till you find one that works.)
    Arch 2.6.28 on X86_64
    Hardy 2.6.24 on X86_64
    AMD Athlon(tm) 64 Processor 3200+
    Maxtor 6L160M0 (SATA) 160G ,NVIDIA G6200

  3. #3
    Join Date
    Nov 2008
    Beans
    3

    Re: no sound in tuxguitar, kguitar and other midi programs

    Thank You.
    I just needed to try all the ports.
    Most of them don't work, but some of them do.

    Now I just need to find a better sequencer or something,
    because there is still a little bit of lag and the sound quality isn't that good (it has artifacts).

    Do you have any idea what the problem might be?

    I am using TiMidity port 0 [128:0] and the TuxGuitar Sequencer.

    Thank You for already being a great help!

  4. #4
    Join Date
    May 2006
    Beans
    176
    Distro
    Xubuntu 8.04 Hardy Heron

    Re: no sound in tuxguitar, kguitar and other midi programs

    Quote Originally Posted by supertonsil View Post
    Now I just need to find a better sequencer or something,
    because there is still a little bit of lag and the sound quality isn't that good (it has artifacts).

    Do you have any idea what the problem might be?
    Does this happends also with tuxguitar-snapshot-jsa :

    http://rzr.online.fr/q/tuxguitar
    # http://rzr.online.fr/q/apt # test my deb's please
    # http://rzr.online.fr/q/ubuntu # contribs docs etc
    # http://rzr.online.fr/q/unicorn # works for me
    # http://go.cur.lv/files# files to be shared or email me

  5. #5
    Join Date
    Nov 2008
    Beans
    3

    Re: no sound in tuxguitar, kguitar and other midi programs

    This is quite a lot of effort to add another repository.
    Isn't there a way I could just download it somewhere and make?

  6. #6
    Join Date
    Jun 2008
    Beans
    7

    Thumbs up Re: no sound in tuxguitar, kguitar and other midi programs

    Thanks a lot this post helped me as well. Settings that worked for me was to use TiMidity port 1 #2. I guess each system is different and you just have to mess around till you get the right one.

  7. #7
    Join Date
    Sep 2007
    Beans
    24

    Re: no sound in tuxguitar, kguitar and other midi programs

    After installing timidity, still no port works for me. I have only some generic onboard sound card.
    EDIT. I just had to reboot. Workds fine now.
    Last edited by frostwyrm333; January 4th, 2009 at 01:38 AM.

  8. #8
    Join Date
    Jun 2010
    Beans
    1

    Talking Re: no sound in tuxguitar, kguitar and other midi programs

    hey i'm very new to kguitar and i need a guide or toturial to help me and i can't find one. can some of you guys help me find one plz!!

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •