Page 3 of 5 FirstFirst 12345 LastLast
Results 21 to 30 of 48

Thread: WORKAROUND: Setting Static IP 8.10

  1. #21
    Join Date
    Dec 2007
    Location
    The last place I look
    Beans
    Hidden!
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: WORKAROUND: Setting Static IP 8.10

    Quote Originally Posted by gigaferz View Post
    hello, sorry to bother (i just want to know)

    So, I have a static internal dhcp address wich is tied to my mac address.

    I logged into my router configuration webpage, and did it from there.

    Is it the same thing you guys are doing here???

    And no matter what os I use it has the same address because is tied (duh) to the hardware.
    Thnx!!

    well ive honestly tried thew pidgin irc but nobody ever replies to me.

    so I come here to haunt people

    no, their talking about turning off DHCP entirely, and configuring ubuntus IP settings manually.

    you have pointed out an interesting side affect of binding licenses to MACs (the multiple OS's). Most high end dhcp devices do that by default.
    I use static addresses on my net (it's small enough to get away with it), and usually manually configure both OSs on a dual boot to use the same IP.

  2. #22
    Join Date
    Dec 2008
    Beans
    18

    Re: WORKAROUND: Setting Static IP 8.10

    Quote Originally Posted by cupcrazy1027 View Post
    Manual workaround for setting static IP address bug in Ubuntu 8.10 Intrepid Ibex
    Thanks, cupcrazy. I did have one strange issue while doing this. The .conf file lost the changes I applied (yes, I saved, but it lost other data that was in there to begin with, also). I reapplied my changes and it worked that time. The workaround that involves adding a new configuration seemed to work for some and not for others. I was one of the others. Your workaround did the trick. Thanks again.

  3. #23
    Join Date
    Apr 2008
    Location
    Colorado
    Beans
    192
    Distro
    Ubuntu 8.10 Intrepid Ibex

    Re: WORKAROUND: Setting Static IP 8.10

    Hi,

    This looks like a work around. Can anyone tell me how to add a second card? It is already installed, but it seems that neither card is working. When I run ifconfig the output shows eth0 but not eth1, any ideas?

  4. #24
    Join Date
    Apr 2008
    Location
    Colorado
    Beans
    192
    Distro
    Ubuntu 8.10 Intrepid Ibex

    Re: WORKAROUND: Setting Static IP 8.10

    I received this answer in another thread, but I believe it would be very useful here.

    http://www.arachnoid.com/linux/Netwo...ger/index.html

    Good luck

  5. #25
    Join Date
    Feb 2007
    Beans
    Hidden!

    Just use WICD

    I have to put in another vote for WICD. Network Manager was such a buggy pain and WICD gave me easy static ip on my first try without reading any documentation. What a relief. wicd install
    Last edited by fido777; January 4th, 2009 at 07:35 PM.

  6. #26
    Join Date
    Jun 2008
    Location
    Glens Falls, NY
    Beans
    17
    Distro
    Ubuntu 8.10 Intrepid Ibex

    Re: WORKAROUND: Setting Static IP 8.10

    Thanks for the fix!

    If you're unable to use your router as a DNS forward and don't want to bother with your ISP's servers, OpenDNS (http://www.opendns.com) would be a decent alternative.

    Here's their servers if you're interested:
    208.67.222.222
    208.67.220.220

  7. #27
    Join Date
    Oct 2008
    Location
    ExodusHair<Čubura
    Beans
    4,272
    Distro
    Ubuntu Development Release

    Re: WORKAROUND: Setting Static IP 8.10

    You do not need to remove Network Manager.

    edit /etc/NetworkManager/nm-system-settings.conf so that it reads
    Code:
    [ifupdown]
    managed=false
    true=let NM manage Your connections
    false=do not let NM manege Your connections

    in System->Preferences->Sessions un-check "Network Manager"

    the rest is, pretty much the same as in "my book".

  8. #28
    Join Date
    May 2006
    Location
    Southern California
    Beans
    867
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: WORKAROUND: Setting Static IP 8.10

    Quote Originally Posted by zika View Post
    You do not need to remove Network Manager.

    edit /etc/NetworkManager/nm-system-settings.conf so that it reads
    Code:
    [ifupdown]
    managed=false
    true=let NM manage Your connections
    false=do not let NM manege Your connections

    in System->Preferences->Sessions un-check "Network Manager"

    the rest is, pretty much the same as in "my book".
    Apparently, it's not that easy.
    Mine is already set as above and I didn't change it...
    Code:
    [main]
    plugins=ifupdown,keyfile
    
    [ifupdown]
    managed=false
    (Master be/fe) ASUS P5KPL IPC, E5400, KVR800D2N6K2/2G, 8500GT, (2)PVR-150, A180, ATSC-115, U10.04, MythTV 0.23-fixes.

  9. #29
    Join Date
    Oct 2008
    Location
    ExodusHair<Čubura
    Beans
    4,272
    Distro
    Ubuntu Development Release

    Re: WORKAROUND: Setting Static IP 8.10

    Quote Originally Posted by NT4usB View Post
    Apparently, it's not that easy.
    Mine is already set as above and I didn't change it...
    Code:
    [main]
    plugins=ifupdown,keyfile
    
    [ifupdown]
    managed=false
    did You set manually Your /etc/network/interfaces? If Yes, that's the answer ... If No, then we'll have to dig further ...

  10. #30
    Join Date
    May 2006
    Location
    Southern California
    Beans
    867
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: WORKAROUND: Setting Static IP 8.10

    I have not edited /etc/network/interfaces manually.
    I did add a static IP address and delete the 'auto' entry using the GUI. It didn't stick after a restart.
    Code:
    ct@p42:/etc/network$ cat interfaces
    # This file describes the network interfaces available on your system
    # and how to activate them. For more information, see interfaces(5).
    
    # The loopback network interface
    auto lo
    iface lo inet loopback
    
    # The primary network interface
    auto eth0
    #iface eth0 inet dhcp
    ct@p42:/etc/network$ ls -al interfaces
    -rw-r--r-- 1 root root 269 2009-01-04 00:43 interfaces
    ct@p42:/etc/network$
    Last edited by NT4usB; January 6th, 2009 at 08:58 AM.
    (Master be/fe) ASUS P5KPL IPC, E5400, KVR800D2N6K2/2G, 8500GT, (2)PVR-150, A180, ATSC-115, U10.04, MythTV 0.23-fixes.

Page 3 of 5 FirstFirst 12345 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •