Page 1 of 2 12 LastLast
Results 1 to 10 of 19

Thread: Cannot mount truecrypt volume over network

  1. #1
    Join Date
    Oct 2008
    Beans
    11

    Cannot mount truecrypt volume over network

    Is it possible to mount a truecrypt container located on another computer on the local network? I'm connected to the other computer via ssh, but when I browse to the file container on the other computer, I get a "permission denied" error when I try to mount it. I am running truecrypt 6.1 and ubuntu 8.04.

  2. #2
    Join Date
    Apr 2007
    Location
    West Coast USA
    Beans
    Hidden!
    Distro
    Ubuntu 8.10 Intrepid Ibex

    Re: Cannot mount truecrypt volume over network

    Have you checked the permissions of the Truecrypt container on the other machine? Does it belong to another user?

    In a terminal, type: ls -l /location/of/truecrypt/container (/home/test/containers/container1, etc)
    Helping people crawl out of their Windoze...
    Please read THIS before asking if Anti-Virus and Firewalls are needed.

  3. #3
    Join Date
    Jun 2006
    Location
    Switzerland
    Beans
    Hidden!
    Distro
    Kubuntu Jaunty Jackalope (testing)

    Re: Cannot mount truecrypt volume over network

    use sshfs instead to mount the remote folder into the local filesystem.

  4. #4
    Join Date
    Oct 2008
    Beans
    11

    Re: Cannot mount truecrypt volume over network

    It seems that I have read/write permissions on the truecrypt container. I have also tried connecting to the other computer using sshfs and still get the 'permission denied' error when I attempt to mount the volume.

    I can even create a new truecrypt volume on the other computer over the network, just can't mount it.

  5. #5

    Re: Cannot mount truecrypt volume over network

    Quote Originally Posted by olepi View Post
    It seems that I have read/write permissions on the truecrypt container. I have also tried connecting to the other computer using sshfs and still get the 'permission denied' error when I attempt to mount the volume.

    I can even create a new truecrypt volume on the other computer over the network, just can't mount it.
    I'm having identical problems in 8.10.

  6. #6
    Join Date
    Nov 2008
    Beans
    1

    Re: Cannot mount truecrypt volume over network

    Quote Originally Posted by olepi View Post
    It seems that I have read/write permissions on the truecrypt container. I have also tried connecting to the other computer using sshfs and still get the 'permission denied' error when I attempt to mount the volume.

    I can even create a new truecrypt volume on the other computer over the network, just can't mount it.
    I am having the same issue. I can connect via sshfs and create new TC containers over the network. However, when I try to mount it I get a 'permission denied' error. I have also tried creating a container locally and I'm able to mount it. Then transferring the container over to my server and attempting to remount it but I get the same error. Anyone out there actually able to do this or get it working? Thanks.

  7. #7
    Join Date
    Apr 2007
    Location
    West Coast USA
    Beans
    Hidden!
    Distro
    Ubuntu 8.10 Intrepid Ibex

    Re: Cannot mount truecrypt volume over network

    Hey guys... you might want to try the Truecrypt forums: http://forums.truecrypt.org/

    Take Care and Good Luck

    PS. If you find a solution, be sure to post it back here and mark this as solved so everybody can use it
    Helping people crawl out of their Windoze...
    Please read THIS before asking if Anti-Virus and Firewalls are needed.

  8. #8
    Join Date
    Nov 2008
    Beans
    1

    Re: Cannot mount truecrypt volume over network

    Hi
    I did it like this :
    1. Mount the volume or container on the host machine with the option umask=000 , this allows to acces the volume as guest.
    2. share the folder for the network with samba

  9. #9
    Join Date
    May 2007
    Beans
    5

    Re: Cannot mount truecrypt volume over network

    To get TrueCrypt to work over a network, you need the mount option "allow_other" (and also setting "user_allow_other" in /etc/fuse.conf). I had the same problem when trying to access a TrueCrypt volume on a USB stick attached to a thin client (LTSP = Linux Terminal Server Project, often associated with Edubuntu). In my case the network file system is "ltspfs", for others it is sshfs or nfs. Check what it is for you.

    This is how I restarted ltspfs with the "allow_other" option (which mtab showed was missing):

    Code:
    sudo ltspfs 192.168.1.24:/var/run/drives/usbdisk-sdb1 /media/myusername/usbdisk-sdb1 -oallow_other
    (The IP address was assigned to the thin client by the DHCP server.) Now TrueCrypt can open the .tc file, and "mount" shows:

    Code:
    ltspfs on /media/myusername/usbdisk-sdb1 type fuse.ltspfs (rw,nosuid,nodev,allow_other)
    I have not figured out how to have "allow_other" automatically be set when mounting the USB stick over the network.

  10. #10
    Join Date
    Aug 2006
    Beans
    3

    Wink Resolved ---- Cannot mount truecrypt volume over network

    c|8^) Finally! Mounting Truecrypt Volumes across network, no more Permission denied: 8^) c|8^)

    8^) Edit fuse.conf and add one line, my command on next line.

    thomas@ubuntu:~$ sudo gedit /etc/fuse.conf

    8^) Add the line below to /etc/fuse.conf on its own line exactly as shown:

    user_allow_other



    8^) I used sshfs with the syntax shown below (DON'T FORGET SUDO!!!!)

    thomas@ubuntu:~$ sudo sshfs thomas@192.168.1.193:/ /home/thomas/mnt/tc -o allow_other


    8^) Happy mounting!!!

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •