Page 25 of 26 FirstFirst ... 1523242526 LastLast
Results 241 to 250 of 255

Thread: HOWTO: Install (G)FCEUX 2.0 NES emulator

  1. #241

    Re: HOWTO: Install (G)FCEUX 2.0 NES emulator

    Quote Originally Posted by punkrockguy318 View Post
    That message would indicate that the tty session that you are invoking fceux from is not able to access the X11 server. Are you running this as root or from within a screen/tmux session? You will likely be unable to run any other X11 applications from that tty session. Try running it from the X session directly and let me know what error message you are receiving -- the above error message is not an issue with fceux itself
    Ok, I need to emphasize again that I am new at this, so some of those terms are lost on me. When I say I'm running from Command Line, I guess technically I mean I'm running from shell (no graphical interface at all, just the prompt). I am running the program as user. I just tried running it again as root and it gave me the same warning but with a different number (13097).

    If I try to run FCEUX from the desktop (is that what you mean by screen session?), as in, double click the FCEUX icon, the program opens, but roms will not load.

    Thanks for the clarification, I'll do some more research on that X11 server business.

  2. #242
    Join Date
    Dec 2004
    Beans
    282

    Re: HOWTO: Install (G)FCEUX 2.0 NES emulator

    Quote Originally Posted by TheUniversalRemonster View Post
    Ok, I need to emphasize again that I am new at this, so some of those terms are lost on me. When I say I'm running from Command Line, I guess technically I mean I'm running from shell (no graphical interface at all, just the prompt). I am running the program as user. I just tried running it again as root and it gave me the same warning but with a different number (13097).

    If I try to run FCEUX from the desktop (is that what you mean by screen session?), as in, double click the FCEUX icon, the program opens, but roms will not load.

    Thanks for the clarification, I'll do some more research on that X11 server business.
    What's the error message you get when attempting to load a ROM from the GUI?

  3. #243

    Re: HOWTO: Install (G)FCEUX 2.0 NES emulator

    Quote Originally Posted by punkrockguy318 View Post
    What's the error message you get when attempting to load a ROM from the GUI?
    That's the frustrating part, there is no error message. Unless there's some kind of log that I'm not seeing. The fceux window just remains blank. That's why I tested the rom on my PC to make sure that wasn't the problem.

  4. #244
    Join Date
    Sep 2009
    Beans
    20

    Re: HOWTO: Install (G)FCEUX 2.0 NES emulator

    hallo, I get the following error when trying to compile from svn (2526) using scons.
    I have all necessary libraries installed on Ubuntu 12.04 64-bit

    scons: Reading SConscript files ...
    platform: posix
    Checking for inflate in C library z... (cached) yes
    Checking for C library SDL... (cached) yes
    Checking for C library gtk-x11-2.0... (cached) yes
    Checking for C library lua... (cached) no
    Checking for C library gd... (cached) no
    Did not find libgd, you won't be able to create a logo screen for your avis.
    Checking for C function asprintf()... (cached) yes
    Checking for C++ library GL... (cached) yes
    base CPPDEFINES: ['_GTK2', '_S9XLUA_H', 'PSS_STYLE=1', ['_GNU_SOURCE', '1'], '_REENTRANT', 'LSB_FIRST', 'FRAMESKIP']
    base CCFLAGS: ['-Wall', '-Wno-write-strings', '-Wno-sign-compare', '-Isrc/lua/src', '-pthread', '-D_GTK', '-DLUA_USE_LINUX', '-DHAVE_ASPRINTF', '-DOPENGL']
    ['-pthread']
    scons: done reading SConscript files.
    scons: Building targets ...
    g++ -o src/drivers/sdl/input.o -c -Wall -Wno-write-strings -Wno-sign-compare -Isrc/lua/src -pthread -D_GTK -DLUA_USE_LINUX -DHAVE_ASPRINTF -DOPENGL -g -D_GTK2 -D_S9XLUA_H -DPSS_STYLE=1 -D_GNU_SOURCE=1 -D_REENTRANT -DLSB_FIRST -DFRAMESKIP -D_DEBUG -DCREATE_AVI -I/usr/include/gtk-2.0 -I/usr/lib/x86_64-linux-gnu/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/pango-1.0 -I/usr/include/gio-unix-2.0 -I/usr/include/glib-2.0 -I/usr/lib/x86_64-linux-gnu/glib-2.0/include -I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/include/libpng12 -I/usr/include/SDL src/drivers/sdl/input.cpp
    src/drivers/sdl/input.cpp: In function 'void KeyboardCommands()':
    src/drivers/sdl/input.cpp:562:9: error: 'string' does not name a type
    src/drivers/sdl/input.cpp:563:49: error: 'movie_fname' was not declared in this scope
    src/drivers/sdl/input.cpp: In function 'void GetMouseData(uint32 (&)[3])':
    src/drivers/sdl/input.cpp:879:13: warning: unused variable 'event' [-Wunused-variable]
    src/drivers/sdl/input.cpp: In function 'void ButtonConfigEnd()':
    src/drivers/sdl/input.cpp:1033:18: warning: unused variable 'GameInfo' [-Wunused-variable]
    src/drivers/sdl/sdl-video.h: At global scope:
    src/drivers/sdl/sdl-video.h:6:21: warning: 's_screen' defined but not used [-Wunused-variable]
    src/drivers/sdl/sdl.h:9:13: warning: 'void DoFun(int)' declared 'static' but never defined [-Wunused-function]
    src/drivers/sdl/sdl.h:10:12: warning: 'isloaded' defined but not used [-Wunused-variable]
    scons: *** [src/drivers/sdl/input.o] Error 1
    scons: building terminated because of errors.

  5. #245
    Join Date
    Dec 2004
    Beans
    282

    Re: HOWTO: Install (G)FCEUX 2.0 NES emulator

    Quote Originally Posted by petran79 View Post
    hallo, I get the following error when trying to compile from svn (2526) using scons.
    I have all necessary libraries installed on Ubuntu 12.04 64-bit

    scons: Reading SConscript files ...
    platform: posix
    Checking for inflate in C library z... (cached) yes
    Checking for C library SDL... (cached) yes
    Checking for C library gtk-x11-2.0... (cached) yes
    Checking for C library lua... (cached) no
    Checking for C library gd... (cached) no
    Did not find libgd, you won't be able to create a logo screen for your avis.
    Checking for C function asprintf()... (cached) yes
    Checking for C++ library GL... (cached) yes
    base CPPDEFINES: ['_GTK2', '_S9XLUA_H', 'PSS_STYLE=1', ['_GNU_SOURCE', '1'], '_REENTRANT', 'LSB_FIRST', 'FRAMESKIP']
    base CCFLAGS: ['-Wall', '-Wno-write-strings', '-Wno-sign-compare', '-Isrc/lua/src', '-pthread', '-D_GTK', '-DLUA_USE_LINUX', '-DHAVE_ASPRINTF', '-DOPENGL']
    ['-pthread']
    scons: done reading SConscript files.
    scons: Building targets ...
    g++ -o src/drivers/sdl/input.o -c -Wall -Wno-write-strings -Wno-sign-compare -Isrc/lua/src -pthread -D_GTK -DLUA_USE_LINUX -DHAVE_ASPRINTF -DOPENGL -g -D_GTK2 -D_S9XLUA_H -DPSS_STYLE=1 -D_GNU_SOURCE=1 -D_REENTRANT -DLSB_FIRST -DFRAMESKIP -D_DEBUG -DCREATE_AVI -I/usr/include/gtk-2.0 -I/usr/lib/x86_64-linux-gnu/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/pango-1.0 -I/usr/include/gio-unix-2.0 -I/usr/include/glib-2.0 -I/usr/lib/x86_64-linux-gnu/glib-2.0/include -I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/include/libpng12 -I/usr/include/SDL src/drivers/sdl/input.cpp
    src/drivers/sdl/input.cpp: In function 'void KeyboardCommands()':
    src/drivers/sdl/input.cpp:562:9: error: 'string' does not name a type
    src/drivers/sdl/input.cpp:563:49: error: 'movie_fname' was not declared in this scope
    src/drivers/sdl/input.cpp: In function 'void GetMouseData(uint32 (&)[3])':
    src/drivers/sdl/input.cpp:879:13: warning: unused variable 'event' [-Wunused-variable]
    src/drivers/sdl/input.cpp: In function 'void ButtonConfigEnd()':
    src/drivers/sdl/input.cpp:1033:18: warning: unused variable 'GameInfo' [-Wunused-variable]
    src/drivers/sdl/sdl-video.h: At global scope:
    src/drivers/sdl/sdl-video.h:6:21: warning: 's_screen' defined but not used [-Wunused-variable]
    src/drivers/sdl/sdl.h:9:13: warning: 'void DoFun(int)' declared 'static' but never defined [-Wunused-function]
    src/drivers/sdl/sdl.h:10:12: warning: 'isloaded' defined but not used [-Wunused-variable]
    scons: *** [src/drivers/sdl/input.o] Error 1
    scons: building terminated because of errors.
    You'll want to ensure that you are building with the latest subversion code. I am unable to reproduce this issue with the latest source on 64 bit linux. At the time of posting, the latest revision is revision 2834, so you will want to "svn update" to the latest version.

  6. #246
    Join Date
    Sep 2009
    Beans
    20

    Re: HOWTO: Install (G)FCEUX 2.0 NES emulator

    ok I updated to the latest revision (2835), but while building got the following error:

    g++ -o src/drivers/sdl/sdl-opengl.o -c -Wall -Wno-write-strings -Wno-sign-compare -Isrc/lua/src -DHAVE_ASPRINTF -pthread -D_GTK -DLUA_USE_LINUX -DOPENGL -g -D_GTK2 -D_S9XLUA_H -DPSS_STYLE=1 -D_GNU_SOURCE=1 -D_REENTRANT -DLSB_FIRST -DFRAMESKIP -D_DEBUG -DCREATE_AVI -I/usr/include/gtk-2.0 -I/usr/lib/x86_64-linux-gnu/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/pango-1.0 -I/usr/include/gio-unix-2.0 -I/usr/include/glib-2.0 -I/usr/lib/x86_64-linux-gnu/glib-2.0/include -I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/include/libpng12 -I/usr/include/SDL src/drivers/sdl/sdl-opengl.cpp
    src/drivers/sdl/sdl.h:9:13: warning: 'void DoFun(int)' declared 'static' but never defined [-Wunused-function]
    src/drivers/sdl/sdl.h:10:12: warning: 'isloaded' defined but not used [-Wunused-variable]
    scons: *** [src/fceux] Implicit dependency `/usr/lib/x86_64-linux-gnu/libGL.so' not found, needed by target `src/fceux'.
    scons: building terminated because of errors.


    this libgl error was also in previous versions.
    probably due to this. problem is I need those drivers because closed source Nvidia solves some issues with video playback.
    http://sourceforge.net/mailarchive/m...sg_id=29448314

  7. #247
    Join Date
    Dec 2004
    Beans
    282

    Re: HOWTO: Install (G)FCEUX 2.0 NES emulator

    Quote Originally Posted by petran79 View Post
    ok I updated to the latest revision (2835), but while building got the following error:

    g++ -o src/drivers/sdl/sdl-opengl.o -c -Wall -Wno-write-strings -Wno-sign-compare -Isrc/lua/src -DHAVE_ASPRINTF -pthread -D_GTK -DLUA_USE_LINUX -DOPENGL -g -D_GTK2 -D_S9XLUA_H -DPSS_STYLE=1 -D_GNU_SOURCE=1 -D_REENTRANT -DLSB_FIRST -DFRAMESKIP -D_DEBUG -DCREATE_AVI -I/usr/include/gtk-2.0 -I/usr/lib/x86_64-linux-gnu/gtk-2.0/include -I/usr/include/atk-1.0 -I/usr/include/cairo -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/pango-1.0 -I/usr/include/gio-unix-2.0 -I/usr/include/glib-2.0 -I/usr/lib/x86_64-linux-gnu/glib-2.0/include -I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/include/libpng12 -I/usr/include/SDL src/drivers/sdl/sdl-opengl.cpp
    src/drivers/sdl/sdl.h:9:13: warning: 'void DoFun(int)' declared 'static' but never defined [-Wunused-function]
    src/drivers/sdl/sdl.h:10:12: warning: 'isloaded' defined but not used [-Wunused-variable]
    scons: *** [src/fceux] Implicit dependency `/usr/lib/x86_64-linux-gnu/libGL.so' not found, needed by target `src/fceux'.
    scons: building terminated because of errors.


    this libgl error was also in previous versions.
    probably due to this. problem is I need those drivers because closed source Nvidia solves some issues with video playback.
    http://sourceforge.net/mailarchive/m...sg_id=29448314
    You need to have libGL on your system. If you have installed the nvidia proprietary drivers, you should already have this on your system. If not, you may need to install mesa to supply libGL

    The issue that you have linked has already been resolved and is not relevant to the issue you are experiencing.

  8. #248
    Join Date
    Sep 2009
    Beans
    20

    Re: HOWTO: Install (G)FCEUX 2.0 NES emulator

    Quote Originally Posted by punkrockguy318 View Post
    You need to have libGL on your system. If you have installed the nvidia proprietary drivers, you should already have this on your system. If not, you may need to install mesa to supply libGL

    The issue that you have linked has already been resolved and is not relevant to the issue you are experiencing.
    since I already have both the latest version of Nvidia and mesa, yet still get this error, it hasnt been resolved yet,

  9. #249
    Join Date
    Dec 2004
    Beans
    282

    Re: HOWTO: Install (G)FCEUX 2.0 NES emulator

    Quote Originally Posted by petran79 View Post
    since I already have both the latest version of Nvidia and mesa, yet still get this error, it hasnt been resolved yet,

    the error you are receiving is a completely different error than what you referenced from the mailing list. you need to have libgl on your system. ive compiled and run latest svn across multiple versions of ubuntu with nvidia drivers. make sure you have all the proper dependencies (apt-get build-dep fceux might help)

  10. #250
    Join Date
    Sep 2009
    Beans
    20

    Re: HOWTO: Install (G)FCEUX 2.0 NES emulator

    Quote Originally Posted by punkrockguy318 View Post
    the error you are receiving is a completely different error than what you referenced from the mailing list. you need to have libgl on your system. ive compiled and run latest svn across multiple versions of ubuntu with nvidia drivers. make sure you have all the proper dependencies (apt-get build-dep fceux might help)
    does it matter whether they are open or closed source drivers? I have the closed source ones and perhaps this might be the problem, as seen in the article I linked.

    because other OpenGL applications and emulators work without issues.

Page 25 of 26 FirstFirst ... 1523242526 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •