Page 3 of 3 FirstFirst 123
Results 21 to 24 of 24

Thread: Missing "application/x-font-ttf"

  1. #21
    Join Date
    Jul 2007
    Beans
    4
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: Missing "application/x-font-ttf"

    I was able to get font thumbnails working by using Saisombun's instructions, then adding the appropriate gconf entries to enable the thumbnailer. The gconf instructions are here:
    http://library.gnome.org/devel/integ...nailer.html.en
    but they don't explain how to add new entries, something which I have never done before. After a good deal of searching around, I was able to figure out how to use gconftool-2 to add the necessary entries.

    Here are the complete instructions to enable font previews in nautilus:

    1. If you have not followed Saisombun's instructions to install the gnome-thumbnail-font binary, do that first. They are in the post directly previous to this.

    2. Open a terminal window as the user you want to enable font thumbnails for (you will need to enable thumbnails for each user individually).

    3. Type the following to add an entry for "application/x-font-ttf" to gconf:
    Code:
    gconftool-2 -t bool -s /desktop/gnome/thumbnailers/application@x-font-ttf/enable true
    4. Now add the actual command.
    Code:
    gconftool-2 -t string -s /desktop/gnome/thumbnailers/application@x-font-ttf/command 'gnome-thumbnail-font --size %s %i %o'
    You can specify your own custom preview text by adding the --text custom tag to the gnome-thumbnail-font command (put it before the %i). Here is an example that shows a preview of AaZz instead of just Aa:
    Code:
    gconftool-2 -t string -s /desktop/gnome/thumbnailers/application@x-font-ttf/command 'gnome-thumbnail-font --size %s --text AaZz %i %o'

  2. #22
    Join Date
    Feb 2009
    Beans
    5
    Distro
    Ubuntu 8.10 Intrepid Ibex

    Re: Missing "application/x-font-ttf"

    Yessss! It works!!

    Thank you, blendenzo! That's what I missed and finally thought that the problem was somewhere in 2.24 gnome-vfs... It's great to know, that everything is much simpler. A very useful information. Respect!

  3. #23
    Join Date
    Feb 2009
    Beans
    5
    Distro
    Ubuntu 8.10 Intrepid Ibex

    Re: Missing "application/x-font-ttf"

    One small addition. If you want to see thumbnails not only for TTF fonts, but, for example, for Open Type Fonts as well, add the same keys as Blendenzo explained, but change MIME-type from x-font-ttf to x-font-otf, i.e.:

    Code:
    gconftool-2 -t bool -s /desktop/gnome/thumbnailers/application@x-font-otf/enable true
    
    gconftool-2 -t string -s /desktop/gnome/thumbnailers/application@x-font-otf/command 'gnome-thumbnail-font --size %s %i %o'

  4. #24
    Join Date
    Feb 2009
    Location
    Spain
    Beans
    14
    Distro
    Ubuntu

    Something was happen!

    Due to a recent update (both XFCE and Gnome installed) I was susprised. I haven't done the trick of GConf, just installed Gnome a week ago, and now thumbnails are back (look screenshot)!
    Attached Images Attached Images

Page 3 of 3 FirstFirst 123

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •