Page 5 of 89 FirstFirst ... 345671555 ... LastLast
Results 41 to 50 of 884

Thread: Wacom tablets in Ubuntu guide/howto

  1. #41
    Join Date
    Dec 2005
    Location
    New Zealand
    Beans
    104
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: Wacom tablets in Ubuntu guide/howto

    I'm a little confused by the file locations you're listing..

    The main fdi file that configures the tablet on hotplug should be at

    /usr/share/hal/fdi/policy/20thirdparty/10-wacom.fdi

    If you make an additional custom fdi file it should be placed in

    /etc/hal/fdi/policy/

    Can you confirm these file locations?

  2. #42
    Join Date
    Jun 2006
    Beans
    100

    Re: Wacom tablets in Ubuntu guide/howto

    You can try to find it with the brute force way:
    cd /
    sudo find | grep .fdi > /tmp/fdi

    Then open the resulting file and see if you find anything that could look like a wacom fdi file (you could also do sudo find | grep wacom.fdi , but you might have given your file another name).

    Alternatively you could just configure it in xorg.conf and be done with (that way you can use the pad and the eraser). The fdi method is only useful if for whatever reason you don't want to plug your tablet at boot. If you can keep it plug, or just plug it at boot and then suspend, even unplugging it then plugging it again would be ok.

    The guide for .fdi was made when we wrongly assumed it would be the future configuration file for wacom tablets, but since it won't be used after Intrepid (you'll still be able to use it if you prefer, but that won't be the default method) the .fdi method isn't so relevant anymore (for wacom tablets at least).

  3. #43
    Join Date
    Aug 2007
    Location
    Portland, OR
    Beans
    6
    Distro
    Ubuntu Karmic Koala (testing)

    Re: Wacom tablets in Ubuntu guide/howto

    Why this took me so long is beyond my comprehension... but I finally got my Toshiba R25-S3513 tablet PC working. What gets me is that the solution was EXACTLY what was put before, it just took a while for me to get working.

    Here is the problem I was having (note: past tense, problem solved just being added for future reference). I would edit the xorg.conf file for my tablet PC, save the file, and then restart. X apparently had a fatal problem with the file because, after restarting, it just showed a command line. I had copied a backup of the default xorg.conf, so I just typed in my "sudo cp /etc/X11/xorg.conf.default /etc/X11/xorg.conf" then "sudo reboot" and after the restart it signed me back into Ubuntu no problems.

    So, I go back, read through the wiki and some of the posts, try (from scratch) to edit my xorg.conf. Long story short(er), I did this 3 or 4 times.

    The ONLY thing I did different this time around was I didn't restart. Not sure if I was just making typos the first half a dozen times, but just (AFTER SAVING ALL YOUR WORK) pressing ctrl+alt+backspace seemed to work best for me. Picked up my stylus, eraser, etc without any problems. For a split second, I thought it was going to have me use the command line again, but it showed the graphic login screen and I was a happy, happy man.
    Here is my current xorg.conf file, in all it's functional glory (I spared you all the common, commented-out header stuff).

    Code:
    Section "Device"
    	Identifier	"Configured Video Device"
    EndSection
    
    Section "Monitor"
    	Identifier	"Configured Monitor"
    EndSection
    
    Section "Screen"
    	Identifier	"Default Screen"
    	Monitor		"Configured Monitor"
    	Device		"Configured Video Device"
    EndSection
    
    # Retropad (classic NES controller converted into a USB controller)
    Section "InputDevice"
    	Identifier	"RetroPad 1"
    	Driver		"joystick"
    	Option		"Device"		"/dev/input/js0"
    	Option		"DebugLevel"		"0"
    	Option		"StartKeysEnabled"	"True"
    	Option		"StartMouseEnabled"	"True"
    	Option		"MapButton1"		"button=1"
    	Option		"MapButton2"		"button=2"
    	Option		"MapButton3"		"button=3"
    	Option		"MapButton4"		"button=4"
    	Option		"MapAxis1"		"mode=relative	axis=+1x	deadzone=5000"
    	Option		"MapAxis2"		"mode=relative	axis=+1y	deadzone=5000"
    EndSection
    
    #wacom tablet attempt
    Section "InputDevice"
    	Identifier	"stylus"
    	Driver		"wacom"
    	Option		"Device"		"/dev/ttyS0"
    	Option		"Type"			"stylus"
    	Option		"ForceDevice"		"ISDV4"
    EndSection
    
    Section "InputDevice"
    	Identifier	"eraser"
    	Driver		"wacom"
    	Option		"Device"		"/dev/ttyS0"
    	Option		"Type"			"eraser"
    	Option		"ForceDevice"		"ISDV4"
    EndSection
    
    Section "InputDevice"
    	Identifier	"cursor"
    	Driver		"wacom"
    	Option		"Device"		"/dev/ttyS0"
    	Option		"Type"			"cursor"
    	Option		"ForceDevice"		"ISDV4"
    EndSection
    
    Section "ServerLayout"
    	Identifier	"Default Layout"
    	Screen		"Default Screen"
    	InputDevice 	"stylus"		"SendCoreEvents"
    	InputDevice 	"eraser"		"SendCoreEvents"
    	InputDevice 	"cursor"		"SendCoreEvents"
    EndSection
    I just wanted to give a huge THANK YOU for everyone on this thread and who work on the wiki for giving me the information I needed to get this working again. This works SO MUCH better than in Hardy for me.

    Oh, and maybe I should have removed the retropad part of my xorg.conf file, but for anyone who buys that Retrozone retropad (classic NES controller that has been converted to a USB controller) it might be nice if google tags this post anyway, since I had to experiment a bit before getting this thing to work for me. [/rant] thanks again all.
    Last edited by interknighterrant; November 29th, 2008 at 12:21 AM.

  4. #44
    Join Date
    Nov 2008
    Beans
    19

    Re: Wacom tablets in Ubuntu guide/howto

    Quote Originally Posted by mesilliac View Post
    I'm a little confused by the file locations you're listing..

    The main fdi file that configures the tablet on hotplug should be at

    /usr/share/hal/fdi/policy/20thirdparty/10-wacom.fdi

    If you make an additional custom fdi file it should be placed in

    /etc/hal/fdi/policy/

    Can you confirm these file locations?
    Thanks for that clearance
    Somehow I've missed this in the guide, now when I added the lines for the buttons in the
    /etc/hal/fdi/policy/custom_wacom.fdi
    everything work as expected
    Thanks again!

  5. #45
    Join Date
    Jun 2006
    Beans
    100

    Re: Wacom tablets in Ubuntu guide/howto

    Quote Originally Posted by interknighterrant View Post
    Oh, and maybe I should have removed the retropad part of my xorg.conf file, but for anyone who buys that Retrozone retropad (classic NES controller that has been converted to a USB controller) it might be nice if google tags this post anyway, since I had to experiment a bit before getting this thing to work for me. [/rant] thanks again all.
    That's nice. I'm sure it would be piked up by Google if you created a wiki page, for example at https://help.ubuntu.com/community/RetrozoneRetropad - while there's not much chance it would be found in this thread

    Then we can add it to https://help.ubuntu.com/community/InputDevices (just need to create a Gamepad section).

    If you want a model, click Edit on any wiki page you want to imitate the layout, then paste it in the page you want to create, and just replace the paragraphs you want to replace. Ask us if you need some help with the wiki.

  6. #46
    Join Date
    Dec 2008
    Beans
    1

    Re: Wacom tablets in Ubuntu guide/howto

    I just went through the "make stylus work" on my m275 process. Essentially, I copied and pasted 123marra's xorg.conf and pasted it over mine. The problem i'm having is that my trackpad's verticle scroll doesn't work anymore and also, I can't grab the scrollbar by double-clicking to drag it down. I'm xubuntu and an m275. This is really annoying, thanks for the help.

  7. #47
    Join Date
    Jun 2006
    Beans
    100

    Re: Wacom tablets in Ubuntu guide/howto

    tennisaddict, I don't know trackpads a lot, but could you please your whole xorg.conf (just attach it) so one can have a look? Hopefully you can also post the xorg.conf that was working before doing some modifications.

    Alternatively, after you've backed up your xorg.conf, unplugged any external screen, and made sure you've got a live CD handy or another Linux install on the hard drive, you can do :
    Code:
    sudo dpkg-reconfigure -phigh xserver-xorg
    Which will revert your xorg.cong to your original configuration (you'll lose the wacom configuration, but you can try again after you've recovered your trackpad).

  8. #48
    Join Date
    Aug 2008
    Beans
    28
    Distro
    Lubuntu 13.04 Raring Ringtail

    Re: Wacom tablets in Ubuntu guide/howto

    I'm having trouble getting the stylus to work on a Compaq TC1000 Tablet. I followed all the instructions here and on the community pages, but am getting a complete blowup when I hit the CTRL-ALT-BKSPACE keys.

    Here is my xorg.conf file:

    Code:
    # xorg.conf (X.Org X Window System server configuration file)
    #
    # This file was generated by dexconf, the Debian X Configuration tool, using
    # values from the debconf database.
    #
    # Edit this file with caution, and see the xorg.conf manual page.
    # (Type "man xorg.conf" at the shell prompt.)
    #
    # This file is automatically updated on xserver-xorg package upgrades *only*
    # if it has not been modified since the last upgrade of the xserver-xorg
    # package.
    #
    # Note that some configuration settings that could be done previously
    # in this file, now are automatically configured by the server and settings
    # here are ignored.
    #
    # If you have edited this file but would like it to be automatically updated
    # again, run the following command:
    #   sudo dpkg-reconfigure -phigh xserver-xorg
    
    Section "Device"
    	Identifier	"Configured Video Device"
    EndSection
    
    Section "Monitor"
    	Identifier	"Configured Monitor"
    EndSection
    
    Section "Screen"
    	Identifier	"Default Screen"
    	Monitor		"Configured Monitor"
    	Device		"Configured Video Device"
    EndSection
    
    Section "InputDevice"
      Driver        "wacom"
      Identifier    "stylus"
      Option        "Device"        "/dev/ttyS0"      # SERIAL ONLY
      Option        "Type"          "stylus"
      Option        "ForceDevice"   "ISDV4"           # Tablet PC ONLY
    EndSection
    
    Section "InputDevice"
      Driver        "wacom"
      Identifier    "eraser"
      Option        "Device"        "/dev/ttyS0"      # SERIAL ONLY
      Option        "Type"          "eraser"
      Option        "ForceDevice"   "ISDV4"           # Tablet PC ONLY
    EndSection
    
    Section "InputDevice"
      Driver        "wacom"
      Identifier    "cursor"
      Option        "Device"        "/dev/ttyS0"      # SERIAL ONLY
      Option        "Type"          "cursor"
      Option        "ForceDevice"   "ISDV4"           # Tablet PC ONLY
    EndSection
    
    Section "ServerLayout"
      Identifier    "Default Layout"
      Screen        "Default Screen"
      InputDevice   "stylus"  "SendCoreEvents"
      InputDevice   "eraser"  "SendCoreEvents"
      InputDevice   "cursor"  "SendCoreEvents" # For non-LCD tablets only
    EndSection
    When I hit the CTRL-ALT-BKSPACE keys, it restarts and gives me an error box saying it is running low-resolution graphics and cannot restart. It then gives me some options to fix the graphics problem. If I push through without changing the graphics, I get a screen that I can't read.

    Any help would be greatly appreciated.

  9. #49
    Join Date
    Jun 2006
    Beans
    100

    Re: Wacom tablets in Ubuntu guide/howto

    With a TabletPC, you shouldn't have a "cursor" section so just comment (add a # at the beginning of the lines) the "cursor" section and the "cursor" line in "ServerLayout".

    If your stylus doesn't have an eraser at the back, do the same for "eraser".

    I'm assuming your original xorg.conf was only including the sections "Device",
    "Monitor" and "Screen" (and not "ServerLayout"), please correct me if I'm wrong, and that you didn't change anything to these sections.

    Fist try with the modifications suggested above. Then if it doesn't work just comment anything after the "Screen" section and try uncommenting the ServerLayout section while commenting everything inside except the lines Identifier and Screen.

    When you get errors, try choosing the "repair" or "troubleshoot" options, I can't remember the names, but there's a way to see the logs. Try checking error messages in those (or attach - don't copy paste - the file /var/log/Xorg.0.log).

    If you know Linux a bit, you can also go to a console (CTRL-ALT-F1, use CTRL-ALT-F7 to go back to X), stop gdm ( sudo /etc/init.d/gdm stop , or sudo killall gdm if you enjoy it) then start X with the startx command and you'll see the error messages in the console (that's how I found out xorg.conf need the Identifier and Screen lines in the "ServerLayout" section, even though there's nothing in a default Intrepid xorg.conf).
    Last edited by Lo´c2; December 9th, 2008 at 12:54 PM.

  10. #50
    Join Date
    Aug 2008
    Beans
    28
    Distro
    Lubuntu 13.04 Raring Ringtail

    Re: Wacom tablets in Ubuntu guide/howto

    Thanks for your fast reply, Loic2.

    Okay, I tried what you suggested. BTW, your assumptions about the original xorg.conf file is correct.

    I'm still getting errors, but was able to Troubleshoot and archive the xorg.0.log file. Here it is (it's not too long, so I'll just cut and paste):

    Code:
    X.Org X Server 1.5.2
    Release Date: 10 October 2008
    X Protocol Version 11, Revision 0
    Build Operating System: Linux 2.6.24-19-server i686 Ubuntu
    Current Operating System: Linux linux-tablet 2.6.27-7-generic #1 SMP Tue Nov 4 19:33:20 UTC 2008 i586
    Build Date: 24 October 2008  08:00:16AM
    xorg-server 2:1.5.2-2ubuntu3 (buildd@rothera.buildd) 
    	Before reporting problems, check http://wiki.x.org
    	to make sure that you have the latest version.
    Module Loader present
    Markers: (--) probed, (**) from config file, (==) default setting,
    	(++) from command line, (!!) notice, (II) informational,
    	(WW) warning, (EE) error, (NI) not implemented, (??) unknown.
    (==) Log file: "/var/log/Xorg.0.log", Time: Tue Dec  9 20:01:43 2008
    (==) Using config file: "/etc/X11/xorg.conf"
    Parse error on line 64 of section ServerLayout in file /etc/X11/xorg.conf
    	Unexpected EOF. Missing EndSection keyword?
    (EE) Problem parsing the config file
    (EE) Error parsing the config file
    
    Fatal server error:
    no screens found
    (WW) xf86CloseConsole: KDSETMODE failed: Bad file descriptor
    (WW) xf86CloseConsole: VT_GETMODE failed: Bad file descriptor
    (WW) xf86OpenConsole: VT_GETSTATE failed: Bad file descriptor
    Unexpected EOF. End of File? Missing EndSection? Line 64 (I think) is the EndSection line. I don't understand. Am I missing some more code?

    Also, I don't know if it matters or not, but I am running Xubuntu 8.10, not Ubuntu, on this tablet.

    Any ideas?
    Attached Files Attached Files

Page 5 of 89 FirstFirst ... 345671555 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •