Page 3 of 89 FirstFirst 123451353 ... LastLast
Results 21 to 30 of 883

Thread: Wacom tablets in Ubuntu guide/howto

  1. #21
    Join Date
    Jun 2006
    Beans
    100

    Re: Wacom tablets in Ubuntu guide/howto

    mesilliac, thanks for your quick reply. The user might have tried to compile it.
    I've seen this line on some howtos:
    Code:
    ./configure --enable-wacom --prefix=/usr
    instead of just ./configure. Maybe it's the problem?

    minibeardeath, you can try with mesilliac's method at https://help.ubuntu.com/community/Wacom/LatestDriver (Using the Pre-built binaries).
    Last edited by Loc2; November 11th, 2008 at 11:58 PM.

  2. #22
    Join Date
    Dec 2005
    Location
    New Zealand
    Beans
    104
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: Wacom tablets in Ubuntu guide/howto

    With ./configure too, the X driver goes in the right place. It's just the tools such as wacomcpl, xidump etc that get put in /usr/local. I'll add it to the configure line, to be consistent with the ubuntu package, but leaving it out won't cause problems with the driver.

    --enable-wacom enables building of the kernel module, which usually isn't necessary. I'll add a line explaining this.

  3. #23
    Join Date
    Jun 2006
    Beans
    100

    Re: Wacom tablets in Ubuntu guide/howto

    Thank you. Hopefully it can help clarify the different contradicting information people get on the forums (not just Ubuntu forums)

  4. #24
    Join Date
    Feb 2008
    Location
    California
    Beans
    129
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: Wacom tablets in Ubuntu guide/howto

    So the more I'm playing with this, the more I'm seeing that GIMP 2.6.1 isn't registering the PRESSURE at all, JUST the velocity. That bums me out. I use the pressure more than the velocity. Should I just go ahead and do the old-school XORG.conf work-around or what?

    *EDIT* Upon looking, GIMP doesn't even list the tablet in the Extended Input Devices. I'm going to sac hot-swap ability for, you know, a properly functioning tablet.

    *EDIT 2* Okay, simple enough. I edited xorg.conf and put in all the wacom fiddly bits and it shows up in GIMP 2.6.1 as "Wacom Bamboo" just fine, now. No muss. No fuss. Hot-swapping still works.

    Here's what I did:

    First, like any good Linux user, I made a wacom directory, then created a backup of my xorg.conf file in that directory in case I did Very Bad Things to my xserver.
    Code:
    mkdir wacom
    cd wacom
    sudo cp /etc/X11/xorg.conf .
    sudo gedit /etc/X11/xorg.conf
    Then, I edited the xorg.conf file. Added the following after Section "Screen" obtained from Wacom Troubleshooting Help:

    Code:
    Section "InputDevice"
      Driver        "wacom"
      Identifier    "stylus"
      Option        "Device"        "/dev/input/wacom" # USB ONLY?
    #  Option        "Device"        "/dev/ttyS0"      # SERIAL ONLY
      Option        "Type"          "stylus"
    #  Option        "ForceDevice"   "ISDV4"           # Tablet PC ONLY
      Option        "USB"           "on"               # USB ONLY
    EndSection
    
    Section "InputDevice"
      Driver        "wacom"
      Identifier    "eraser"
      Option        "Device"        "/dev/input/wacom" # USB ONLY?
    #  Option        "Device"        "/dev/ttyS0"      # SERIAL ONLY
      Option        "Type"          "eraser"
    #  Option        "ForceDevice"   "ISDV4"           # Tablet PC ONLY
      Option        "USB"           "on"               # USB ONLY
    EndSection
    
    Section "InputDevice"
      Driver        "wacom"
      Identifier    "cursor"
      Option        "Device"        "/dev/input/wacom" # USB ONLY?
    #  Option        "Device"        "/dev/ttyS0"      # SERIAL ONLY
      Option        "Type"          "cursor"
    #  Option        "ForceDevice"   "ISDV4"           # Tablet PC ONLY
      Option        "USB"           "on"               # USB ONLY
    EndSection
    
    Section "InputDevice"
      Driver        "wacom"
      Identifier    "pad"
      Option        "Device"        "/dev/input/wacom"    # USB ONLY
    #  Option        "Device"        "/dev/ttyS0"         # SERIAL ONLY
      Option        "Type"          "pad"
      Option        "USB"           "on"                  # USB ONLY
    EndSection
    Save, quit gEdit. CTRL+ALT+Backspace to reboot xserver et VOILA. GIMP now recognizes tablet with pressure AND velocity and hot-swapping still works. Bonus. Took like two minutes and it works for me. Your results may vary.

    Also I'm using the included version of the wacom drivers, which is 0.8.1.4-0ubuntu3.
    Last edited by Xfcn; November 13th, 2008 at 04:57 PM. Reason: Didn't have EndSection code.
    (Laptop) Dell Inspiron E1505 | 1GB RAM | ATI Radeon X1400 | Ubuntu Hardy Heron 8.04 | Intel Core Duo @ 1.83 Ghz
    Now #1 in a Google search for Xfcn. How sad is that? [Accurate as of 18:34 July 21,2008]

  5. #25
    Join Date
    Jun 2006
    Beans
    100

    Re: Wacom tablets in Ubuntu guide/howto

    Happy to know it works for you now

    Your xorg.conf extract is perfect, except it lacks the "ServerLayout" part...

  6. #26
    Join Date
    Feb 2008
    Location
    California
    Beans
    129
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: Wacom tablets in Ubuntu guide/howto

    Xorg doesn't seem to care terribly much about having it there, for whatever reason. I'll add it a bit later and let you know if it's all still working.
    (Laptop) Dell Inspiron E1505 | 1GB RAM | ATI Radeon X1400 | Ubuntu Hardy Heron 8.04 | Intel Core Duo @ 1.83 Ghz
    Now #1 in a Google search for Xfcn. How sad is that? [Accurate as of 18:34 July 21,2008]

  7. #27
    Join Date
    Mar 2008
    Location
    Anderson, IN
    Beans
    55
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Wacom tablets in Ubuntu guide/howto

    Ummm... Okay this is weird. I upgraded to 8,10 today and did the hole ordeal and ever thing you know, but my graphire 2 is only partly working! My pen works fine but when I try to use my mouse it doesn't even recognize that I have it one the tablet. need some help?

  8. #28
    Join Date
    Jun 2006
    Beans
    100

    Re: Wacom tablets in Ubuntu guide/howto

    Quote Originally Posted by Malvazar View Post
    Ummm... Okay this is weird. I upgraded to 8,10 today and did the hole ordeal and ever thing you know, but my graphire 2 is only partly working! My pen works fine but when I try to use my mouse it doesn't even recognize that I have it one the tablet. need some help?
    That's hardly enough information.

    Did you edit /etc/X11/xorg.conf, and can you attach it here?
    "and ever thing you know" : for a Graphire 2, AFAIK, that's just editing the xorg.conf, nothing else. If you did something else, that may be the cause of the problem.

  9. #29
    Join Date
    Dec 2005
    Location
    New Zealand
    Beans
    104
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: Wacom tablets in Ubuntu guide/howto

    I've been playing around with tablet settings, hotplugging, HAL, xorg.conf, and I found some things out:

    You can configure your tablet using both the default (HAL/.fdi) way, and through xorg.conf at the same time.

    For xorg.conf setup to be recognised the tablet must be connected / plugged in / turned on when you log in.

    If you hotplug your tablet after this, it will connect (stylus only) and work as in Option A.

    With xorg.conf configured also, you can now do the old trick of switching to another virtual terminal and back: CTRL-ALT-F6 then CTRL-ALT-F7. This gives you the usual tablet functionality provided via Option B.

    In this way, disabling "AutoAddDevices" in xorg.conf is definitely not needed. Furthermore, configuring via xorg.conf does not remove hotplug functionality.

    I'd heard a couple reports to this effect, but what was going on was a little confusing. I hope this helps to clarify a bit.

  10. #30
    Join Date
    Sep 2008
    Location
    Ohio
    Beans
    582

    Re: Wacom tablets in Ubuntu guide/howto

    It would be nice if hotplugging worked for the mouse on the tablet. Yes, I use it lol

Page 3 of 89 FirstFirst 123451353 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •