Page 2 of 89 FirstFirst 12341252 ... LastLast
Results 11 to 20 of 884

Thread: Wacom tablets in Ubuntu guide/howto

  1. #11
    Join Date
    Dec 2005
    Location
    New Zealand
    Beans
    104
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: Wacom tablets in Ubuntu guide/howto

    I was curious so I looked - ubuntu has a virtual keyboared installed by default but hidden. You can show the menu items for it by going to System > Preferences > Main Menu and enabling "onBoard" (seems to be under preferences for some reason).

    For handwriting recognition you can use "cellwriter". Install it via Add/Remove, or using synaptic (System > Administration > Synaptic Package Manager).

    I heard a while ago that "xournal" is a good journal / note taking app, but I've never used it myself (again, install using either add/remove or synaptic).
    Last edited by mesilliac; November 5th, 2008 at 12:34 AM.

  2. #12
    Join Date
    Jun 2006
    Beans
    100

    Re: Wacom tablets in Ubuntu guide/howto

    mesilliac, thanks for correcting my mistakes. I edited my post and linked to your post ion both this thread and the guide. Your explanation on installing/deinstalling wacom drivers from the LWP is really good an clear, it would certainly help others if you could add it to the guide. Considering you already know the formating on the forums, it should be pretty straightforward - and me doing it would be a copy-paste in this case (which wouldn't be fair) since everything is there.

    @123marra
    For tablets apps, I did a bit of search, and indeed CellWriter is often advised. You'll get more apps on http://luke.no-ip.org/x60tablet/ (just scroll to the bottom of the page.

    Hw recognition seems still limited to grid recognition, you can't link letters (yet) which is behind what exists elsewhere.

    Summary of apps:
    HW recognition :
    CellWriter http://risujin.org/cellwriter/ it's in the repos, so just
    Code:
    sudo apt-get install cellwriter
    On-screen kb (mesilliac's one is already included, so maybe that's not so useful):
    gok (Gnome, maybe the included one?), klavier (KDE), onscreen

    Other :
    Xournal, often cited, can annotate PDF (no hw recognition)
    Code:
    sudo apt-get install xournal
    But as I said, the link above does a far better job, and links more apps, see especially http://groundstate.ca/tabletsoft and check onenote (haven't been able to connect to their website though).

    Basically, once you have a good setup, you can edit the page at https://help.ubuntu.com/community/TabletPC and add your experience - at the moment it's quite empty, and I'm sure many users face similar problems as you encounter.

    Since I don't own any Tablet PC, I can't do the same as for Wacom tablets - only somebody that uses a Tablet will know what really work! I'm also interested in this subject, but unless Lenovo creates a 13,3' Thinkpad Tablet PC and prices it aggressively (<1000$, compared to their ~2000$ T60 ) I'll keep sitting on the fence...
    Last edited by Loc2; November 5th, 2008 at 01:13 AM.

  3. #13
    Join Date
    Jun 2006
    Beans
    100

    Re: Wacom tablets in Ubuntu guide/howto

    I did a big update on the Example Lines for /etc/X11/xorg.conf to better support serial tablet and Tablet PC users + verified there's no need for
    Code:
    Option "AutoAddDevices" "False"
    However, since the configuration on The Linux Wacom Project is quite outdated, I need someone with a Tablet Pc or a serial tablet to tell me where there wacom device appears in /dev/ - is it still /dev/wacom, or is it now /dev/input/wacom like on USB tablets? The LWP doc points to "/dev/ttyS0" , which isn't always wrong by see, but is going to be a pain each time the number changes.

    I also updated the guide and a few other wacom-related pages as well. And I asked upstream for the future of wacom devices configuration... which for them seems xorg.conf (along with a big white beard la ZZ Top).
    Last edited by Loc2; November 8th, 2008 at 06:14 PM.

  4. #14
    Join Date
    Feb 2008
    Location
    California
    Beans
    129
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: Wacom tablets in Ubuntu guide/howto

    Well with my Wacom Bamboo and 8.10 on my Dell Inspiron E1505, I've got it working just fine with the default setup. I'd like to keep the ability to hot-swap, but I'd also like to be able to change the cursor speed. Right now it moves faster than I'd like.
    (Laptop) Dell Inspiron E1505 | 1GB RAM | ATI Radeon X1400 | Ubuntu Hardy Heron 8.04 | Intel Core Duo @ 1.83 Ghz
    Now #1 in a Google search for Xfcn. How sad is that? [Accurate as of 18:34 July 21,2008]

  5. #15
    Join Date
    Nov 2008
    Beans
    4

    Re: Wacom tablets in Ubuntu guide/howto

    Dear Loic2,

    You were right about the sudo command. I got confused and mixed things up. Sorry for it.

    Mesilliac,

    Thanks a lot as well for pointing out the virtual keyboard and other useful tips. Meanwhile I found a link

    http://www.vafrous.com/articles.php?request=7

    and installed Gournal. It works, but it is for an older version of Ubuntu (6.06) and I will delete it.

    Thanks a lot again and regards,
    123marra

    P.S. I have one little questions (a silly one : If I install a new program / application, them how do I display an icon for it on my desktop or put an icon into my Applications menu? It seems I can't just drag and drop it.

  6. #16
    Join Date
    Jun 2006
    Beans
    100

    Re: Wacom tablets in Ubuntu guide/howto

    Quote Originally Posted by Xfcn View Post
    I'd like to keep the ability to hot-swap, but I'd also like to be able to change the cursor speed. Right now it moves faster than I'd like.
    According to the list of xorg.conf options at the LWP, the option to change cursor speed is:
    Code:
    Option "Speed" "Rspeed"
                      sets the cursor's  relative  movement speed to Rspeed.  The default value is 1.0.  A Rspeed greater than 1.0 will speed up the cursor's  relative movement.  A Rspeed less than 1.0 but greater  than 0 will slow  down the  cursor's  relative movement. A Rspeed too close to 0 is not recommanded.
    To add an option, create a custom_wacom.fdi file following the instructions at Wacom.fdi

    However, that option is only for the "cursor" device and at the moment only the configuration with xorg.conf (Option B) allow the use of the cursor (the mouse).

    The stylus (=pen tip) device is usually set in absolute mode, where the whole screen is mapped to the surface of your tablet, which is the only decent way if you want to draw. In this situation, to solve your problem, no need to edit the wacom configuration - just set the stylus to "Window" instead of "Screen" when configuring Extended Input Devices in your drawing program - see these guide screenshots.

    If you want to use the pen tip as a mouse, you can achieve that with the default solution (creating a custom_wacom.fdi file). The xorg option is :
    Code:
    Option "Mode" "Relative"
    In your custom_wacom.fdi, the line would be:
    Code:
       <merge key="input.x11_options.Mode" type="string">Relative</merge>
    If that's what you want, I created a custom .fdi file for you and added the option - it's called Relative.fdi and i put it on the Wacom.fdi page so it could benefit others. Just put it in /etc/hal/fdi/policy


    Quote Originally Posted by 123marra View Post
    P.S. I have one little questions (a silly one : If I install a new program / application, them how do I display an icon for it on my desktop or put an icon into my Applications menu? It seems I can't just drag and drop it.
    Applications comming from Ubuntu repositories should install the icon themselves in one of the application menus (for this kind of apps it should be "Accessibility" or "Universal Access"). If it doesn't and is in Intrepid or Hardy repositories, please file a bug in Launchpad (that's a really important step, you'll be helping future users like you're helped by others). After that, as a quick fix, you can add the application on the top panel (next to the Firefox, Mail and Help icons) by right clicking and choosing "add to panel">Custom Application Launcher.

    There's also a menu editor for Gnome menus, but I can't remember it. But please, please, file a bug in Lauchpad so it can be sorted out for everybody.

  7. #17
    Join Date
    Jan 2008
    Beans
    54
    Distro
    Xubuntu 10.04 Lucid Lynx

    Re: Wacom tablets in Ubuntu guide/howto

    i have a gateway 142-xl tablet pc, and i had my tablet working with hardy (using 8.1.5 build), but when installed intrepid, the tablet stoped working. i have gone in and tried option b (editing the xorg.conf), but it has not worked even though i simply uncommented that exaect configuration from b4. i have not yet tried to run the tablet w/o the "autoadddevices" "false", and i will be trying that once i get out of class. also, i am 95% sure that the tablet input is still @ /dev/ttyS0.
    edit: on my machine, the tablet input is either /dev/ttyS0 or /dev/input/wacom
    Last edited by minibeardeath; November 10th, 2008 at 09:49 PM.

  8. #18
    Join Date
    Jun 2006
    Beans
    100

    Re: Wacom tablets in Ubuntu guide/howto

    Quote Originally Posted by minibeardeath View Post
    i have a gateway 142-xl tablet pc, and i had my tablet working with hardy (using 8.1.5 build), but when installed intrepid, the tablet stoped working. i have gone in and tried option b (editing the xorg.conf), but it has not worked even though i simply uncommented that exaect configuration from b4. i have not yet tried to run the tablet w/o the "autoadddevices" "false", and i will be trying that once i get out of class.
    Can you post your xorg.conf here? I think it's the little paperclip icon next to the smiley icon.
    For now, possible candidates are:
    - check you have uncommented
    Code:
    Option "ForceDevice" "ISDV4" # Tablet PC ONLY
    but if your previous xorg.conf was similar then you already have it;
    - checking the ServerLayout section;
    - remove /usr/share/hal/fdi/policy/20thirdparty/10-wacom.fdi and haven't a custom wacom.fdi in /etc/hal/fdi/policy ;
    - try with /dev/input/wacom instead of /dev/ttys0
    - try with or without the "AutoAddDevices" "false" option in the ServerFlags section.
    Code:
    Section "ServerFlags"
            Option "AutoAddDevices" "False"
    EndSection
    But usually you shouldn't need it.

    Then you might be suffering from a bug in the 0.8.1.4 wacom drivers in Intrepid, so if the above doesn't work try to reinstall the drivers by downloading them from the Linux Wacom Project site. There's a link on the wiki that details how to do that, but I didn't try it and an user on a bug report had problems after installing the binaries (first method) so it's not 100% guaranteed to work. You could also compile them and install them, there again many people that try this method in the Forums have troubles too.

    0.8.1.6 might get into Intrepid through some updates, which would make it simpler. Whaterver you do make sure to backup your xorg.conf and note what commands you can type to reinstall the drivers if X doesn't load.
    Code:
    sudo apt-get purge xserver-xorg-input-wacom wacom-tools
    sudo apt-get install xserver-xorg-input-wacom wacom-tools
    Quote Originally Posted by minibeardeath View Post
    edit: on my machine, the tablet input is either /dev/ttyS0 or /dev/input/wacom
    Thanks. We can maybe keep /dev/ttyS0 on the guide for the moment, since the example working xorg.conf for TabletPC I saw on Launchpad were also using it, but in the long term if other TabletPC users report /dev/input/wacom is also created for them it would make the example line simpler (no change between serial and USB).
    Last edited by Loc2; November 10th, 2008 at 11:18 PM.

  9. #19
    Join Date
    Jun 2006
    Beans
    100

    Re: Wacom tablets in Ubuntu guide/howto

    Quote Originally Posted by mesilliac View Post
    Anyway, the linuxwacom drivers come with precompiled binaries so all you need to do is:

    * double click the linuxwacom-0.8.1-6.tar.bz2 file and extract it to your desktop (you can delete these later)
    * open a terminal (Accessories > Terminal)
    * type the following:
    Code:
    cd Desktop/linuxwacom-0.8.1-6/prebuilt
    sudo ./uninstall
    sudo ./install
    I got a post at https://bugs.launchpad.net/ubuntu/+s...292/comments/3 where the user say you need to add the --prefix=/usr option to configure "otherwise the updated driver is installed in /usr/local and isn't used".

    mesilliac, since I never used this method, could you check if the option is needed so we could correct the wiki if needed?

    The user also report some crashes after that, but he also encountered some with an Intrepid not updated (then the crash was solved, and reapeared after installing the 0.8.1.6 wacom drivers).

  10. #20
    Join Date
    Dec 2005
    Location
    New Zealand
    Beans
    104
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: Wacom tablets in Ubuntu guide/howto

    --prefix/usr is not necessary. The X driver is put in the correct place regardless.

    The prebuilt scripts don't take command line options anyway.

Page 2 of 89 FirstFirst 12341252 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •