Page 18 of 89 FirstFirst ... 816171819202868 ... LastLast
Results 171 to 180 of 883

Thread: Wacom tablets in Ubuntu guide/howto

  1. #171
    Join Date
    Mar 2005
    Location
    Sweden
    Beans
    158
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: Wacom tablets in Ubuntu guide/howto

    Seems to work fine on my Wacom Graphire 4 (USB)!

    I set it up my as follows:
    • The button closest to the pen tip to be right click
    • The tablet to be in relative mode
    • Slow down the cursor a little bit


    My custom FDI-file:
    Code:
    <?xml version="1.0" encoding="UTF-8"?> <!-- -*- SGML -*- -->
    <deviceinfo version="0.2">
      <device>
        <match key="input.x11_driver" contains="wacom">
          <match key="input.x11_options.Type" contains="stylus">
           	<merge key="input.x11_options.Mode" type="string">Relative</merge>
           	<merge key="input.x11_options.Button2" type="string">3</merge>
           	<merge key="input.x11_options.Button3" type="string">2</merge>
           	<merge key="input.x11_options.Speed" type="string">0.9</merge>
          </match>
        </match>
        <match key="input.x11_driver" contains="wacom">
          <match key="input.x11_options.Type" contains="eraser">
           	<merge key="input.x11_options.Mode" type="string">Relative</merge>
          </match>
        </match>
      </device>
    </deviceinfo>
    Last edited by ola; May 3rd, 2009 at 09:35 AM. Reason: Decreasing tip speed

  2. #172
    Join Date
    Oct 2007
    Location
    Germany
    Beans
    13
    Distro
    Ubuntu 7.10 Gutsy Gibbon

    Question Re: Wacom tablets in Ubuntu guide/howto

    Hi!

    My tablet (Wacom Intuos 3) runs fine under Ubuntu Janty using a custom_wacom.fdi file (see my post above). However, setting a keystroke to one of the buttons doesn't work so far.

    For example, when I try setting

    Code:
    <merge key="input.x11_options.Button1" type="string">core key space</merge>
    adapted from what I would use with xsetwacom, I only get this warning in /var/log/Xorg.0.log:

    Code:
    (WW) Option "Button1" requires an integer value
    So I wonder whether there's a way to add keystrokes to buttons without going back to use /etc/X11/xorg.conf.

    Thanks,

    Martin
    Last edited by mzuther; May 4th, 2009 at 08:47 PM.

  3. #173
    Join Date
    Jun 2006
    Beans
    100

    Re: Wacom tablets in Ubuntu guide/howto

    Quote Originally Posted by mzuther View Post
    Hi!

    My tablet (Wacom Intuos 3) runs fine under Ubuntu Janty using a custom_wacom.cpi file (see my post above). However, setting a keystroke to one of the buttons doesn't work so far.

    Code:
    (WW) Option "Button1" requires an integer value
    So I wonder whether there's a way to add keystrokes to buttons without going back to use /etc/X11/xorg.conf.
    AFAIR, wacomcpl only allowed the stylus side buttons to be assigned to either left, right or middle mouse button, so it's possible that's the only options that will work. That's probably why you get the error message - an integer value would be 1, 2 or 3 (for the respective mouse buttons).

    If you want to troubleshoot it, however, here's a crude method:

    You can use the xsetwacom command to pass parameters on the fly to your wacom devices. First, use
    Code:
    xinput --list
    to get the name of your devices, which should be similar to the ones in this post, also using an Intuos 3. Those lines are for the pad, yours sounds more like a stylus button, but that should follow the same principle (if i remember correctly, the stylus would be the string without any name of device at the end, like "Wacom Intuos3 6x8" instead of "Wacom Intuos3 6x8 pad" in the example).

    If you got troubles, either revert to the /etc/X11/xorg.conf method to get a decent configuration from wacomcpl, or better just install Ubuntu 8.10 on a separate partition, configure /etc/X11/xorg.conf then use wacomcpl, and get the script it produces (.xinitrc), change the names "stylus"... by the names you have in Ubuntu 9.04 with
    Code:
    xinput --list
    , and execute the script in Ubuntu 9.04.
    Last edited by Lo´c2; May 4th, 2009 at 05:18 PM.

  4. #174
    Join Date
    Oct 2007
    Location
    Germany
    Beans
    13
    Distro
    Ubuntu 7.10 Gutsy Gibbon

    Re: Wacom tablets in Ubuntu guide/howto

    Hi Lo´c2,

    I didn't know that I could use xsetwacom without having the respective entries in /etx/X11/xorg.conf, so thanks a lot!

    I was actually trying to set up my pad buttons. Anyway, these entries worked for stylus and pad buttons:

    Code:
    xsetwacom set "Wacom Intuos3 6x8" Button1 "CORE KEY SPACE"
    xsetwacom set "Wacom Intuos3 6x8pad " Button1 "CORE KEY SPACE"
    The only thing I wonder is why I can't set keys to buttons using the custom_wacom.fdi method. It would be nice to have all in one file, wouldn't it?

    Thanks again,

    Martin

  5. #175
    Join Date
    Nov 2008
    Beans
    169

    Re: Wacom tablets in Ubuntu guide/howto

    The "xinput --list" seems to work for me as well though I found my information from this thread at the Linux Wacom Project site. For Jaunty 9.04, I replaced various entries like "pad" with ""Wacom Bamboo pad"" and "stylus" with ""Wacom Bamboo"". I also used the custom_wacom.FDI method, but I don't think it's required when using the "xsetwacom" settings method within a SH script.

    Here are the contents of my personal xsetwacom_settings.SH file in case it helps anyone:

    Code:
    xsetwacom set "Wacom Bamboo pad" AbsWDn "core key  CTRL  SHIFT s"
    xsetwacom set "Wacom Bamboo pad" AbsWUp "core key  CTRL  SHIFT s"
    xsetwacom set "Wacom Bamboo pad" Button4 "core key  NumpadMinus "
    xsetwacom set "Wacom Bamboo pad" Button3 "core key  NumpadPlus "
    xsetwacom set "Wacom Bamboo pad" Button2 "core key  F12 "
    xsetwacom set "Wacom Bamboo pad" Button1 "CORE KEY  Esc"
    xsetwacom set "Wacom Bamboo" Suppress "15"
    xsetwacom set "Wacom Bamboo" RawSample "15"
    xsetwacom set "Wacom Bamboo" ClickForce "5"
    xsetwacom set "Wacom Bamboo" PressCurve "0 0 100 100"
    xsetwacom set "Wacom Bamboo" Accel "1"
    xsetwacom set "Wacom Bamboo" SpeedLevel "4"
    xsetwacom set "Wacom Bamboo" TPCButton "off"
    xsetwacom set "Wacom Bamboo" mode "Relative"
    xsetwacom set "Wacom Bamboo" Button3 "Button 3"
    xsetwacom set "Wacom Bamboo" Button2 "Button 2"
    xsetwacom set "Wacom Bamboo" Button1 "Button 1"
    xsetwacom set "Wacom Bamboo eraser" Suppress "15"
    xsetwacom set "Wacom Bamboo eraser" RawSample "15"
    xsetwacom set "Wacom Bamboo eraser" ClickForce "5"
    xsetwacom set "Wacom Bamboo eraser" PressCurve "0 0 100 100"
    xsetwacom set "Wacom Bamboo eraser" Accel "1"
    xsetwacom set "Wacom Bamboo eraser" SpeedLevel "4"
    xsetwacom set "Wacom Bamboo eraser" mode "Relative"
    xsetwacom set "Wacom Bamboo eraser" Button1 "Button 1"
    xsetwacom set "Wacom Bamboo cursor" Accel "1"
    xsetwacom set "Wacom Bamboo cursor" SpeedLevel "4"
    As similarly mentioned in posts above, I add the file to the list of things started when logging in. To do so, I make sure the SH file is executable. In Gnome, placing a check mark next to "Allow executing file as program" under the Permissions tab in the file Properties works. Also, using something like "sudo chmod +x xsetwacom_settings.sh" in a Terminal (or command shell) screen works. After that, I visit System -> Preferences -> Startup Applications. I have an entry added that uses:

    sh "/home/your_profile_name_here(case_sensitive)/Wacom Settings/xsetwacom_settings.sh"

    Behavior for my Wacom tablet afterwards behaves the same in Jaunty 9.04 as it did Intrepid 8.10. Disconnections of the tablet require that the SH file be ran again while still logged in. I also assume the settings for "xsetwacom" might work in a custom_wacom.FDI file instead with a few changes, but I am happy for now.
    Last edited by shatterblast; May 7th, 2009 at 05:37 PM.

  6. #176
    Join Date
    Nov 2008
    Beans
    9,635
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Wacom tablets in Ubuntu guide/howto

    Hi everyone,

    As you have discovered it looks like the problems with wacomcpl and the xsetwacom commands come from the default Jaunty 10-wacom.fdi not parsing the names HAL is returning correctly for linuxwacom to understand. Cyberfish came up with a .fdi that does parse the HAL names correctly and as modified by gali98 works for our usb tablet pc's.

    I modified it for usb external graphics tablets. K-buntu says it works on his Wacom Bamboo Fun. Wacomcpl etc. work for him without having to rename anything.

    You can configure everything through wacomcpl (& .xinitrc) and xsetwacom as before. You can also configure through the .fdi like you use to do with xorg.conf. If you do not have, for eg. the Wacom mouse, you could remove the append cursor line in the first section and the cursor section following it.

    1) For usb Wacom tablets in Jaunty and Karmic: Jaunty ext graphics_test 2_10-wacom.fdi.txt

    Remember this modified 10-wacom.fdi is for the 0.8.2-2 linuxwacom packages that come "default" with Jaunty: xserver-xorg-input-wacom & wacom-tools

    It looks like the modified .fdi also works with Karmic.

    Just move and save the default 10-wacom.fdi in /usr/share/hal/fdi/policy/20thirdparty/ somewhere safe (after changing .fdi to .bak say) and substitute the attached .fdi. After renaming it 10-wacom.fdi of course. One way to do this is the following:

    -First download the attached .fdi to your desktop.
    -Then make a back up of the current "default" Jaunty 10-wacom.fdi by typing in a terminal:
    Code:
    sudo cp /usr/share/hal/fdi/policy/20thirdparty/10-wacom.fdi /home/yourusername/Desktop/10-wacom.bak
    In Karmic the .fdi has been renamed to 10-linuxwacom.fdi. So to back up the "default" Karmic .fdi:
    Code:
    sudo cp /usr/share/hal/fdi/policy/20thirdparty/10-linuxwacom.fdi /home/yourusername/Desktop/10-linuxwacom.bak
    Where "yourusername" is the user name you are using. Check that the "wacom.bak" is now on your Desktop and has the correct contents by right clicking on it and 'Open as a "text file"'. You can move it to wherever you want in Nautilus (Places) later. Close it.
    -Now open the current 10-wacom.fdi as root in gedit with:
    Code:
    gksudo gedit /usr/share/hal/fdi/policy/20thirdparty/10-wacom.fdi
    In Karmic use:
    Code:
    gksudo gedit /usr/share/hal/fdi/policy/20thirdparty/10-linuxwacom.fdi
    Delete the entire contents (its safe, you've verified your backup). Now copy and paste the entire contents of the downloaded modified wacom.fdi (you can right click on it and open it in another text editor) save and close.
    -Reboot.

    Now "xinput --list" and "xsetwacom list" entered in a terminal should agree with each other and return the linuxwacom names stylus, eraser, cursor (if you have the Wacom mouse), pad (tablet buttons), and touch. With "xsetwacom list" working you are now able to use 'wacomcpl', the LWP's configuration and calibration gui. Just enter 'wacomcpl' (without the quotes) in a terminal and the gui will pop up. To set it up so that it's settings last through a reboot see "Section 3: Calibrating your Tablet".

    Intuos4 tablet users need a 'wacom.ko' (the usb kernel driver/module) newer than the default Jaunty 0.8.2-2 wacom.ko. The default one doesn't allow usb communication to your tablet. To compile the new 'wacom.ko' follow Section 1, and Section 1 only, of gali98's Jaunty HOW TO in post #104. In Karmic the default 0.8.4-1 linuxwacom wacom.ko works fine, no need to compile anything.

    To further set up your pad see shatterblast's post #188 on the following page. For the Intuous4 pad see also ceridwen's post #95 on another thread. That's the Intuos4 thread, lots of tips in it.

    2) For serial Wacom tablets in Jaunty and Karmic: serial-tablet&tablet-pc_test2_10-wacom.fdi.txt

    The serial .fdi attached below seems to work. Same instructions as in 1) above. Because there are new serial tablets I added them by modeling the serial section match lines in the linuxwacom 0.8.5-6 .fdi. The new multi-touch tablets will need to use at least linuxwacom 0.8.5-6 (or up). With all the new tablet identifiers I decided to merge the serial tablet and tablet pc .fdi's to make things simpler. Older serial tablets probably need to remove or comment out this line:
    Code:
    	<merge key="input.x11_options.ForceDevice" type="string">ISDV4</merge>
    (The serial-graphics-tablet_test1 .fdi had 48 downloads.)

    3) For all (serial & usb & bluetooth) Wacom tablets and tablet pc's in Jaunty and Karmic: new-generic_rc2_10-linuxwacom.fdi.txt

    The new-generic release candidate attached below is my attempt to construct a .fdi that works for all the Wacom tablets. It adds support for the TX2000 and TX2500 (finally) tablet pc's. And also the new Bamboo Pen and Touches and the new HP dv3-2250 multi-touch laptop (E2) (use the current development branch linuxwacom 0.8.5-7 series drivers). RC2 is out because of the new serial tablets, see 2) above. It's been mainly tested in Karmic. Hopefully it will work without too many glitches. (The new-generic_rc1 .fdi had 43 downloads.)

    I added some labels so things aren't so mysterious. If you are interested in trying it the instructions are in 1) above.

    Note: With the last few versions of linuxwacom (~0.8.10 and up) wacomcpl was modified to deal with the longer more descriptive names and no longer needs stylus, eraser, cursor, pad, or touch. This means you can remove the merge key="info.product" lines or the <!-- Wacom names "parser" --> section if you want to.
    Last edited by Favux; May 31st, 2011 at 07:28 PM. Reason: clarified which .fdi to use for usb and serial tablets

  7. #177
    Join Date
    Nov 2008
    Beans
    169

    Re: Wacom tablets in Ubuntu guide/howto

    Quote Originally Posted by Favux View Post
    Hi everyone,

    As you have discovered it looks like the problems with wacomcpl and the xsetwacom commands come from the default Jaunty 10-wacom.fdi not parsing the names HAL is returning correctly for linuxwacom to understand. Cyberfish came up with a .fdi that does parse the HAL names correctly and as modified by gali98 works for our usb tablet pc's.

    I modified it for usb external graphics tablets. K-buntu says it works on his Wacom Bamboo Fun. Wacomcpl etc. work for him without having to rename anything.

    If you're interested please test it and let me know if it works for you. You can configure everything through wacomcpl (& .xinitrc) and xsetwacom as before. You can also configure through the .fdi like you use to do with xorg.conf. If it works for you please mention which tablet you have. If you do not have, for eg. the Wacom mouse, you could remove the append cursor line in the first section and the cursor section following it.

    Just move and save the default 10-wacom.fdi in /usr/share/hal/fdi/policy/20thirdparty/ somewhere safe (after changing .fdi to .bak say) and substitute the attached .fdi. After renaming it 10-wacom.fdi of course.

    If the usb .fdi works for you maybe something analogous can be done with the serial tablet's subsection of the 10-wacom.fdi?
    I can confirm that this file when used properly does indeed appear to allow the configuration in "wacomcpl" again for Jaunty 9.04 with a USB Wacom Bamboo. I didn't follow instructions carefully, which caused my GUI problems with the Wacom tablet connected. I corrected my mistake and had success after reading thoroughly.
    Last edited by shatterblast; May 8th, 2009 at 01:26 AM. Reason: Had to stop "bunny" from ruling the world. For now.

  8. #178
    Join Date
    Nov 2008
    Beans
    9,635
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Wacom tablets in Ubuntu guide/howto

    Hi shatterblast, ubootfant, Sawer, crazybus, nebux, jjatria

    Thanks for testing the .fdi. Glad it worked for you.


    So that's 12 Wacom tablets, 5 Bamboo's, a Bamboo Fun, a Cintiq 21UX, a Graphire2, and 4 Intuous4's it has worked for. Looking good so far!

    -The Cintiq 21UX user said it also fixed the TwinView problem he had been having.
    -For the Intuos4 we had to substitute a newer (0.8.3-3) wacom.ko (the usb kernel driver) to get it working. To get the Pad working see post #95 by ceridwen here: http://ubuntuforums.org/showthread.p...120029&page=10
    -The Graphire2 user said everything worked except wacdump (a general HAL/.fdi problem?)
    Last edited by Favux; May 30th, 2009 at 05:08 AM.

  9. #179
    Join Date
    Nov 2008
    Beans
    169

    Re: Wacom tablets in Ubuntu guide/howto

    Mine is not a "Fun", but it is compatible with it.

  10. #180
    Join Date
    Dec 2008
    Beans
    30

    Re: Wacom tablets in Ubuntu guide/howto

    I'm lost. How to I put the express key script in /etc/init.d and chmod +x? I do graphics stuff and an not much of a hacker.
    Thanks

Page 18 of 89 FirstFirst ... 816171819202868 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •