Page 16 of 89 FirstFirst ... 614151617182666 ... LastLast
Results 151 to 160 of 883

Thread: Wacom tablets in Ubuntu guide/howto

  1. #151
    Join Date
    Apr 2006
    Beans
    3
    Distro
    Kubuntu Jaunty Jackalope (testing)

    Re: Wacom tablets in Ubuntu guide/howto

    Found the bug report for the problem I'm seeing, it's still not fixed yet.

    http://bugs.winehq.org/show_bug.cgi?id=11846

    Thanks for all the help in this thread though, it's been a great resource.

  2. #152
    Join Date
    Apr 2009
    Beans
    1

    Re: Wacom tablets in Ubuntu guide/howto

    Hi,

    I've configured my custom_wacom.fdi for my stylus. It goes well. But how can I add my eraser, pad and so on? I would like to make for my eraser and mouse an different mode as for my stylus.
    And how can I configre my buttons on my pad without overwrite my configuration for my stylus?
    Is there anywhere a description for this?

    At the moment my custom_wacom.fid looks like this:

    Code:
      <device>
        <match key="info.capabilities" contains="input">
          <match key="info.product" contains="Wacom">
            <merge key="input.x11_driver" type="string">wacom</merge>
            <merge key="input.x11_options.Type" type="string">stylus</merge>
            <merge key="input.x11_options.Mode" type="string">Absolute</merge>
            <merge key="input.x11_options.TopX" type="string">0</merge>
            <merge key="input.x11_options.TopY" type="string">0</merge>
            <merge key="input.x11_options.BottomX" type="string">40639</merge>
            <merge key="input.x11_options.BottomY" type="string">25399</merge>
          </match>
          <match key="info.product" contains="WALTOP">
            <merge key="input.x11_driver" type="string">wacom</merge>
            <merge key="input.x11_options.Type" type="string">stylus</merge>
          </match>
        </match>
      </device>

  3. #153
    Join Date
    Oct 2005
    Location
    Netherlands
    Beans
    350

    Re: Wacom tablets in Ubuntu guide/howto

    I just upgraded to Jaunty, and now the pad of my Bamboo only scrolls up.... I tried overruling this by using
    Code:
    xsetwacom set pad relwup 5
    xsetwacom set pad relwdn 4
    but this doesn't work.... it only keeps scrolling up
    Anyone knows how to solve this?

  4. #154
    Join Date
    Nov 2008
    Beans
    9,635
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Wacom tablets in Ubuntu guide/howto

    Hi krylian,

    I think it should look something like:
    Code:
      <device>
        <match key="info.capabilities" contains="input">
          <match key="info.product" contains="Wacom">
            <merge key="input.x11_driver" type="string">wacom</merge>
            <merge key="input.x11_options.Type" type="string">stylus</merge>
            <append key="info.callouts.add" type="strlist">hal-setup-wacom</append>
            <append key="wacom.types" type="strlist">eraser</append>
            <append key="wacom.types" type="strlist">pad</append>
            <merge key="input.x11_options.Button2" type="string">3</merge>
            <merge key="input.x11_options.Mode" type="string">Absolute</merge>
            <merge key="input.x11_options.TopX" type="string">0</merge>
            <merge key="input.x11_options.TopY" type="string">0</merge>
            <merge key="input.x11_options.BottomX" type="string">40639</merge>
            <merge key="input.x11_options.BottomY" type="string">25399</merge>
          </match>
          <match key="info.product" contains="WALTOP">
            <merge key="input.x11_driver" type="string">wacom</merge>
            <merge key="input.x11_options.Type" type="string">stylus</merge>
          </match>
        </match>
      </device>
    Where I've added eraser, pad, and a stylus button as a right mouse click. You may be able to add the options to stylus under stylus and then follow with eraser, pad, etc. (just to make things look organized). I'm not sure about that because I am definitely not a .fdi guru.

    Hi Peter76,

    The "native" Jaunty linuxwacom 0.8.2-2 (as patched by Timo Aaltonen to support HAL and Xserver 1.6) doesn't support xsetwacom (and hence wacomcpl and it's .xinitrc). This is because the callout from the .fdi file returns HAL/D-BUS names that aren't compatible with linuxwacom. Rec discovered this on this thread: http://ubuntuforums.org/showthread.php?t=1122952 And came up with a script to fix it. He posted the script on Timo's launchpad feedback site: https://bugs.launchpad.net/ubuntu/+s...ls/+bug/355340 And it looks like maybe Timo has now patched xorg-xserver to work correctly: https://launchpad.net/~tjaalton/+archive/ppa At least I'm hoping that's what the changelog means.

    In the meantime if you want to experiment with the script and see if it lets you configure your tablet through wacomcpl and/or xsetwacom see Jaunty Users near the top here: http://ubuntuforums.org/showthread.php?t=1038949 The link will take you to post #104 on that thread where gali98 has a HOW TO. If your graphics tablet is working OK you probably don't need to do the part about compiling the 0.8.3-2 wacom.ko kernel driver, just the script part.

    Edit: It looks like ProhetofDoom found another way from the LWP site. See post #8 here: http://ubuntuforums.org/showthread.p...89#post7143989 It is from Tom Jaeger. He posted today at LWP another way to do things without rec's script: http://sourceforge.net/mailarchive/f...xwacom-discuss Instead of "xsetwacom list" he suggests "xinput --list" and using those "names".
    Last edited by Favux; April 27th, 2009 at 08:16 PM.

  5. #155
    Join Date
    Apr 2009
    Beans
    2

    Re: Wacom tablets in Ubuntu guide/howto

    Hello! I need a bit of help. ^_^

    I was having issues with my Bamboo Fun Tablet on Intrepid, and so I updated to Jaunty today, in hopes of having an easier time with it.

    And I did. The tablet is picked up in GIMP, and I managed to set the scroll wheel to work as well as the stylus being recognized.

    BUT, the problem I am having is with the pressure sensitivity of the stylus.
    Right now, the stroke will turn out lighter or darker depending on the pressure applied, but when I used this tablet on Windows it would also vary the thickness of the stroke according to the pressure, and that is the sensitivity I am more concerned with.

    Anyone know what I can do about this? Or is this just something that GIMP does not pick up on and I should be using a different art program?

    - DD

  6. #156
    Join Date
    Apr 2009
    Location
    Quebec, Canada
    Beans
    126
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Wacom tablets in Ubuntu guide/howto

    I don't know how well you know Gimp, so forgive me if I'm saying something obvious to you.

    I'm not sure about the exact terms, since my system is in French I'm translating the terms as I best think they must be in English.

    When the brush/pencil/airbrush is active, you can change the brush dynamics in the options right underneath the toolbox. You have to click on "Brush Dynamics" to get the dropdown options. They give you options on pressure, speed and random, with such controls as opacity, ratio, color, size and hardness.

    When I first started to fiddle with this, only opacity was ticked. It may be the case for you as well.

    Hope this helps.

    - G.

    P.S. Would you mind explaining what exactly you did to make the scroll wheel and the stylus work? Are the eraser and the mouse working as well?

    I'd like to upgrade to 9.04 but I want to be sure everything works on my Bamboo Fun, as it does right now on 8.10.

    Thanks!
    Last edited by Gemnoc; April 27th, 2009 at 04:27 AM.

  7. #157
    Join Date
    Apr 2009
    Beans
    2

    Re: Wacom tablets in Ubuntu guide/howto

    @ Gemnoc - Thanks for replying!

    I'm used to Adobe Photoshop and I'm trying to switch over to GIMP instead of trying to wrestle with Linux to install Photoshop.

    But those were exactly the settings I was looking for. Thank you!

    As for what I did to get my stylus and etc working:

    All I did (Using Jaunty), was setup my tablet using the setup CD. Just a simple open and install.
    Then I opened GIMP and went into Edit > Preferences > Input Devices > Configure Extended Input Devices

    Once there, the drop-down called Devices: and choose each of the possible Wacom options, changing each one to "Screen" Mode and then just save in that window. Click "Close", and in the window underneath, click "Save Input Device Settings Now", then close.

    Once I did that, my stylus was working, as well as the mouse and the scroll wheel.
    The buttons do not work on mine though.
    *Note: My eraser was working as a paintbrush so at first I thought it wasn't registering, but I selected Eraser with that end of the stylus, and it has remembered that since.

    Hope this helps.
    If anything is confusing-sounding, let me know and I'll try to clarify my rambles.

    - DD

  8. #158
    Join Date
    Apr 2009
    Location
    Quebec, Canada
    Beans
    126
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Wacom tablets in Ubuntu guide/howto

    You're welcome. Gimp has indeed a quirky UI.

    So, straight up Jaunty install, the scroll wheel works, but the buttons don't. As I was afraid (and as infered by previous posters), some more tinkering seems to be needed...

    Thanks for the info.

  9. #159
    Join Date
    Dec 2005
    Location
    New Zealand
    Beans
    104
    Distro
    Ubuntu 10.10 Maverick Meerkat

    Re: Wacom tablets in Ubuntu guide/howto

    Hi, I've just managed to get my Graphire Bluetooth working, and the new hotplug functionality works brilliantly .

    It still needs a driver to be manually installed, so if anyone with the same tablet wants to get it working, try following the instructions at http://ubuntuforums.org/showthread.p...4738&page=8#77

    Now for some general wacom tablet info regarding settings:

    custom .fdi files

    This simple .fdi file seems to work for calibrating both stylus and eraser (these are my preferred settings, adjust to taste):

    /etc/hal/fdi/policy/custom_wacom.fdi
    Code:
    <?xml version="1.0" encoding="UTF-8"?> <!-- -*- SGML -*- -->
    
    <deviceinfo version="0.2">
    
      <device>
        <match key="input.x11_driver" contains="wacom">
          <match key="input.x11_options.Type" contains="stylus">
            <merge key="input.x11_options.TPCButton" type="string">on</merge>
            <merge key="input.x11_options.KeepShape" type="string">on</merge>
            <merge key="input.x11_options.Threshold" type="string">1</merge>
            <merge key="input.x11_options.PressCurve" type="string">50,0,100,50</merge>
          </match>
        </match>
        <match key="input.x11_driver" contains="wacom">
          <match key="input.x11_options.Type" contains="eraser">
            <merge key="input.x11_options.TPCButton" type="string">on</merge>
            <merge key="input.x11_options.KeepShape" type="string">on</merge>
            <merge key="input.x11_options.Threshold" type="string">1</merge>
            <merge key="input.x11_options.PressCurve" type="string">50,0,100,50</merge>
          </match>
        </match>
      </device>
    
    </deviceinfo>
    Does this work for anyone else?
    It should work for most Wacom tablets.

    NOTE: if your custom .fdi file contains the "hal-setup-wacom" callout it can crash your X... to stop it crashing, unplug your tablet.
    Last edited by mesilliac; April 27th, 2009 at 07:51 AM.

  10. #160
    Join Date
    Aug 2007
    Location
    Poland
    Beans
    21
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: Wacom tablets in Ubuntu guide/howto

    Hi, I`d like to share with you how I`ve managed to get my WACOM Intuos3 tablet working under jaunty. It was working on ubuntu 8.10 after I did what`s listed here: https://help.ubuntu.com/community/Wacom and here: https://help.ubuntu.com/community/WacomTroubleshooting and set express keys with wacomcpl.
    After upgrade to jaunty, my tablet was still working, but express keys and touch strip on the pad didn`t. I`ve found solution here: http://ubuntuforums.org/showthread.p...66#post7143866. I`ve simply changed my /home/username/.xinitrc file to:
    Code:
    #!/bin/sh
    xsetwacom set "Wacom Intuos3 6x8 pad" StripRDn "CORE KEY NumpadPlus"
    xsetwacom set "Wacom Intuos3 6x8 pad" StripRUp "CORE KEY NumpadMinus"
    xsetwacom set "Wacom Intuos3 6x8 pad" StripLDn "CORE KEY ["
    xsetwacom set "Wacom Intuos3 6x8 pad" StripLUp "CORE KEY ]"
    xsetwacom set "Wacom Intuos3 6x8 pad" Button8 "CORE KEY CTRL z"
    xsetwacom set "Wacom Intuos3 6x8 pad" Button7 "CORE KEY CTRL y"
    xsetwacom set "Wacom Intuos3 6x8 pad" Button6 "CORE KEY backslash"
    xsetwacom set "Wacom Intuos3 6x8 pad" Button5 "CORE KEY '"
    xsetwacom set "Wacom Intuos3 6x8 pad" Button4 "CORE KEY Tab"
    xsetwacom set "Wacom Intuos3 6x8 pad" Button3 "CORE KEY SHIFT"
    xsetwacom set "Wacom Intuos3 6x8 pad" Button2 "CORE KEY ALT"
    xsetwacom set "Wacom Intuos3 6x8 pad" Button1 "CORE KEY CTRL"
    xsetwacom set "Wacom Intuos3 6x8" "PressCurve" 50 0 100 50
    The file is of course executable and filed under gnome-session-properties. Everything works fine except that if I unplug the tablet and plug it again I have to run /home/username/.xinitrc again. I remember that there was an option (somewhere in preferred applications) to run some app when graphic tablet is pluged in. Can`t find it though. Maybe that would do the trick. Besides, it would be great if there was a graphical tool to change Express Keys shortcuts and tablet`s sensivity as wacomcpl doesn`t work now (at least for me).
    Last edited by mallow; April 27th, 2009 at 11:29 AM.

Page 16 of 89 FirstFirst ... 614151617182666 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •