Page 3 of 8 FirstFirst 12345 ... LastLast
Results 21 to 30 of 71

Thread: x11vnc shutting down on Intrepid login

  1. #21
    Join Date
    Aug 2007
    Beans
    4

    Re: x11vnc shutting down on Intrepid login

    I set the KillInitClients back to false and all is well. I no longer get kicked out. Losing the custom mouse cursor with -noxfixes is no big deal to me. Thanks again for the help!

  2. #22
    Join Date
    Jan 2007
    Beans
    193

    Re: x11vnc shutting down on Intrepid login

    Quote Originally Posted by krunge View Post
    I reported the problem to Xorg: http://bugs.freedesktop.org/show_bug.cgi?id=18451


    BTW, if a person is willing to build x11vnc version 0.9.6 from the upstream source tarball, it has an option "-reopen" that works around this problem fairly well.

    When using x11vnc's "-reopen" one does not specify KillInitClients=false to GDM, you either leave GDM in its default configuration or set to "true".

    Then, when you login with GDM through x11vnc, GDM tries to kill x11vnc, but instead x11vnc just waits a few seconds and then tries to reopen the X display. It seems to work around this problem pretty well, and gives the full cursor shape (no need for -noxfixes).

    Going forward, "-reopen" will probably become the preferred way to work around GDM's KillInitClients behavior.

    http://www.karlrunge.com/x11vnc/x11v...tml#opt-reopen
    Hey Karl, thanks for all of your help on this one! I got things working using the -noxfixes option.

    I've got one small annoyance and I don't know if it's related or not. The cursor in the VNC viewer window shows as a big X instead of the cursor... is that because of something in x11vnc?

  3. #23
    Join Date
    Dec 2006
    Beans
    810

    Re: x11vnc shutting down on Intrepid login

    Quote Originally Posted by Underpants View Post
    Hey Karl, thanks for all of your help on this one! I got things working using the -noxfixes option.

    I've got one small annoyance and I don't know if it's related or not. The cursor in the VNC viewer window shows as a big X instead of the cursor... is that because of something in x11vnc?
    Yes, it is precisely because you turned off xfixes:

    http://www.karlrunge.com/x11vnc/x11v...tml#opt-cursor

  4. #24
    Join Date
    Jan 2007
    Beans
    193

    Re: x11vnc shutting down on Intrepid login

    Excellent!

    This has been a pretty productive thread. I'm going to construct a nice howto for headless systems and folks that just want control of the console session.

    If you are a Bourbon drinker, send me an address and I'll make sure you get a nice little bottle of something good from Kentucky for the holidays.

    x11vnc is giftware, right?

  5. #25
    Join Date
    Nov 2007
    Location
    República de Tejas,Centro
    Beans
    232
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: x11vnc shutting down on Intrepid login

    Quote Originally Posted by krunge View Post
    Thanks.

    BTW for x11vnc -noxfixes when using GDM with KillInitClients=false properly configured (gdm.conf-custom, or where ever) you should only need to connect once. Check if that works.
    It does. Thanx much.

    No SSH, just VNC... added only "-noxfixes"

    On the local client I get the big ugly "X" cursor and don't see the remote server's pretty little red arrow but that's nit picking.

    Lines at end of /etc/gdm/Init/Default:

    Code:
    #
    # Setup x11vnc for remote resumable session within LAN - SRG 12/2007
    #
    /usr/bin/x11vnc -forever -nolookup -bg -sb 11 -noxfixes -usepw -rfbauth /home/skip/.vnc/passwd -rfbport 5923 -allow 192.168.218. -o /var/log/xvnclog -auth /var/lib/gdm/:0.Xauth
    
    exit 0
    Entry in /etc/gdm/gdm.conf-custom (no changes to gdm.conf):

    Code:
    [daemon]
    #
    # Added KillInitClients=false - SRG
    #
    KillInitClients=false
    Last edited by Skip Da Shu; January 6th, 2009 at 12:29 AM.
    - da shu @ HeliOS,
    "A child's exposure to technology should never be predicated on an ability to afford it."

  6. #26
    Join Date
    Jan 2007
    Beans
    193

    Re: x11vnc shutting down on Intrepid login

    add "-cursor normal" to the end of your line and you'll get a regular looking black arrow. I think that's the correct option, seek the help doc on Karl's site, but I think that's correct.

  7. #27
    Join Date
    Nov 2007
    Location
    República de Tejas,Centro
    Beans
    232
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: x11vnc shutting down on Intrepid login

    Quote Originally Posted by Underpants View Post
    Excellent!

    This has been a pretty productive thread. I'm going to construct a nice howto for headless systems and folks that just want control of the console session.

    If you are a Bourbon drinker, send me an address and I'll make sure you get a nice little bottle of something good from Kentucky for the holidays.

    x11vnc is giftware, right?
    There's a how-to for x11vnc grafted into this how-to on setting up headless machines on Xubnutu to run BOINC HERE or HERE.

    At this moment it doesn't contain this fix but it will shortly.
    - da shu @ HeliOS,
    "A child's exposure to technology should never be predicated on an ability to afford it."

  8. #28
    Join Date
    Nov 2007
    Location
    República de Tejas,Centro
    Beans
    232
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: x11vnc shutting down on Intrepid login

    Quote Originally Posted by Underpants View Post
    add "-cursor normal" to the end of your line and you'll get a regular looking black arrow. I think that's the correct option, seek the help doc on Karl's site, but I think that's correct.
    That didn't work for me... but you got me to look at Karl's doc and what did work was "-cursor arrow" w/ the "-noxfixes" parm. I also added "-cursor n".

    I didn't see, but may have missed, what the arrow pointer options give you. I tried -arrow 2|3|4|5|6 all of which worked for me. Here's what the options give:

    1 = stubby black arrow, default w/o this command
    2 = stubby white arrow
    3 = thin tailed black arrow
    4 = thin tailed white arrow
    5 = smaller head, longer tail, thin black arrow
    6 = smaller head, longer tail, thin white arrow

    I liked the 5 & 6 options but 3 was easier for my old eyes to spot so I went back to that.

    So on the v8.10 headless number cruncher the end of my /etc/gdm/Init/Default now looks like:

    Code:
    #
    # Setup x11vnc for remote resumable session within LAN - SRG 12/2007
    #
    /usr/bin/x11vnc -forever -nolookup -bg -sb 11 -noxfixes -cursor arrow -arrow 3 -usepw -rfbauth /home/skip/.vnc/passwd -rfbport 5923 -allow 192.168.218. -o /var/log/xvnclog -auth /var/lib/gdm/:0.Xauth
    - da shu @ HeliOS,
    "A child's exposure to technology should never be predicated on an ability to afford it."

  9. #29
    Join Date
    Jan 2007
    Beans
    193

    Re: x11vnc shutting down on Intrepid login

    Sorry, this is the line I use in /etc/gdm/Init/Default

    Code:
    /usr/bin/x11vnc -localhost -o /var/log/x11vnc.log -forever -bg -noxfixes -ultrafilexfer -cursor arrow

  10. #30
    Join Date
    Jan 2009
    Beans
    46

    Re: x11vnc shutting down on Intrepid login

    i thought i'd contribute to make things clear to fix this problem. you need to add the "-nofixes" option to fix the crash and the "-auth /var/lib/gdm/:0.Xauth" option to view the login screen. also, find out if your GDM uses /etc/gdm/gdm.conf or /etc/gdm/gdm.conf-custom (the emptier one is the unused one!) and edit the used one to include "KillInitClients=false" under the [daemon] section.

    the command i use is this:

    Code:
    sudo x11vnc -WhateverOptionsYouWant -noxfixes -auth /var/lib/gdm/:0.Xauth -display :0
    with KillInitClients=true in my /etc/gdm/gdm.conf file. i only need to start x11vnc once. i don't care about the "X" cursor.

    thanks guys.
    Last edited by excbuntu; February 20th, 2009 at 07:27 AM.

Page 3 of 8 FirstFirst 12345 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •