Page 1 of 9 123 ... LastLast
Results 1 to 10 of 82

Thread: HOWTO: Setting up USB MidiSport

  1. #1
    Join Date
    Oct 2005
    Location
    IN, USA
    Beans
    274
    Setting up Midisport Uno, Midisport 1x1, or Midisport 2x2, USB-2-Midi

    The Midisport Uno is a usb-based cable that connects a midi controller (like a synthesizer) to a usb port on your computer. Then you can use a midi sequencer like Rosegarden to record and edit music scores. A while back, I didn't have a sound card that had midi ports, so I just purchased a Midisport Uno instead. The advantage to the using a Midisport is that you don't need a special sound card for midi devices, and can connect them to any computer that has a free usb input.

    If your device does not auto-magically work out of the box, setting this device up for Linux is not that tricky. The Midisport Uno requires firmware to be loaded to the device before it will do anything. In other words, you need (a) a firmware file, and (b) a program for loading the firmware.

    Install the midisport-firmware package (firmware is included in package).

    If you prefer the graphical interface, go to:

    Applications -> Ubuntu Software Center

    And search for midisport. You should see the package named "midisport-firmware." Click install.

    Or, you can install the firmware by running this command in a terminal:

    Code:
    sudo apt-get install midisport-firmware
    Now plug in the USB cable and you should be good to go (you should see pulsing lights).

    That's it. ENJOY!

    ------------------------------------------------------------------------------------------------------------

    If you have an older/alternate version of Linux, there are more how-to's below which may work:

    This is a HOWTO for Ubuntu 9.04 (Jaunty Jackalope)

    I'll give two ways to set this up. The first method (in Section I) should be easiest. The second method (in Section II) will almost always work if the first does not.

    Section I.

    First install the midisport-firmware package (firmware is included in package). You can run:

    Code:
    sudo apt-get install midisport-firmware
    Now you will need to create a configuration file (that defines the rules for recognizing the device and loading the firmware).

    You can create/edit this file by running:

    Code:
    gksudo gedit /etc/udev/rules.d/99-midisport-firmware.rules
    Then paste the following code:

    Code:
    # midisport-firmware.rules - udev rules for loading firmware into MidiSport devices
    
    # MidiSport 1x1
    ACTION=="add", SUBSYSTEM=="usb*", ATTRS{idVendor}=="0763", ATTRS{idProduct}=="1010", RUN+="/sbin/fxload -s /usr/share/usb/maudio/MidiSportLoader.ihx -I /usr/share/usb/maudio/MidiSport1x1.ihx -D %N"
    
    # MidiSport 2x2
    ACTION=="add", SUBSYSTEM=="usb*", ATTRS{idVendor}=="0763", ATTRS{idProduct}=="1001", RUN+="/sbin/fxload -s /usr/share/usb/maudio/MidiSportLoader.ihx -I /usr/share/usb/maudio/MidiSport2x2.ihx -D %N"
    
    # KeyStation
    ACTION=="add", SUBSYSTEM=="usb*", ATTRS{idVendor}=="0763", ATTRS{idProduct}=="1014", RUN+="/sbin/fxload -s /usr/share/usb/maudio/MidiSportLoader.ihx -I /usr/share/usb/maudio/MidiSportKS.ihx -D %N"
    
    # MidiSport 4x4
    ACTION=="add", SUBSYSTEM=="usb*", ATTRS{idVendor}=="0763", ATTRS{idProduct}=="1020", RUN+="/sbin/fxload -s /usr/share/usb/maudio/MidiSportLoader.ihx -I /usr/share/usb/maudio/MidiSport4x4.ihx -D %N"
    
    # MidiSport 8x8
    ACTION=="add", SUBSYSTEM=="usb*", ATTRS{idVendor}=="0763", ATTRS{idProduct}=="1031", ATTRS{bcdDevice}=="0110", RUN+="/sbin/fxload -s /usr/share/usb/maudio/MidiSportLoader.ihx -I /usr/share/usb/maudio/MidiSport8x8-2.10.ihx -D %N"
    ACTION=="add", SUBSYSTEM=="usb*", ATTRS{idVendor}=="0763", ATTRS{idProduct}=="1031", ATTRS{bcdDevice}=="0121", RUN+="/sbin/fxload -s /usr/share/usb/maudio/MidiSportLoader.ihx -I /usr/share/usb/maudio/MidiSport8x8-2.21.ihx -D %N"
    
    # vim: ft=conf
    Then save the file, it should force the rules to reload.

    Then plug in device and you should see flashing lights. This means that the firmware has loaded and you are in business.

    Tip borrowed from post #59.

    Special Notes on Ubuntu 8.10 Intrepid Ibex, 8.04 Hardy Heron

    A config file exists, but is broken. The same steps above will work, or you can edit the existing file with:

    Code:
    gksudo gedit /etc/udev/rules.d/*-midisport-firmware.rules
    Special Notes on Ubuntu 7.10 Gutsy Gibbon

    Looks like the only difference between the gutsy and the ibex file is the SUBSYSTEM string is matching on "usb_device" instead of "usb". So I used a wildcard in the conf to match both patterns. The same patch should work for both systems.

    For more info see post #39, #41

    ------------------------------------------------------------------------------------------------------------


    Section II. -- Alternate Instructions

    If the above instructions do not work, try these below... this is not the easiest method, but it will almost always work.

    See post #60:
    http://ubuntuforums.org/showpost.php...4&postcount=60

    ------------------------------------------------------------------------------------------------------------


    Section III.

    Configuring Rosegarden and Your Keyboard

    In Rosegarden, goto:

    Code:
    	Studio -> Manage Midi Devices
    I selected my midisport as the playback and record option. (I use my synthesizer for generating sound rather than my cheap sound card.)

    Note, if you hear phase shifting when recording, or choppy playback, you probably need to turn off the local control on the keyboard.
    Last edited by yaaarrrgg; February 8th, 2014 at 11:35 PM. Reason: Clean up

  2. #2
    Join Date
    Nov 2005
    Location
    the Netherlands
    Beans
    282
    Distro
    Ubuntu 7.04 Feisty Fawn

    Re: HOWTO: Setting up USB MidiSport

    I try to set up my 1x1, but get this message when i try to load:

    Code:
    jos@ubuntu:~/usbmidi$ sudo fxload -I /etc/firmware/ezusbmidi1x1 -D /proc/bus/usb/001/003
    /etc/firmware/ezusbmidi1x1: unable to open for input.
    Any ideas?
    Last edited by gosh; March 1st, 2006 at 07:59 PM.
    Ubuntu user # 7485 - Linux User # 412249
    "Oh, bother," said the Borg. "We've assimilated Pooh."

  3. #3
    Join Date
    Nov 2005
    Location
    the Netherlands
    Beans
    282
    Distro
    Ubuntu 7.04 Feisty Fawn

    Re: HOWTO: Setting up USB MidiSport

    I've found it:

    The command should read:
    Code:
    ~/usbmidi$ sudo fxload -I /etc/firmware/ezusbmidi1x1.ihx -D /proc/bus/usb/001/003
    Ubuntu user # 7485 - Linux User # 412249
    "Oh, bother," said the Borg. "We've assimilated Pooh."

  4. #4
    Join Date
    Apr 2006
    Beans
    Hidden!

    Angry Re: HOWTO: Setting up USB MidiSport

    ... seems to be no problem after all
    Last edited by arnoudscheer; April 28th, 2006 at 09:47 AM.

  5. #5
    Join Date
    Oct 2005
    Location
    IN, USA
    Beans
    274

    Re: HOWTO: Setting up USB MidiSport

    thank you for the feedback... corrected the typo.

  6. #6
    Join Date
    Oct 2006
    Location
    New Market, MD
    Beans
    43
    Distro
    Xubuntu 7.10 Gutsy Gibbon

    Re: HOWTO: Setting up USB MidiSport

    I got to the step above where I'm supposed to load the firmware on my Uno, and I got an error about some pipe being broken (I don't have it in front of me right now). So I abandoned this and used http://usb-midi-fw.sourceforge.net/

    This seems to work fine; it even seems to do plug and play, but I have to plug it in after I power up or it takes priority over my sound card and then the sound card won't work.

    I'm a new Ubuntu (and Linux) user running Dapper Drake, so that might be a reason the above step didn't work for me. Is it different than for Breezy?

  7. #7
    Join Date
    Nov 2005
    Location
    the Netherlands
    Beans
    282
    Distro
    Ubuntu 7.04 Feisty Fawn

    Re: HOWTO: Setting up USB MidiSport

    Quote Originally Posted by sbennettgso View Post
    I got to the step above where I'm supposed to load the firmware on my Uno, and I got an error about some pipe being broken (I don't have it in front of me right now). So I abandoned this and used http://usb-midi-fw.sourceforge.net/

    This seems to work fine; it even seems to do plug and play, but I have to plug it in after I power up or it takes priority over my sound card and then the sound card won't work.

    I'm a new Ubuntu (and Linux) user running Dapper Drake, so that might be a reason the above step didn't work for me. Is it different than for Breezy?
    I just tried this too, but didn't work on my 1x1. So no plug and play for me, not even after reboot with or without usb plugged in.
    Ubuntu user # 7485 - Linux User # 412249
    "Oh, bother," said the Borg. "We've assimilated Pooh."

  8. #8
    Join Date
    Nov 2005
    Location
    the Netherlands
    Beans
    282
    Distro
    Ubuntu 7.04 Feisty Fawn

    Re: HOWTO: Setting up USB MidiSport

    Q: Why does the device number and name of the device change after fxload?
    This is what I mean.

    before fxload: Bus 005 Device 009, name Midiman Midisport 1x1
    Code:
    jos@jos-desktop:/tmp/midisport-firmware-1.2$ lsusb
    Bus 005 Device 009: ID 0763:1010 Midiman Midisport 1x1
    Bus 005 Device 007: ID 05ac:1300 Apple Computer, Inc. iPod Shuffle
    Bus 005 Device 006: ID 6993:b001 Freshtel FT-102 VoIP USB Phone
    Bus 005 Device 002: ID 07ff:00ff  
    Bus 005 Device 004: ID 0930:653e Toshiba Corp. 
    Bus 005 Device 003: ID 0409:0058 NEC Corp. HighSpeed Hub
    Bus 005 Device 001: ID 0000:0000  
    Bus 004 Device 001: ID 0000:0000  
    Bus 003 Device 001: ID 0000:0000  
    Bus 001 Device 002: ID 045e:00d1 Microsoft Corp. 
    Bus 001 Device 001: ID 0000:0000  
    Bus 002 Device 002: ID 046d:08c5 Logitech, Inc. 
    Bus 002 Device 001: ID 0000:0000
    After fxload: Bus 005 Device 010, name Midiman
    Code:
    jos@jos-desktop:/tmp/midisport-firmware-1.2$ sudo midisportsetup
    fxload -I /etc/firmware/ezusbmidi1x1.ihx -D /proc/bus/usb/005/009
    jos@jos-desktop:/tmp/midisport-firmware-1.2$ lsusb
    Bus 005 Device 010: ID 0763:1110 Midiman 
    Bus 005 Device 007: ID 05ac:1300 Apple Computer, Inc. iPod Shuffle
    Bus 005 Device 006: ID 6993:b001 Freshtel FT-102 VoIP USB Phone
    Bus 005 Device 002: ID 07ff:00ff  
    Bus 005 Device 004: ID 0930:653e Toshiba Corp. 
    Bus 005 Device 003: ID 0409:0058 NEC Corp. HighSpeed Hub
    Bus 005 Device 001: ID 0000:0000  
    Bus 004 Device 001: ID 0000:0000  
    Bus 003 Device 001: ID 0000:0000  
    Bus 001 Device 002: ID 045e:00d1 Microsoft Corp. 
    Bus 001 Device 001: ID 0000:0000  
    Bus 002 Device 002: ID 046d:08c5 Logitech, Inc. 
    Bus 002 Device 001: ID 0000:0000
    Ubuntu user # 7485 - Linux User # 412249
    "Oh, bother," said the Borg. "We've assimilated Pooh."

  9. #9
    Join Date
    Oct 2005
    Location
    IN, USA
    Beans
    274

    Re: HOWTO: Setting up USB MidiSport

    hmmm good question! I hadn't noticed that.

    I wonder if fxload is re-registering the usb device? Maybe the first is the default usb connection (which is broken?) ... not sure.

  10. #10
    Join Date
    Jul 2006
    Beans
    31

    Re: HOWTO: Setting up USB MidiSport

    Hi,
    Great instructions!
    I have a midiman usb 2x2. Carried out the instruction for 1x1 by mistake first. The firmware did load though. With 2x2 firmware loaded the box seems to be all good. Input from both A and B seems fine going on the light from the indicators.
    But how do I get this to work in Pure Data?
    I have a layla 24 but couldn't get the midi to work (didn't try to hard). There is no option in pd to use the midiman device for midi only
    - default midi (which gave no options)
    - alsa midi which started fine but PD did not register any input. Granted I did not look any further into this.

    Should the midi man appear as the default device? As I said the box itself looks good with it's interaction with the keyboard.

    regards,
    Conor

Page 1 of 9 123 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •