Page 1 of 4 123 ... LastLast
Results 1 to 10 of 36

Thread: [8.04->8.10] Xlib: extension "RANDR" missing on display ":0.0"

  1. #1
    Join Date
    Apr 2006
    Beans
    136

    [8.04->8.10] Xlib: extension "RANDR" missing on display ":0.0"

    I've upgraded two of my boxes from 8.04 to 8.10 and am getting the following error on both:

    Xlib: extension "RANDR" missing on display ":0.0"

    I know it's some type of video/X11 error, but how do I fix it? Whenever I open anything graphical it prints out that message, and its rather annoying


    BTW: both machines I've done this on are dual screens, and both have NVIDIA cards and drivers
    Last edited by zackiv31; October 30th, 2008 at 09:08 PM.

  2. #2
    Join Date
    Oct 2008
    Beans
    115
    Distro
    Ubuntu

    Re: [8.04->8.10] Xlib: extension "RANDR" missing on display ":0.0"

    Same problem here. Nvidia and xinerama.

  3. #3
    Join Date
    May 2008
    Beans
    2

    Re: [8.04->8.10] Xlib: extension "RANDR" missing on display ":0.0"

    I'm also getting this error on a fresh install of the 64 bit version of 8.10. Also, when I try to enable any of the Compiz stuff from the Appearance Preferences/Visual Effects screen I get a error dialog that says "The Composite extension is not available". I have 2 LCD panels using Xinerama that I configued using the nvidia-settings utility.

  4. #4
    Join Date
    Oct 2008
    Beans
    115
    Distro
    Ubuntu

    Re: [8.04->8.10] Xlib: extension "RANDR" missing on display ":0.0"

    Well, then it is prolly at least not the fault of nVidia, because I configured the displays manually via xorg.conf (aparently, nv-settinggs' xinerama did not work for me).

    PS I was getting the exact error as well after upgrading as now, after fresh installation.
    Last edited by lores; November 1st, 2008 at 12:22 PM.

  5. #5
    Join Date
    Sep 2007
    Beans
    18

    Re: [8.04->8.10] Xlib: extension "RANDR" missing on display ":0.0"

    JoHandsum,

    your problem there has nothing to do with RandR. You need to enable the composite extension in your xorg.conf file. In general, if you want compiz, your basically going to have to go with twinview ( and not xinerama) from my experience. Maybe that has changed, but it definitely used to be that way when I tried it. There are a host of issues that pop up when using compiz on a dual-head, dual-display setup (I wont go into them, some of them I`ve never found a solution for). My suggestion is to not even bother, if you have a dual display, its likely for productivity, and the extra bells and whistles arent really adding much are they.

    Hope that puts you at ease about the "error" (I get it too, and its obviously some quirk to do with X11). Hope the above gives you some help.

    oh and last but not least, from my experience, the NVIDIA utility is garbage and you best do the xorg.conf editing by hand. Try it out yourself. You can make changes in the GUI that dont all "stick" and it doesnt even show all the important settings/extensions and what have you. In fact, I`m no unix mastermind, but in general, i`ve found that if you dont know how to edit the config by hand, you probably shouldnt be doing it most of the time (my two cents).
    Last edited by gus_393; November 2nd, 2008 at 01:15 AM.

  6. #6
    Join Date
    Oct 2008
    Beans
    115
    Distro
    Ubuntu

    Re: [8.04->8.10] Xlib: extension "RANDR" missing on display ":0.0"

    Hello again.

    I'm posting my xorg.conf, as it provides both - functional xinerama and compiz. NVidia utility did not work for me, so I've written it by hand. It includes also the important entry
    Code:
    Section "Extensions"
        Option         "Composite" "Enable"
    EndSection
    which might me especially helpful for You (I can remember having had Your issue a long time ago).

    However, I have been testing this config just for one day now, and I keep getting the error message "Xlib: extension "RANDR" missing on display ":0.0"." (sometimes it appears doubled) when opening nearly anything (from the terminal), if not everything. Anyway, I don't know if it implies any malfunctionality, because I use just the basic compiz and no games or 3D-intensive apps whatsoever.

    Post any results!

    Code:
    # nvidia-settings: X configuration file generated by nvidia-settings
    # nvidia-settings:  version 1.0  (buildd@vernadsky)  Thu Jun  5 09:26:53 UTC 2008
    
    # xorg.conf (X.Org X Window System server configuration file)
    #
    # This file was generated by dexconf, the Debian X Configuration tool, using
    # values from the debconf database.
    #
    # Edit this file with caution, and see the xorg.conf manual page.
    # (Type "man xorg.conf" at the shell prompt.)
    #
    # This file is automatically updated on xserver-xorg package upgrades *only*
    # if it has not been modified since the last upgrade of the xserver-xorg
    # package.
    #
    # If you have edited this file but would like it to be automatically updated
    # again, run the following command:
    #   sudo dpkg-reconfigure -phigh xserver-xorg
    
    Section "Module"
    	Load		"glx"
    EndSection
    
    Section "InputDevice"
        Identifier     "Generic Keyboard"
        Driver         "kbd"
        Option         "XkbRules" "xorg"
        Option         "XkbModel" "pc105"
        Option         "XkbLayout" "pl"
    EndSection
    
    Section "InputDevice"
        Identifier     "Configured Mouse"
        Driver         "mouse"
        Option         "CorePointer"
        Option         "Device" "/dev/input/mice"
        Option         "Protocol" "ExplorerPS/2"
        Option         "Buttons" "7"
        Option         "ZAxisMapping" "6 7"
        Option         "ButtonMapping" "1 2 3 6 7"
        Option         "Emulate3Buttons" "true"
        Option         "Sensitivity" "1.3"
        Option         "Resolution" "800"
    EndSection
    
    Section "Monitor"
        Identifier     "Monitor0"
        VendorName     "Unknown"
        ModelName      "BenQ FP93GP"
        HorizSync       31.0 - 83.0
        VertRefresh     56.0 - 76.0
    EndSection
    
    Section "Monitor"
        Identifier     "Monitor1"
        VendorName     "Unknown"
        ModelName      "HP LP1965"
        HorizSync       31.0 - 83.0
        VertRefresh     56.0 - 76.0
    EndSection
    
    Section "ServerLayout"
        Identifier     "Default Layout"
        Screen      0  "Screen0" 0 0
    EndSection
    
    Section "ServerFlags"
        Option         "Xinerama" "1"
    EndSection
    
    Section "Device"
        Identifier     "Videocard0"
        Driver         "nvidia"
        VendorName     "NVIDIA Corporation"
        BoardName      "GeForce 8600 GT"
    EndSection
    
    Section "Screen"
        Identifier     "Screen0"
        Device         "Videocard0"
        Monitor        "Monitor0"
        DefaultDepth    24
        Option         "AddARGBGLXVisuals" "True"
        Option         "RenderAccel" "true"
        Option         "NoLogo" "1"
        Option         "TwinView" "1"
        Option         "metamodes" "1280x1024_60 1280x1024_60"
    EndSection
    
    Section "Extensions"
        Option         "Composite" "Enable"
    EndSection

  7. #7
    Join Date
    Sep 2007
    Beans
    18

    Re: [8.04->8.10] Xlib: extension "RANDR" missing on display ":0.0"

    just in relation to what lores said, I know this might be obvious, but I thought I would make it explicit that odds are you cant just copy and paste that config for your own use.

    please note that he set the screen metamodes explicitly aswell as the montior refresh rates (you should probably set these in line with your own, or else use auto-detect for the metamodes). Also, there is the possible annoyance that he also set the mouse sensitivity and what have you. Im just pointing this out because I`m willing to bet someone might just blindly copy it over and experience issues.

    my experience has been that you cant properly enable composite while running xinerama. The config above, from what I can gather (and i`m no expert) isnt even running xinerama (in actuality) because people have told me that twinview over-rides whatever you set for xinerama.

    I have noticed for myself that whenever I disable xinerama with twinview enabled, that I get two seperate gnome desktop bars on each screen (that is I can use them as one, but I have double the task bars). So I usually leave it on aswell, but again, I`m told its not actually running xinerama (which to my understanding is basically just a glorified way to have two completely seperate x screens that can share a mouse pointer, and not much else).

    anyway, all that said (hopefully in protection of newcomers from bashing their xorg.conf), I would greatly like to hear if anyone finds out about the randr error.

    My suggestion, if someone has the time, would be to report it to the bug tracker. I`ll do it myself when I have the time to go through it, but that wont be for a little while.

  8. #8
    Join Date
    Oct 2008
    Beans
    115
    Distro
    Ubuntu

    Re: [8.04->8.10] Xlib: extension "RANDR" missing on display ":0.0"

    You're right, Gus, but I should've pasted just the relevant part of my xorg.conf - my bad. Anyway, one should always try to understand what EACH LINE means + make a backup before any modification...

    From what I've just tested I can say that extended compiz desk-effects work for me just great, though I ordinarily use the standard ones. I can't really say what the matter with this error message is, as I can't seem to observe any setbacks. Additionally, Phun is working fine as well, and I currently don't use any other gfx-apps.

    According to the config - I've two LCDs which I'm using as one extended wide-display, i. e. I've shared bars, windows, mouse etc. for both monitors (and one window can span both of them simultaneously). This did not work for me until I enabled xinerama in xorg.conf, so I kept thinking I was actually using xrama .

    Another thing is - when I $gedit or $sudo gedit, I get one randr error, and when I $gksudo gedit (which is usually the case), I get this error twice (instantly two e-messages). So, this is surely strictly connected with just thee gfx-srv. Also, I certainly can't run xrandr - when I try, I get
    Code:
    Xlib:  extension "RANDR" missing on display ":0.0".
    RandR extension missing
    , yet I don't really miss it, so...

    Hope it helps one.
    Last edited by lores; November 2nd, 2008 at 06:44 PM.

  9. #9
    Join Date
    Jan 2008
    Location
    Paris, France
    Beans
    8
    Distro
    Ubuntu

    Re: [8.04->8.10] Xlib: extension "RANDR" missing on display ":0.0"

    I had the same issue after the upgrade Ubuntu 8.04 -> 8.10.
    I solved it by disabling Xinerama in xorg.conf . I have an ati card.

    This seems to be an already documented (but unsolved) bug : here. (I wrote the last message).

    I don't know if you can use your dual-screen display without Xinerama (don't have one) but this could be a solution.

  10. #10
    Join Date
    Nov 2008
    Beans
    1

    Re: [8.04->8.10] Xlib: extension "RANDR" missing on display ":0.0"

    I'm also experiencing this error, but as others have mentioned it's of little consequence to me - Compiz was kinda nice but I didn't really use any of it (apart from some keyboard shortcuts I can recreate elsewhere.)

    That said - is there any way to permanently suppress this error? For example one of the in-house development tools is wxWidgets-based and causes this error every time it starts, which gets old fast.

Page 1 of 4 123 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •