Results 1 to 7 of 7

Thread: [SOLVED] loud squelch when shutdown

  1. #1
    Join Date
    Feb 2008
    Beans
    147
    Distro
    Ubuntu 8.10 Intrepid Ibex

    [SOLVED] loud squelch when shutdown

    When i select shutdown from the panel and confirm it I get a loud squelch from the internal speaker. Does this happen to other people too and how can I disable it?

  2. #2
    Join Date
    Jan 2007
    Beans
    1,010
    Distro
    Kubuntu Development Release

    Re: loud squelch when shutdown

    Does this happen if you disable the internal speaker?
    my shiz: http://inportb.com/
    use Dropbox if you need an awesome free file hosting service; please follow my referral link for an extra 256MB of free storage.

  3. #3
    Join Date
    Feb 2008
    Beans
    147
    Distro
    Ubuntu 8.10 Intrepid Ibex

    Re: loud squelch when shutdown

    Turned off the internal speaker using advice from this thread and it no longer beeps

    Quote Originally Posted by carney1979 View Post
    Try this:

    From a Gnome-Terminal:

    Code:
    sudo gedit /etc/modprobe.d/blacklist
    Scroll to the end of the file and enter:

    Code:
    blacklist pcspkr
    Save the file, exit gedit.

    then in the terminal type:

    Code:
    sudo rmmod pcspkr
    You should never hear that system beep again when you shut down.

    Upon any further system startups the line you added in the blacklist file will keep the pc speaker's module from being loaded.

    Worked for me.

    David

  4. #4
    Join Date
    Feb 2007
    Beans
    25

    Re: [SOLVED] loud squelch when shutdown

    what is the actual cause of this, rather then just resorting to turning off the system speaker ?

  5. #5
    Join Date
    Jan 2007
    Beans
    1,010
    Distro
    Kubuntu Development Release

    Re: [SOLVED] loud squelch when shutdown

    I am not sure. But I blacklist that module anyway as I find the system beep annoying in other situations as well.
    my shiz: http://inportb.com/
    use Dropbox if you need an awesome free file hosting service; please follow my referral link for an extra 256MB of free storage.

  6. #6
    Join Date
    Aug 2008
    Location
    Hannover, Germany
    Beans
    181

    Re: [SOLVED] loud squelch when shutdown

    Following a lead from another thread, I tried using the new "fast user switcher" thingy instead of the old shutdown button (which I had been using) and found that the beep disappeared. Again, the normal shutdown button that I either retained on my system when upgrading from Hardy or which I added later (I can't recall) seems to be the culprit. Using the now-standard user switcher, there is no beep.
    Shane

  7. #7
    Join Date
    Nov 2007
    Location
    NC, USA
    Beans
    829
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: [SOLVED] loud squelch when shutdown

    Even when I disabled the pcspkr module, mine still beeped. It hasnt done so in about a week now, but Im waiting for it to go ballstic during class again.
    Linux User #460341 || Ubuntu User #19510 || Unanswered Posts Team

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •