Results 1 to 7 of 7

Thread: problem with latex and eps in Kile

  1. #1
    Join Date
    Oct 2008
    Location
    Netherlands
    Beans
    7
    Distro
    Ubuntu 8.04 Hardy Heron

    problem with latex and eps in Kile

    Hi everybody,

    latex has 0 errors, 0 warnings and still it doesn't display my eps or jpg in the dvi or the pdf file.
    After compiling latex it says nothing or pdflatex is says exit with error status 70.

    I have already tried usepackage{graphics, graphicx, psfigure, pstopdf, ifpdf etc}


    Latex compiles all right, but the viewer doesn't make a file with pictures.

    I'm using Kile in Ubuntu-->Hardy Heron-->8.04-->gnome environment

    here's my tex code
    \documentclass[a4paper,11pt,draft]{article}

    \usepackage{amsmath}
    \usepackage[UKenglish]{babel}
    \usepackage{graphics}
    \usepackage[dvips, pdftex]{graphicx}
    \usepackage{pspicture}
    %\usepackage{ifpdf}
    %\ifpdf
    %\usepackage[pdftex]{hyperref}
    %\else
    %\usepackage[dvipdfm]{hyperref}
    %\fi


    \author{me}
    \title{Test}
    \date{2008-10-27}


    \begin{document}
    \maketitle

    bgkhbngkghkjnhjkhnklghnhkglnghkn

    \noindent jfmgflgjgfjlfgjglk


    \begin{figure}
    \centering
    \includegraphics{test}
    \caption{test}
    \label{fig:test}
    \end{figure}


    \end{document}

  2. #2
    Join Date
    May 2007
    Beans
    125

    Re: problem with latex and eps in Kile

    First, try running LaTeX multiple times over the document (I don't know why this works, but 3 times is usually enough).

    If that doesn't work, I'd suggest changing the line
    Code:
    \includegraphics{test}
    to
    Code:
    \includegraphics{test.eps}
    and running LaTeX at least 3 times over the resulting document.

    If *that* doesn't work, try converting your figures to pdf with ps2pdf.

  3. #3
    Join Date
    Oct 2008
    Beans
    56

    Re: problem with latex and eps in Kile

    Hi,

    just remove the option draft in this line:
    Quote Originally Posted by gaarheidswafel View Post
    \documentclass[a4paper,11pt,draft]{article}
    because the draft option suppresses the inclusion of graphics, just boxes with the filename will be displayed.

    Regarding these lines:
    Quote Originally Posted by gaarheidswafel View Post
    \usepackage{graphics}
    \usepackage[dvips, pdftex]{graphicx}
    just
    Code:
    \usepackage{graphicx}
    is enough. graphics will be loaded by graphicx. Don't set driver options like dvips and pdftex if it's not really necessary, it should be automatically detected.
    You could find some useful documents concerning the import of graphics with LaTeX here.

    Stefan
    Last edited by Stefan_K; October 28th, 2008 at 04:44 PM.

  4. #4
    Join Date
    Oct 2008
    Location
    Netherlands
    Beans
    7
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: problem with latex and eps in Kile

    Thank you Paul and Stefan!

    the solution of Stefan worked!

    Thanks very much!

  5. #5
    Join Date
    Nov 2006
    Beans
    185

    Re: problem with latex and eps in Kile

    Quote Originally Posted by gaarheidswafel View Post
    Thank you Paul and Stefan!

    the solution of Stefan worked!

    Thanks very much!
    It would be very useful to those of us who write LaTeX documentation if you could say where you got the idea for mixing \usepackage{graphics,graphicx} so that we can make it clearer that \usepackage{graphicx} is usually all you need.

  6. #6
    Join Date
    Aug 2012
    Beans
    1

    problem with figures in kile

    figures are not getting added in doc after i run latex in kile on ubuntu

    \documentstyle{llncs}
    \newtheorem{observation}{Observation}
    %\usepackage{graphicx}
    %\usepackage{epstopdf}
    \title{Improved Average Interference in Wireless Sensor Networks}
    \author{}
    \institute{Department of Computer Science and Engineering,\\ Tezpur University,
    Assam, 786028, India
    \and
    Department of Mathematics,\\Indian Institute of Technology, Guwahatii, 781 - 039, India}
    \date{}
    \begin{document}
    \maketitle
    \input{psfig.sty}

    \begin{abstract}

  7. #7
    Join Date
    Oct 2007
    Beans
    1,914
    Distro
    Lubuntu 12.10 Quantal Quetzal

    Re: problem with figures in kile

    Quote Originally Posted by Manju116 View Post
    figures are not getting added in doc after i run latex in kile on ubuntu
    Note that it is typically advisable to start a new thread here if the older thread is .... very old.

    First, why did you comment out "\usepackage{graphicx}"?

    Second, try to run "pdflatex <yourpaper>.tex" from the terminal and see if it hangs somewhere. Kile sometimes suppresses certain errors.

    Third, "\input{psfig.sty}" is a very weird line - where did you got that from? Typically, you would rather want "\usepackage{psfig}", and this command has to be put *before* "\begin{document}".

    Finally, if these things do not work, build a *minimal, complete LaTeX code example* that shows your problem, and post it here together with the LaTeX output you received. There problem with your post here is that id doesn't actually show the lines of the document in which some figure is added.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •