Results 1 to 6 of 6

Thread: HDMI Sound In 11.10

  1. #1
    Join Date
    Dec 2010
    Beans
    21

    HDMI Sound In 11.10

    I have asked about this in Multimedia and Sound but to no avail.

    OK i have of course seen many threads on this but i have tried all of the suggestions, gone through the "comprehensive guide..." and because of what has happened i believe someone may be able to help and therefore help many others.

    My PC is connected via HDMI to a TV. If i hook up my headphones to the back of the PC i hear everything. If i take them out i only hear the sound from games (Eternal Lands and Glest).

    So, those games must be activating/loading the correct sound driver right? I've looked for any hints of what they are loading in config files etc but can't find anything.

    Banshee plays audio, VLC plays audio and Epiphany web browser plays audio.

    Firefox and Chromium don't.

    Grateful for any help.

    Ubuntu 11.10 64 bit.
    Radeon 6300 on board graphics.

  2. #2
    Join Date
    Jul 2011
    Location
    South-Africa
    Beans
    678
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: HDMI Sound In 11.10

    Hay,

    Open up your sound preferences (Type "sound" in the panel and you should find it)

    Make sure your output is set to "Digital" or "HD Media" or "HDMI" or such... Most guides on the internet asume you have already checked this.

    Just stating the obvious since its sometimes overlooked.

    Cherz
    Switched away from windows XP to Ubuntu 9.04. Never turned around to look back.

  3. #3
    Join Date
    Dec 2010
    Beans
    21

    Re: HDMI Sound In 11.10

    Thanks for the reply zero. Yes, in sound, hardware there are 2 devices - HDMI output and analogue stereo.

    The only thing that isn't producing sound now is Mozilla Firefox (my browser of choice because of BBC iPlayer, ITV player etc) and the O/S itself. Although i can hear audio on Firefox if i plug my headphones into the jack on the back of the PC.

  4. #4
    Join Date
    Jun 2009
    Location
    0:0:0:0:0:0:0:1
    Beans
    4,357
    Distro
    Xubuntu 13.04 Raring Ringtail

    Re: HDMI Sound In 11.10

    File:
    /etc/asound.conf
    Content:
    Code:
    pcm.pulse {
    type pulse
    }
    ctl.pulse {
    type pulse
    }
    pcm.!default {
    type pulse
    }
    ctl.!default {
    type pulse
    }
    That fixed it for my mom (lucid 64bit/nvidia gt 430) [related thread]
    you may need to log out and in or reboot for it to take effect
    Last edited by pqwoerituytrueiwoq; March 14th, 2012 at 07:41 PM.
    Laptop: ASUS A54C-NB91 (Storage: WD3200BEKT + MKNSSDCR60GB-DX); Desktop: Custom Build - Images included; rPi Server
    Putting your Networked Printer's scanner software to shame PHP Scanner Server
    I frequently edit my post when I have the last post

  5. #5
    Join Date
    Dec 2010
    Beans
    21

    Re: HDMI Sound In 11.10

    Well i can't quite believe it pqw, that worked! I shall post that on my other thread and put it to solved.

    Thanks very much!

  6. #6
    Join Date
    Dec 2010
    Beans
    21

    Re: HDMI Sound In 11.10

    Could someone just explain what the pcm and the ctl commands are?

    Rather than just getting sound and being happy i'd like to learn from this.

    Thanks very much.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •