Page 11 of 87 FirstFirst ... 9101112132161 ... LastLast
Results 101 to 110 of 867

Thread: SiS 771/671 Mirage 3 Video Drivers

  1. #101
    Join Date
    Dec 2007
    Beans
    37

    Re: SiS 771/671 Mirage 3 Video Drivers!?!?

    Quote Originally Posted by Solarium View Post
    Well i got satux 1.8 the driver works, i got full 3D the supertux game runs, the wifi works nothing bad to say ....

    It seems like satux 1.8 is just a mod of debian etch so these drivers might work on it.

    Think i am gonna stick with it for a while, in the installation of 1.8 u can make it in english.
    Solarium,

    Can you please post the result of 'sudo dpkg-query -l xserver-xorg-core xorg' ?

    Thanks,

    Pierre.
    Last edited by zorglups; February 12th, 2009 at 12:59 PM.

  2. #102
    Join Date
    Dec 2008
    Location
    Haifa, Israel
    Beans
    36
    Distro
    Ubuntu 8.10 Intrepid Ibex

    Re: SiS 771/671 Mirage 3 Video Drivers!?!?

    Code:
    satux@Satux:~$ sudo dpkg-query -l xserver-xorg-core xorg
    Desired=Unknown/Install/Remove/Purge/Hold
    | Status=Not/Installed/Config-files/Unpacked/Failed-config/Half-installed
    |/ Err?=(none)/Hold/Reinst-required/X=both-problems (Status,Err: uppercase=bad)
    ||/ Name           Version        Description
    +++-==============-==============-============================================
    ii  xorg           7.1.0-19       X.Org X Window System
    ii  xserver-xorg-c 1.1.1-21etch5  X.Org X server -- core server
    satux@Satux:~$

    BTW: trying some stuff and asking on the satux forums the sis3d they got does not support compiz at all which kinda was my purpose in all of this

    How ever full screen video / stream video (youtube) works super good much better then ubuntu very smooth, and i can run the games talked about in this thread.

    *How i wish that we had a good working real 3D driver*

  3. #103
    Join Date
    May 2006
    Beans
    7

    Re: SiS 771/671 Mirage 3 Video Drivers!?!?

    Can anyone confirm whether this driver should also work on the Intel D201GLY2A board with Ubuntu 8.10? I can't get it to work...

  4. #104
    Join Date
    Feb 2009
    Beans
    2

    Re: SiS 771/671 Mirage 3 Video Drivers!?!?

    Hi all,

    I'm struggling increasing the screen resolution to 1200x800 using the driver provided in this threat by Barros Lee. The maximum I get is 800x600.

    I have the following adapter in my laptop (Acer Aspire 3003WLMi)

    archie@home:~$ lspci | grep VGA
    01:00.0 VGA compatible controller: Silicon Integrated Systems [SiS] 661/741/760 PCI/AGP or 662/761Gx PCIE VGA Display Adapter

    Under Ubuntu 8.05, everything worked fine using this xorg.conf settings:

    Section "Module"
    Load "bitmap"
    Load "dbe"
    Load "ddc"
    # Load "dri"
    Load "evdev"
    Load "extmod"
    Load "freetype"
    Load "glx"
    Load "int10"
    Load "record"
    Load "synaptics"
    # Load "type1"
    Load "vbe"
    EndSection

    Section "Device"
    Identifier "SiSVideoCard"
    Driver "sis"
    BusID "PCI:1:0:0"
    Option "UseSSE" "yes"
    Option "ScaleLCD" "no"
    Option "CenterLCD" "yes"
    # Option "ForceCRT1Type" "vesa"
    # Option "ForceCRT1VGAspect" "normal"
    # Option "ForceCRT2Type" "LCD"
    EndSection

    Section "Monitor"
    Identifier "LaptopMonitor"
    Option "DPMS"
    # HorizSync 30-67
    # VertRefresh 30-60
    Modeline "1280x800@60" 83.91 1280 1312 1624 1656 800 816 824 841
    EndSection

    Section "Screen"
    Identifier "Default Screen"
    Device "SiSVideoCard"
    Monitor "LaptopMonitor"
    Option "metamodes" "1280x800@60 +0+0; 800x600 +0+0"
    DefaultDepth 24
    SubSection "Display"
    Depth 1
    Modes "1280x800" "800x600" "640x480"
    ViewPort 0 0
    EndSubSection
    SubSection "Display"
    Depth 4
    Modes "1280x800" "800x600" "640x480"
    EndSubSection
    SubSection "Display"
    Depth 8
    Modes "1280x800" "800x600" "640x480"
    EndSubSection
    SubSection "Display"
    Depth 15
    Modes "1280x800" "800x600" "640x480"
    EndSubSection
    SubSection "Display"
    Depth 16
    Modes "1280x800" "800x600" "640x480"
    EndSubSection
    SubSection "Display"
    Depth 24
    Modes "1280x800" "800x600" "640x480"
    EndSubSection
    EndSection

    Section "ServerLayout"
    Identifier "Default Layout"
    Screen "Default Screen"
    EndSection

    Section "DRI"
    Mode 0666
    EndSection

    Find attached the Xorg.0.log when I start X using my old xorg.conf.

    Did anyone have a similar problem and found a solution for that?

    Cheers
    Uwe
    Attached Files Attached Files

  5. #105
    Join Date
    Feb 2009
    Beans
    3

    Re: SiS 771/671 Mirage 3 Video Drivers!?!?

    I get the same problem as Uwe.
    I've tried it on exactly the same laptop (Acer Aspire 3003WLMi). The maximum I get is 1024x768 with xorg.conf like follows:

    Code:
    Section "Device"
    identifier "Generic Video Card"
    boardname "sis"
    busid "PCI:1:0:0"
    driver "vesa"
    screen 0
    EndSection
    
    Section "Monitor"
    identifier "Generic Monitor"
    vendorname "Generic"
    modelname "Flat Panel 1280x800"
    HorizSync 31.5-90
    VertRefresh 60
    modeline "1280x800@60.00" 83.46 1280 1344 1480 1680 800 801 804 828 -hsync +vsync
    gamma 1.0
    EndSection
    
    Section "Screen"
    Identifier "Default Screen"
    Device "Generic Video Card"
    Monitor "Generic Monitor"
    DefaultDepth 24
    SubSection "Display"
    depth 24
    modes "1280x800@60"
    EndSubSection
    EndSection
    It worked on Ubuntu 7.04.
    Any suggestions will be appreciated as I've tried anything that comes to my mind twice.

  6. #106
    Join Date
    Jun 2008
    Location
    Netherlands
    Beans
    Hidden!

    Re: SiS 771/671 Mirage 3 Video Drivers!?!?

    @majkelpl

    :You need to set your driver to "sis" , instead of "vesa"

    @captainarcher
    :disable your Modeline, by putting # in front of it.
    and enable your HorizSync and VertRefresh by leaving # away.
    also I guess you also best disable all the other extra modelines/methamodes etc.

    Here's my Xorg.conf.

    This is what keeps my sis 771/671 running in 1280x800



    Section "InputDevice"
    Identifier "Generic Keyboard"
    Driver "kbd"
    Option "XkbRules" "xorg"
    Option "XkbModel" "pc105"
    Option "XkbLayout" "us"
    EndSection

    Section "InputDevice"
    Identifier "Configured Mouse"
    Driver "mouse"
    Option "CorePointer"
    EndSection

    Section "InputDevice"
    Identifier "Synaptics Touchpad"
    Driver "synaptics"
    Option "SendCoreEvents" "true"
    Option "Device" "/dev/psaux"
    Option "Protocol" "auto-dev"
    Option "HorizEdgeScroll" "0"
    EndSection

    Section "Device"
    Identifier "Configured Video Device"
    Boardname "SIS Real256E"
    Busid "PCI:1:0:0"
    Driver "sis"
    Screen 0
    Vendorname "SIS"
    Option "EnableSisCtrl" "yes"
    Option "XvDefaultAdaptor" "Blitter"
    Option "AddARGBGLXVisuals" "True"
    EndSection

    Section "Monitor"
    Identifier "Configured Monitor"
    HorizSync 31.0 - 48.0
    VertRefresh 50.0 - 100.0

    EndSection

    Section "Screen"
    Identifier "Default Screen"
    Monitor "Configured Monitor"
    Device "Configured Video Device"
    SubSection "Display"
    Viewport 0 0
    Depth 24
    Modes "1280x800"
    EndSubSection

    EndSection

    Section "ServerLayout"
    Identifier "Default Layout"
    Screen "Default Screen"
    InputDevice "Synaptics Touchpad"
    EndSection
    Last edited by mhgsys; February 24th, 2009 at 05:57 PM.

  7. #107
    Join Date
    Feb 2009
    Beans
    2

    Re: SiS 771/671 Mirage 3 Video Drivers!?!?

    Thanks mhgsys, but unfortunately, it doesn't seem to be that easy. I removed all these settings but still, I only get 800x600

  8. #108
    Join Date
    Jun 2008
    Location
    Netherlands
    Beans
    Hidden!

    Re: SiS 771/671 Mirage 3 Video Drivers!?!?

    @Captainarcher.

    I just saw you need another driver then I do myself.
    You have a different videocard

    I'm pretty sure your Xorg.conf isn't the real problem here,
    I guess you're trying to enable a sis 771/671 driver on a sis 661/741/760

    You should delete all the sis driver files and download the correct ones.

    Good luck with finding them .

    mhgsys.

  9. #109
    Join Date
    Dec 2008
    Beans
    1

    Smile Re: SiS 771/671 Mirage 3 Video Drivers!?!?

    adding the refresh rates to the conf file worked, thanks

  10. #110
    Join Date
    Feb 2009
    Beans
    12
    Distro
    Ubuntu 8.10 Intrepid Ibex

    Re: SiS 771/671 Mirage 3 Video Drivers!?!?

    Hey guys
    I got the 2d drivers for intrepid today
    Finally got them working =]

    Compiz says it can't run because of "software rasterizer"

    Is there anything i can do about that or is it a lost cause ?

Page 11 of 87 FirstFirst ... 9101112132161 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •