Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: Impossible to install Ubuntu on HP

  1. #1
    Join Date
    Dec 2005
    Beans
    65

    Impossible to install Ubuntu on HP

    Hi,
    I tried to install Ubuntu 8.04 on a HP Vista 8530w.

    I get errors like cpu#1 busy. If I use options such as nolapic and so on, I still can't install it. I get a lot of sata errors.

    System specification:
    http://www.neptun.ethz.ch/hardware/m...specs_large_EN

  2. #2
    Join Date
    Jun 2006
    Beans
    7,419
    Distro
    Ubuntu 8.04 Hardy Heron

  3. #3
    Join Date
    Dec 2005
    Beans
    65

    Re: Impossible to install Ubuntu on HP

    Thanks for the link. So this means, it's actually an Ubuntu bug or more specific the kernel, which doesn't work for such a new notebook?
    Is there kind of a "rule", how long it will take until this bug will be fixed. Because now I'm using Vista and I really hate it. Nearly nothing runs correctly.

  4. #4
    Join Date
    Apr 2007
    Beans
    44

    Re: Impossible to install Ubuntu on HP

    Hello Sanix,

    I wrote you also in the launchpad bug which i opened this week. For me ubuntu works when I use acpi=off, although its not really a solution to work without acpi...

    If you can boot ubuntu, you have to install the latest NVidia Graphic driver (177.80, not included in Ibex). You can find a manuel here https://help.ubuntu.com/community/NvidiaManual.

    Does Sound works for you? For me not atm, but i dont know what the problem might be... aplay -l show devices, but it doesnt work:
    **** Liste von PLAYBACK Geräten ****
    Karte 0: Intel [HDA Intel], Gerät 0: AD198x Analog [AD198x Analog]
    Untergeordnete Geräte: 1/1
    Untergeordnetes Gerät '0: subdevice #0
    Karte 0: Intel [HDA Intel], Gerät 1: AD198x Digital [AD198x Digital]
    Untergeordnete Geräte: 1/1
    Untergeordnetes Gerät '0: subdevice #0

    Anyone any idea?

    Bye
    falstaff

  5. #5
    Join Date
    Apr 2007
    Beans
    44

    Post Re: Impossible to install Ubuntu on HP

    News from here:

    I installed Ubuntu 8.10 AMD64. I had to activate the failsave graphic mode (F4) and add advanced options (F6) and add there acpi=ht. With this options the installation went fine!

    Strange: I tried once again to boot with acpi, and it worked! But only once, so the acpi bug seems to be a sporadical bug.

    After i started sucessfully I installed nvidia restricted drivers, and they are working now like a charm!

    I found out that sound at the headphone 3.5 jack works! So only speaker does not work, any how to solve this?

    bye
    falstaff

  6. #6
    Join Date
    Dec 2005
    Beans
    65

    Re: Impossible to install Ubuntu on HP

    Thanks a lot. I'm going to give a try but a question, do you have an AMD Processor? I've got an Intel. It's kind of "funny". I tried 8.10 and pressed install with several options but finally it starts ubuntu in text mode. But it doesn't start any installation. So I don't know if I can install the nvidia driver, I will probably try tomorrow.

  7. #7
    Join Date
    Apr 2007
    Beans
    44

    Post Re: Impossible to install Ubuntu on HP

    I've got an Intel Processor also. AMD64 is a processor extension for 64-Bit, which also works under Intel Processors... So you can use more than 3 GB Memory...

    With Ubuntu 8.10 Release Canditate it worked for me by pressing F6 at the boot screen and type acpi=ht. With this boot option he doesnt load ACPI except the multi core support...

    bye
    falstaff

  8. #8
    Join Date
    Oct 2005
    Location
    Switzerland
    Beans
    404
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: Impossible to install Ubuntu on HP

    I got acpi working on the 8530w with Ubuntu 8.10 by fiddling in the bios (Version F.04)
    Try disabling "Fan always ON on AC Power" under System Config -> Device Config in the BIOS. This seemed to make it possible for me to boot without any ACPI bootflags during boot. (suspend still doesn't work, though).

    Other people confirmed that this helps on http://www.linlap.com/wiki/HP+EliteBook+8530W

  9. #9
    Join Date
    Apr 2007
    Beans
    44

    Re: Impossible to install Ubuntu on HP

    Thanks freak42, this solution works for me!

  10. #10
    Join Date
    Nov 2008
    Beans
    77

    Re: Impossible to install Ubuntu on HP

    Quote Originally Posted by freak42 View Post
    I got acpi working on the 8530w with Ubuntu 8.10 by fiddling in the bios (Version F.04)
    Try disabling "Fan always ON on AC Power" under System Config -> Device Config in the BIOS. This seemed to make it possible for me to boot without any ACPI bootflags during boot. (suspend still doesn't work, though).

    Other people confirmed that this helps on http://www.linlap.com/wiki/HP+EliteBook+8530W
    I'm also having the same laptop.
    What are the downsides of changing that option on Bios?

    Thanks.

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •