Page 3 of 18 FirstFirst 1234513 ... LastLast
Results 21 to 30 of 172

Thread: HOW TO surf anonymous

  1. #21
    Join Date
    Apr 2005
    Location
    USA
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: HOW TO surf anonymous

    I think that there are way TOO much Tor Client.
    We need more people who provide Tor Server.

    TOr: http://tor.eff.org/

  2. #22
    Join Date
    Aug 2005
    Beans
    994

    Re: HOW TO surf anonymous

    does this make bittorrent use anonymous?

  3. #23
    Join Date
    Dec 2005
    Beans
    20

    Re: HOW TO surf anonymous

    I've used this before, and it's pretty awesome. However, I'm having problems getting it running now....

    When I start it via 'sudo /etc/init.d/tor start' and 'sudo /etc/init.d/privoxy start' it says all is well. However, trying to connect to the proxy with Firefox fails. On top of that, running an nmap on my machine shows ports 9050 and 8118 are both closed.

    I have tried killing it via the init scripts and running 'sudo killall -9 tor' and 'sudo killall -9 privoxy' and confirming that they both stopped.

    Any ideas?

  4. #24
    Join Date
    Oct 2004
    Location
    Netherlands
    Beans
    2,983
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: HOW TO surf anonymous

    duch : thnx for the howto. Please also put the links I gave you in there.

  5. #25
    Join Date
    Oct 2005
    Location
    Heart of Texas
    Beans
    1,888
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: HOW TO surf anonymous

    Quote Originally Posted by skeezer65134
    I've used this before, and it's pretty awesome. However, I'm having problems getting it running now....

    When I start it via 'sudo /etc/init.d/tor start' and 'sudo /etc/init.d/privoxy start' it says all is well. However, trying to connect to the proxy with Firefox fails. On top of that, running an nmap on my machine shows ports 9050 and 8118 are both closed.

    I have tried killing it via the init scripts and running 'sudo killall -9 tor' and 'sudo killall -9 privoxy' and confirming that they both stopped.

    Any ideas?
    Make sure you put the line for foward socks in your privoxy config, the line with the dot(.) at the end. Running nmap from a different IP on your machine should show them closed, when privoxy starts it say "listening on port 8118 for local connections only" so I think it is supposed to look like that. just try and start tor and privoxy without the /etc/init.d, Just run "tor" and "privoxy" from a terminal and see what happens

  6. #26
    Join Date
    Dec 2005
    Beans
    20

    Re: HOW TO surf anonymous

    Quote Originally Posted by Dr. Nick
    just try and start tor and privoxy without the /etc/init.d, Just run "tor" and "privoxy" from a terminal and see what happens
    Yes, I added that line, and yes I was running nmap from the same machine that I installed Tor and Privoxy on (this one).
    Code:
    #        Sample Configuration File for Privoxy
    #
    #  Copyright (C) 2001-2004 Privoxy Developers http://privoxy.org
    #
    #  $Id: config,v $
    #
    # Added for Tor support
    forward-socks4a / localhost:9050 .

    Running on their own I get this:
    Code:
    $ sudo tor
    Dec 02 08:58:49.920 [notice] Tor v0.1.0.15. This is experimental software. Do not rely on it for strong anonymity.
    Dec 02 08:58:49.977 [warn] /var/lib/tor is not owned by this UID (0). You must fix this to proceed.
    Dec 02 08:58:49.977 [err] options_act(): Couldn't access/create private data directory /var/lib/tor
    Dec 02 08:58:49.978 [err] init_from_config(): Acting on config options left us in a broken state. Dying.
    $ sudo privoxy
    Dec 02 08:59:03 Privoxy(b7d606c0) Fatal error: can't check configuration file '/{$PWD}/config':  No such file or directory
    Dec 02 08:59:03 Privoxy(b7d606c0) Fatal error: can't check configuration file '/{$PWD}/config':  No such file or directory
    $
    I filled in {$PWD}, but basically it would just look for the config file anywhere that I tried to run it from.

    Running 'ps aux' I see that they run as the following:
    Tor - /usr/sbin/tor
    Privoxy - /usr/sbin/privoxy --pidfile /var/run/privoxy.pid --user privoxy /etc/privoxy/config

    So, this is how I ran the both of them (this time, as root, and not just with sudo):
    Code:
    # /usr/sbin/tor
    Dec 02 09:09:24.772 [notice] Tor v0.1.0.15. This is experimental software. Do not rely on it for strong anonymity.
    Dec 02 09:09:24.833 [warn] /var/lib/tor is not owned by this UID (0). You must fix this to proceed.
    Dec 02 09:09:24.834 [err] options_act(): Couldn't access/create private data directory /var/lib/tor
    Dec 02 09:09:24.834 [err] init_from_config(): Acting on config options left us in a broken state. Dying.
    # /usr/sbin/privoxy --pidfile /var/run/privoxy.pid --user privoxy /etc/privoxy/config
    Dec 02 09:09:39 Privoxy(b7d786c0) Info: loading configuration file '/etc/privoxy/config':
    Dec 02 09:09:39 Privoxy(b7d786c0) Info: Privoxy version 3.0.3
    Dec 02 09:09:39 Privoxy(b7d786c0) Info: Program name: /usr/sbin/privoxy
    Dec 02 09:09:39 Privoxy(b7d786c0) Info: Listening on port 8118 for local connections only
    #
    OK, so Privoxy starts, but not Tor (which is odd because Tor was working last night). Despite it saying it's working and listenning on port 8118, nmap still shows nothing. Odd indeed. Maybe not..... when I do 'telnet localhost 8118' it logs in. Typeing "help" results in it exiting saying "HTTP/1.0 400 Invalid header received from browser". Maybe it really is running after all.

    Starting Tor from the init script (because it still fails from the command line) gives me:
    Code:
    # /etc/init.d/tor start
     * Starting tor daemon (tor)...                                                                                                                                          Dec 02 09:12:39.343 [notice] Tor v0.1.0.15. This is experimental software. Do not rely on it for strong anonymity.
                                                                                                                                                                      [ ok ]
    #
    This leads me to believe that it's running. Again, using telnet to connect works, but it exits on any command (as I guess I'd expect since I don't know what commands to use).

    So, time to fire up Firefox. Setting it to use 127.0.0.1:8118 results in it connecting to Privoxy now, but Tor is still MIA. Instead Privoxy results in a 404 error regardless of what page I try to load.

    Code:
    No such domain
    
    Your request for http://www.google.com/ could not be fulfilled, because the domain name www.google.com could not be resolved.
    
    This is often a temporary failure, so you might just try again.
    So, I'm half way there.... kinda. Still seems odd that the init script doesn't want to load it right. I'm missing something, what is it?! The Official Doc only says to add that one line to the Privoxy config and leave the rest alone, which I have done before. This was so easy to set up on Gentoo, and it should be just as easy here. Any more ideas?!
    Last edited by skeezer65134; December 2nd, 2005 at 04:23 PM.

  7. #27
    Join Date
    Dec 2005
    Beans
    20

    Re: HOW TO surf anonymous

    Gah! Now it magically workswhen running from the init scripts! What is this, Windows with it's "I work sometime, other times I don't" attitude?!

    The only extra thing I did was telnet to localhost:9050 and type 'HTTP-REQUEST' (sans the ') and I got this....
    Code:
    # telnet localhost 9050
    Trying 127.0.0.1...
    Connected to localhost.localdomain.
    Escape character is '^]'.
    HTTP-REQUEST
    HTTP/1.0 501 Tor is not an HTTP Proxy
    Content-Type: text/html; charset=iso-8859-1
    
    <html>
    <head>
    <title>Tor is not an HTTP Proxy</title>
    </head>
    <body>
    <h1>Tor is not an HTTP Proxy</h1>
    <p>
    It appears you have configured your web browser to use Tor as an HTTP Proxy.
    This is not correct: Tor provides a SOCKS proxy. Please configure your
    client accordingly.
    </p>
    <p>
    See <a href="http://tor.eff.org/documentation.html">http://tor.eff.org/documentation.html</a> for more information.
    <!-- Plus this comment, to make the body response more than 512 bytes, so IE will be willing to display it. Comment comment comment comment comment comment comment comment comment comment comment comment.-->
    </p>
    </body>
    </html>
    Connection closed by foreign host.
    This told me Tor was actually running. Fired up Firefox, and it works fine now. Sigh...... Thanks for the help I guess.

  8. #28
    Join Date
    Oct 2005
    Location
    Heart of Texas
    Beans
    1,888
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: HOW TO surf anonymous

    I see an error when tor started up about not being owned by this uid, If you go back to page one I showed how to fix that, Ive had it aswell. I will run nmap on my self and edit this post with its results

    EDIT
    Nmap didnt show either tor or privoxy open on mine yet it works
    To fix the tor uid error run
    sudo chown yourusername /var/lib/tor
    then killall tor and rerun tor
    Last edited by Dr. Nick; December 2nd, 2005 at 04:39 PM.

  9. #29
    Join Date
    Jun 2005
    Beans
    49

    Re: HOW TO surf anonymous

    Very nice how-to, Dutch, and thank you.
    Were you once of the Gentoo community?
    Cheers!
    One world
    One family of humankind
    Ubuntu

  10. #30
    Join Date
    Dec 2005
    Beans
    53

    Re: HOW TO surf anonymous

    Just wanted to say thanks for the great howto.
    Works like a charm here, well done.

Page 3 of 18 FirstFirst 1234513 ... LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •