Page 1 of 4 123 ... LastLast
Results 1 to 10 of 32

Thread: kdevelop can't compile on ubuntu 8.10

  1. #1
    Join Date
    Oct 2008
    Beans
    2

    Angry kdevelop can't compile on ubuntu 8.10

    After installing ubuntu8.10 and kdevelop3.5.3,I created a project using template "simple hello world program". Although "Run automake&friends" and "Run configure" was successfully executed, "compile file" and "buile project" generated some errors as follows:

    cd '/home/chenym/workspace/test1/debug/src' && WANT_AUTOCONF_2_5="1" WANT_AUTOMAKE_1_6="1" LC_MESSAGES="C" LC_CTYPE="C" make test1.lo
    compiling test1.cpp (g++)
    ../libtool: line 832: X--tag=CXX: command not found
    ../libtool: line 865: libtool: ignoring unknown tag : command not found
    ../libtool: line 832: X--mode=compile: command not found
    ../libtool: line 999: *** Warning: inferring the mode of operation is deprecated.: command not found
    ../libtool: line 1000: *** Future versions of Libtool will require --mode=MODE be specified.: command not found
    ../libtool: line 1143: Xg++: command not found
    ../libtool: line 1143: X-DHAVE_CONFIG_H: command not found
    ../libtool: line 1143: X-I.: command not found
    ../libtool: line 1143: X-I/home/chenym/workspace/test1/src: No such file or directory
    ../libtool: line 1143: X-I..: command not found
    ../libtool: line 1143: X-O0: command not found
    ../libtool: line 1143: X-g3: command not found
    ../libtool: line 1143: X-MT: command not found
    ../libtool: line 1143: Xtest1.lo: command not found
    ../libtool: line 1143: X-MD: command not found
    ../libtool: line 1143: X-MP: command not found
    ../libtool: line 1143: X-MF: command not found
    ../libtool: line 1143: X.deps/test1.Tpo: No such file or directory
    ../libtool: line 1143: X-c: command not found
    ../libtool: line 1195: Xtest1.lo: command not found
    ../libtool: line 1200: libtool: compile: cannot determine name of library object from `': command not found
    make: *** [test1.lo] Error 1
    *** Exited with status: 2 ***

    errors generated by "build project":
    cd '/home/chenym/workspace/test1/debug' && WANT_AUTOCONF_2_5="1" WANT_AUTOMAKE_1_6="1" LC_MESSAGES="C" LC_CTYPE="C" make
    make all-recursive
    Making all in src
    linking test1 (g++)
    ../libtool: line 832: X--tag=CXX: command not found
    ../libtool: line 865: libtool: ignoring unknown tag : command not found
    ../libtool: line 832: X--mode=link: command not found
    ../libtool: line 999: *** Warning: inferring the mode of operation is deprecated.: command not found
    ../libtool: line 1000: *** Future versions of Libtool will require --mode=MODE be specified.: command not found
    gcc-4.1: no input files
    gcc-4.1: no input files
    gcc-4.1: no input files
    gcc-4.1: no input files
    ../libtool: line 2237: X-O0: command not found
    ../libtool: line 2237: X-g3: command not found
    ../libtool: line 2406: Xtest1: command not found
    X: user not authorized to run the X server, aborting.
    ../libtool: line 2418: Xtest1: command not found
    ../libtool: line 2426: mkdir /.libs: No such file or directory
    mkdir: cannot create directory `/.libs': Permission denied
    make[2]: *** [test1] Error 1
    make[1]: *** [all-recursive] Error 1
    make: *** [all] Error 2
    *** Exited with status: 2 ***

    My environment is configured as follows:
    KDE 3.5.10
    Qt 3.3.8
    g++ 4.1
    GNU make 3.81
    perl 5.10.0
    autoconf 2.61
    automake 1.9.6
    flex 2.5.35
    libtool 2.2.2
    Berkley 4.3

    I have been puzzled for two days. I appreciate any help for this problem.

  2. #2
    Join Date
    Oct 2008
    Beans
    2

    Re: kdevelop can't compile on ubuntu 8.10

    Have you found anything out? I'm having the same problem trying to compile bzflag's mainline codebase on Intrepid beta.

  3. #3
    Join Date
    Oct 2008
    Beans
    2

    Re: kdevelop can't compile on ubuntu 8.10

    Hmm, just went to http://packages.ubuntu.com/intrepid/libtool and noticed that for Intrepid, they upgraded libtool to version 2.2.4, while Hardy used 1.5.26. I see errors all over the place involving issues with the upgrade, but not a guide yet...

  4. #4
    Join Date
    Jul 2008
    Location
    Norway
    Beans
    6
    Distro
    Ubuntu 8.04 Hardy Heron

    Re: kdevelop can't compile on ubuntu 8.10

    hmm, I have the same problem after upgrading to 8.10.

  5. #5
    Join Date
    Oct 2008
    Beans
    2

    Re: kdevelop can't compile on ubuntu 8.10

    Exactly the same for me!
    Hope there will be solutions to fix that...

  6. #6
    Join Date
    Oct 2006
    Beans
    218

    Re: kdevelop can't compile on ubuntu 8.10

    Same problem here. :S I'd really love to get this taken care of. It makes it hard to do my programming.
    Borris
    __________________________________________________ __

    "If at first it doesn't work... install, install, install again."

  7. #7
    Join Date
    Mar 2008
    Location
    South Africa
    Beans
    63
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: kdevelop can't compile on ubuntu 8.10

    Hi

    I cannot believe this ! I left Gentoo because this happened (the libtool upgrade - and the fact that I was having so much fun tweaking I got no studies done...).

    The solution mentioned to me back in Gentoo was to run

    libtoolize --copy --force

    before building each project - maybe it will work for you ?

  8. #8
    Join Date
    Jun 2005
    Location
    Heraklion
    Beans
    73

    Re: kdevelop can't compile on ubuntu 8.10

    Quote Originally Posted by keep-on-smiling View Post
    Hi

    I cannot believe this ! I left Gentoo because this happened (the libtool upgrade - and the fact that I was having so much fun tweaking I got no studies done...).

    The solution mentioned to me back in Gentoo was to run

    libtoolize --copy --force

    before building each project - maybe it will work for you ?
    You mean run it in a konsole? Obviously, I have the same problem and I solved it by downgrading libtool.
    In a world without walls and fences, who needs Windows and Gates ?

  9. #9
    Join Date
    Oct 2006
    Beans
    218

    Re: kdevelop can't compile on ubuntu 8.10

    That's what I ended up doing as well.... Kinda lame, cause now I have this pesky "You have one upgrade" all the time...
    Borris
    __________________________________________________ __

    "If at first it doesn't work... install, install, install again."

  10. #10
    Join Date
    Mar 2008
    Location
    South Africa
    Beans
    63
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: kdevelop can't compile on ubuntu 8.10

    hi grinias

    yep - as far as i remember i cd'd to the project and ran that command - as i recall, it did work, but the need to do this really irritated me - so i ended using geany in ubuntu and codeblocks in xp (yes codeblocks IS in ubuntu, but i could never get it to reload my workspace automatically, even when specifically saving it - always it did the blank workspace...)

    cheers

Page 1 of 4 123 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •