Results 1 to 10 of 10

Thread: don't autostart dropbox?

  1. #1
    Join Date
    Jun 2008
    Location
    Denmark
    Beans
    52
    Distro
    Ubuntu

    don't autostart dropbox?

    Hi all

    I've installed the Dropbox for Nautilus plugin... now whenever I boot up my computer, the dropboxd service starts too..
    How can I remove this autostart, anyone that uses it who knows?... Can't see the service in sysv-rc-conf, and neither in

    Smain
    Last edited by smain; October 7th, 2008 at 07:31 PM.

  2. #2
    Join Date
    Apr 2005
    Location
    Xpain
    Beans
    117
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: don't autostart dropbox?

    dropboxd starts with your GNOME session (in fact, when Nautilus is launched). You can find some tips on how to disable it in here:
    http://forums.getdropbox.com/topic.php?id=3575

  3. #3
    Join Date
    Oct 2008
    Beans
    15

    Re: don't autostart dropbox?

    I have the opposite problem. Suddenly, my dropbox has stopped launching at start up and I have no idea why. It worked for a few days and suddenly stopped. I am running Intrepid, 32 bit. Any way to get it to start again at startup

  4. #4
    Join Date
    Apr 2005
    Location
    Xpain
    Beans
    117
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: don't autostart dropbox?

    Quote Originally Posted by wobblyheadedjon View Post
    I have the opposite problem. Suddenly, my dropbox has stopped launching at start up and I have no idea why. It worked for a few days and suddenly stopped. I am running Intrepid, 32 bit. Any way to get it to start again at startup
    Does the tray icon show on panel?

  5. #5
    Join Date
    Oct 2008
    Beans
    15

    Re: don't autostart dropbox?

    Quote Originally Posted by infinito View Post
    Does the tray icon show on panel?
    no, and I have no idea how to manually start dropbox either...so I'm kind of up the river...

  6. #6
    Join Date
    Apr 2005
    Location
    Xpain
    Beans
    117
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: don't autostart dropbox?

    Quote Originally Posted by wobblyheadedjon View Post
    no, and I have no idea how to manually start dropbox either...so I'm kind of up the river...
    Try to reinstall the dropbox nautilus extension and to remove the dropbox daemon folder (rm -fr ~/.dropbox-dist), then quit nautilus nicely and launch it again (nautilus -q; sleep 2; nautilus) to see if it gives you any error message.

  7. #7
    Join Date
    Oct 2008
    Beans
    15

    Smile Re: don't autostart dropbox?

    Quote Originally Posted by infinito View Post
    Try to reinstall the dropbox nautilus extension and to remove the dropbox daemon folder (rm -fr ~/.dropbox-dist), then quit nautilus nicely and launch it again (nautilus -q; sleep 2; nautilus) to see if it gives you any error message.
    That seems to have taken care of my problem. At least it loaded at start this first time around. thanks a ton. Good luck on figuring out the origional problem of this thread.

  8. #8
    Join Date
    May 2008
    Beans
    9

    Re: don't autostart dropbox?

    I agree, I dislike people starting things automatically, esp if it is a connection to the internet.

    What does irritate me somewhat, is that is is apparently easier for a windows user to stop dropbox from autostarting (startup folder)... but for ubuntu... there is no easy way!!

    The current method seems to be either uninstall it or disable it after it has started up, for it hides somewhere (perhaps in the ?nautilus / ?ubuntu desktop boot up sequence).

    This seems somewhat ironical to me. I expected there to be one line to be deleted from an obscure file that would fix this problem. But little do I know.


    --------------
    Apparently:

    To stop the dropbox daemon: (won't affect the icon in tray)

    - click on tray icon: stop dropbox
    - start-stop-daemon -o -c <user> -K -x /home/<user>/.dropbox-dist/dropboxd
    - killall dropboxd


    To restart daemon:

    - click on tray icon: start dropbox
    - start-stop-daemon -b -o -c user -S -x /home/user/.dropbox-dist/dropboxd


    To automate this:
    - Ubuntu8.10Menubar ! System ! Preferences ! Sessions
    - add new startup item
    - start-stop-daemon -o -c <user> -K -x /home/<user>/.dropbox-dist/dropboxd


    [Thanks Cam: http://forums.getdropbox.com/topic.p...=2#post-30310]
    Last edited by mia.king; March 12th, 2009 at 01:11 PM.

  9. #9
    Join Date
    May 2009
    Beans
    133

    Re: don't autostart dropbox?

    any news on this topic?
    i'd rather prefer to start dropbox by myself whenever i need it....

  10. #10
    Join Date
    May 2010
    Beans
    2

    Re: don't autostart dropbox?

    Hello,

    i removed dropbox icon from system tray. How to get it back? I have tried to re-install nautilus-dropbox package without no success.

    Dropbox is working fine. Only lost one icon.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •